FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 11-11-2008, 01:48 PM
Paul Cartwright
 
Default virtualbox error

I'm trying to get virtualbox running on debian Lenny.
my system is a Dell desktop:
# uname -a
Linux paulandcilla 2.6.26-1-686 #1 SMP Thu Oct 9 15:18:09 UTC 2008 i686
GNU/Linux

I have these applications installed:
ii virtualbox-ose 1.6.6-dfsg-3
x86 virtualization solution - binaries
ii virtualbox-ose-modules-2.6.26-1-486
2.6.26+1.6.2-dfsg-4 PC virtualization solution for Linux
2.6.26 on x86
ii virtualbox-ose-modules-2.6.26-1-686
1.6.6-dfsg-3+2.6.26-8 VirtualBox modules for Linux (kernel
2.6.26-1-686)
ii virtualbox-ose-modules-2.6.26-1-xen-686
2.6.26+1.6.2-dfsg-4 PC virtualization solution for Linux
2.6.26 on i686
ii virtualbox-ose-source 1.6.6-dfsg-3
x86 virtualization solution - kernel module source

when I try to install an OS, it gets to where you start the installation and I
get this error:
The version of the VirtualBox kernel modules and the version of VirtualBox
application are not matching. You can correct this by either installing the
correct virtualbox-ose-modules package (if available) through apt-get or by
building it manually with: module-assistant auto-install virtualbox-ose.
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).


what do I need to install/remove to make this work??
--
Paul Cartwright
Registered Linux user # 367800
Registered Ubuntu User #12459


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2008, 02:17 PM
Carl Fink
 
Default virtualbox error

On Tue, Nov 11, 2008 at 09:48:40AM -0500, Paul Cartwright wrote:

> when I try to install an OS, it gets to where you start the installation and I
> get this error:
> The version of the VirtualBox kernel modules and the version of VirtualBox
> application are not matching. You can correct this by either installing the
> correct virtualbox-ose-modules package (if available) through apt-get or by
> building it manually with: module-assistant auto-install virtualbox-ose.
> VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).
>
>
> what do I need to install/remove to make this work??

Instead of just installing the debs, use the brilliant module-assistant to
compile the needed modules, as explained here:

http://debaday.debian.net/2007/12/05/virtualbox-a-virtual-pc-for-you/
--
Carl Fink nitpicking@nitpicking.com

Read my blog at blog.nitpicking.com. Reviews! Observations!
Stupid mistakes you can correct!


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2008, 03:43 PM
Paul Cartwright
 
Default virtualbox error

On Tue November 11 2008, Carl Fink wrote:
>
> Instead of just installing the debs, use the brilliant module-assistant to
> compile the needed modules, as explained here:
>
> http://debaday.debian.net/2007/12/05/virtualbox-a-virtual-pc-for-you/
> --
that would be nice if it worked.. actually, the error dialog box mentioned
doing:
# modprobe vboxdrv
# module-assistant auto-install virtualbox-ose

which I did. still didn't work

his little HOW-TO also fails:
same error message..


--
Paul Cartwright
Registered Linux user # 367800
Registered Ubuntu User #12459


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2008, 05:54 PM
"Mariusz Sielicki"
 
Default virtualbox error

2008/11/11 Paul Cartwright <ale@pcartwright.com>:
> On Tue November 11 2008, Carl Fink wrote:
>>
>> Instead of just installing the debs, use the brilliant module-assistant to
>> compile the needed modules, as explained here:
>>
>> http://debaday.debian.net/2007/12/05/virtualbox-a-virtual-pc-for-you/
>> --
> that would be nice if it worked.. actually, the error dialog box mentioned
> doing:
> # modprobe vboxdrv
> # module-assistant auto-install virtualbox-ose
>
> which I did. still didn't work
>
> his little HOW-TO also fails:
> same error message..
>

I had the same problem.
There is my solution:

aptitude install bridge-utils virtualbox-ose-source module-assistance
m-a auto-install virtualbox-ose
modprobe vboxdrv

Regards
Mariusz


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2008, 08:01 PM
Paul Cartwright
 
Default virtualbox error

On Tue November 11 2008, Mariusz Sielicki wrote:
> aptitude install bridge-utils virtualbox-ose-source module-assistance
> m-a auto-install virtualbox-ose
> modprobe vboxdrv

when I look in /usr/src here is the modules file I see:
virtualbox-ose-modules-2.6.26-1-686_1.6.6-dfsg-3+2.6.26-8_i386.deb


note the "i386" at the end..
but /var/log/dpkg.log shows this:
2008-11-11 15:55:49 status unpacked virtualbox-ose-modules-2.6.26-1-686
1.6.6-dfsg-3+2.6.26-8
2008-11-11 15:55:49 configure virtualbox-ose-modules-2.6.26-1-686
1.6.6-dfsg-3+2.6.26-8 1.6.6-dfsg-3+2.6.26-8
2008-11-11 15:55:49 status unpacked virtualbox-ose-modules-2.6.26-1-686
1.6.6-dfsg-3+2.6.26-8
2008-11-11 15:55:49 status half-configured virtualbox-ose-modules-2.6.26-1-686
1.6.6-dfsg-3+2.6.26-8
2008-11-11 15:55:49 status installed virtualbox-ose-modules-2.6.26-1-686
1.6.6-dfsg-3+2.6.26-8

kern.log has this( so does messages):
Nov 11 15:53:37 paulandcilla kernel: [23780.647203] SUP_IOCTL_COOKIE: Version
mismatch. Requested: 0x80000 Min: 0x80000 Current: 0x70002


it still doesn't work and I just don't get it.

--
Paul Cartwright
Registered Linux user # 367800
Registered Ubuntu User #12459


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 10-08-2012, 04:15 AM
Junayeed Ahnaf
 
Default Virtualbox Error

Getting this error: http://i.imgur.com/5pjLy.png


Configuration: AMD FX 6100(5 cores to vbox) , 8 GB DDR3 1067 Mhz (4GB to vbox)


Virtualbox installed from oracle repo, fedora 17 64 bit. Trying to boot arch



Junayeed Ahnaf Nirjhor




--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 10-08-2012, 04:54 AM
Ed Greshko
 
Default Virtualbox Error

On 10/08/2012 12:15 PM, Junayeed Ahnaf wrote:
> Getting this error: http://i.imgur.com/5pjLy.png
>
>
> Configuration: AMD FX 6100(5 cores to vbox) , 8 GB DDR3 1067 Mhz (4GB to vbox)
>
>
>
> Virtualbox installed from oracle repo, fedora 17 64 bit. Trying to boot arch
>

ls -l /usr/lib/virtualbox/VMMR0.r0 ?



--
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning. -- Rick Cook, The Wizardry Compiled
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 10-08-2012, 05:07 AM
Junayeed Ahnaf
 
Default Virtualbox Error

-rw-r--r--. 1 root root 6340877 Sep 13 15:10 /usr/lib/virtualbox/VMMR0.r0


Junayeed Ahnaf Nirjhor





> Date: Mon, 8 Oct 2012 12:54:17 +0800
> From: Ed.Greshko@greshko.com
> To: users@lists.fedoraproject.org
> Subject: Re: Virtualbox Error
>

>
> ls -l /usr/lib/virtualbox/VMMR0.r0 ?
>


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 10-08-2012, 05:33 AM
Ed Greshko
 
Default Virtualbox Error

On 10/08/2012 01:07 PM, Junayeed Ahnaf wrote:
> -rw-r--r--. 1 root root 6340877 Sep 13 15:10 /usr/lib/virtualbox/VMMR0.r0

OK..... Some google searching suggested an ownership problem with that file.... But, it is OK.

I've got no problems running VirtualBox-4.1-4.1.22_80657_fedora17-1.x86_64.

You may find the VBox community helpful in this case....

https://www.virtualbox.org/wiki/Community

--
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning. -- Rick Cook, The Wizardry Compiled
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 10-08-2012, 05:36 AM
Hiisi
 
Default Virtualbox Error

On 8 October 2012 09:33, Ed Greshko <Ed.Greshko@greshko.com> wrote:
> On 10/08/2012 01:07 PM, Junayeed Ahnaf wrote:
>> -rw-r--r--. 1 root root 6340877 Sep 13 15:10 /usr/lib/virtualbox/VMMR0.r0
>
> OK..... Some google searching suggested an ownership problem with that file.... But, it is OK.
>
> I've got no problems running VirtualBox-4.1-4.1.22_80657_fedora17-1.x86_64.
>
> You may find the VBox community helpful in this case....
>
> https://www.virtualbox.org/wiki/Community
>

yum reinstall virtualbox??
--
Hiisi.
Registered Linux User #487982. Be counted at: http://counter.li.org/
--
Spandex is a privilege, not a right.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 

Thread Tools




All times are GMT. The time now is 09:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org