Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   sound app issues (http://www.linux-archive.org/debian-user/188909-sound-app-issues.html)

Mark Grieveson 11-06-2008 06:17 PM

sound app issues
 
Hello. Recently some of my sound applications have stopped working
properly. I use Etch. This occurred after a recent upgrade. The two
apps that no longer work properly are volume.app, and xmms. vlc does
still give sound when I play either music or video files, as does the
Internet (using iceweasel). xmms states that it can't find the audio
device, and so does volume.app. I do have Openoffice.org installed
from debian-backports as well, though I'm assuming this wouldn't be the
cause. Any suggestions for fixing this are appreciated.

Mark


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Florian Kulzer 11-06-2008 07:32 PM

sound app issues
 
On Thu, Nov 06, 2008 at 14:17:17 -0500, Mark Grieveson wrote:
> Hello. Recently some of my sound applications have stopped working
> properly. I use Etch. This occurred after a recent upgrade. The two
> apps that no longer work properly are volume.app, and xmms. vlc does
> still give sound when I play either music or video files, as does the
> Internet (using iceweasel). xmms states that it can't find the audio
> device, and so does volume.app. I do have Openoffice.org installed
> from debian-backports as well, though I'm assuming this wouldn't be the
> cause. Any suggestions for fixing this are appreciated.

Check if you have /dev/dsp with the proper permissions:

$ ls -l /dev/dsp
crw-rw---- 1 root audio 14, 3 2008-11-06 19:41 /dev/dsp

If /dev/dsp is missing, try "modprobe snd_pcm_oss" as root. If that
improves the situation, add snd_pcm_oss to /etc/modules to have it
loaded automatically at boot time.

--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Mark Grieveson 11-07-2008 01:12 AM

sound app issues
 
On Thu, 6 Nov 2008 22:02:36 +0000 (UTC)
debian-user-digest-request@lists.debian.org wrote:

> Check if you have /dev/dsp with the proper permissions:
>
> $ ls -l /dev/dsp
> crw-rw---- 1 root audio 14, 3 2008-11-06 19:41 /dev/dsp
>
> If /dev/dsp is missing, try "modprobe snd_pcm_oss" as root. If that
> improves the situation, add snd_pcm_oss to /etc/modules to have it
> loaded automatically at boot time.


Thanks. Both volume.app and xmms now work.

Mark


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 11:01 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.