Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Using Linda (http://www.linux-archive.org/debian-user/18779-using-linda.html)

"David Schulberg" 12-13-2007 09:23 AM

Using Linda
 
Hi All,


*


Have just set up Linda or I thought I had.


When I run ‘linda package.deb’ I get errors as
follows:


*


debian:/home/david/Desktop/Downloads# linda
checkinstall_1.6.1-1_i386.deb


Linda: Running as root, dropping to nobody.


Traceback (most recent call last):


* File "/usr/bin/linda", line 101, in ?


*** main.run()


* File "/usr/bin/linda", line 59, in run


*** checker.check(file)


* File
"/var/lib/python-support/python2.4/linda/checker.py", line 28, in
check


*** self.go()


* File
"/var/lib/python-support/python2.4/linda/checker.py", line 31, in go


*** self.unpack(1)


* File "/var/lib/python-support/python2.4/linda/checker.py",
line 51, in unpack


*** self.unpacker.unpack(self.file, level)


* File
"/var/lib/python-support/python2.4/linda/unpack.py", line 21, in
unpack


*** getattr(self, 'unpack_%s_%d' % (file[-3:], level))(file)


* File "/var/lib/python-support/python2.4/linda/unpack.py",
line 31, in unpack_deb_1


*** run_external_cmd('ar x %s' % file)


* File
"/var/lib/python-support/python2.4/linda/funcs.py", line 14, in
run_external_cmd


*** raise ExtCmdException("%s exited with a status of
%d" % (command,


linda.funcs.ExtCmdException: ar x
/home/david/Desktop/Downloads/checkinstall_1.6.1-1_i386.deb exited with a
status of 256


*


What is the problem here?



Regards,

David Schulberg

Chris Lale 12-13-2007 03:16 PM

Using Linda
 
David Schulberg wrote:
> Hi All,
>
>
>
> Have just set up Linda or I thought I had.
>
> When I run 'linda package.deb' I get errors as follows:
>
>
>
> debian:/home/david/Desktop/Downloads# linda checkinstall_1.6.1-1_i386.deb
>
> Linda: Running as root, dropping to nobody.
>
> Traceback (most recent call last):
>
> File "/usr/bin/linda", line 101, in ?
>
> main.run()
[...]
> What is the problem here?
>

When you build a Debian package you end up with files like these:

package_n.n.n-n_xxx.deb
package_n.n.n.orig.tar.gz
package_n.n.n-n.diff.gz
package_n.n.n-n.dsc
package_n.n.n-n_i386.changes

I think that you are meant to run linda on the ".changes" file.

linda package_n.n.n-n_i386.changes

The Debian New Maintainers' Guide [1] has more details.

[1] http://www.us.debian.org/doc/maint-guide/

Hope that helps,

--
Chris.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

"David Schulberg" 12-13-2007 06:51 PM

Using Linda
 
Hi All,


*


Have just set up Linda or I thought I had.


When I run ‘linda package.deb’ I get errors as
follows:


*


debian:/home/david/Desktop/Downloads# linda
checkinstall_1.6.1-1_i386.deb


Linda: Running as root, dropping to nobody.


Traceback (most recent call last):


* File "/usr/bin/linda", line 101, in ?


*** main.run()


* File "/usr/bin/linda", line 59, in run


*** checker.check(file)


* File
"/var/lib/python-support/python2.4/linda/checker.py", line 28, in
check


*** self.go()


* File "/var/lib/python-support/python2.4/linda/checker.py",
line 31, in go


*** self.unpack(1)


* File
"/var/lib/python-support/python2.4/linda/checker.py", line 51, in
unpack


*** self.unpacker.unpack(self.file, level)


* File "/var/lib/python-support/python2.4/linda/unpack.py",
line 21, in unpack


*** getattr(self, 'unpack_%s_%d' %
(file[-3:], level))(file)


* File
"/var/lib/python-support/python2.4/linda/unpack.py", line 31, in
unpack_deb_1


*** run_external_cmd('ar x %s' % file)


* File "/var/lib/python-support/python2.4/linda/funcs.py",
line 14, in run_external_cmd


*** raise ExtCmdException("%s exited
with a status of %d" % (command,


linda.funcs.ExtCmdException: ar x
/home/david/Desktop/Downloads/checkinstall_1.6.1-1_i386.deb exited with a
status of 256


*


What is the problem here?


Regards,

David Schulberg

"Sergio Cullar Valds" 12-13-2007 10:03 PM

Using Linda
 
2007/12/13, David Schulberg <davids@evertech.com.au>:
> Hi All,
>
>
>
> Have just set up Linda or I thought I had.
>
> When I run 'linda package.deb' I get errors as follows:

[snip]

> What is the problem here?

Hello,

maybe you should post that question to: debian-mentors@lists.debian.org

Best regards,
Sergio Cuelalr


--
"Meine Hoffnung soll mich leiten
Durch die Tage ohne Dich
Und die Liebe soll mich tragen
Wenn der Schmerz die Hoffnung bricht"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 11:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.