Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   digital out with alsa (http://www.linux-archive.org/debian-user/182014-digital-out-alsa.html)

Alex Samad 10-25-2008 07:57 AM

digital out with alsa
 
On Sat, Oct 25, 2008 at 04:13:05PM +1100, Alex Samad wrote:
> Hi
>
> I have recently purchased a new motherboard gigabyte ga-m750sli-ds4
>
> it has a nvidia / intel sound chip set
> NVidia [HDA NVidia], device 0: ALC882 Analog [ALC882 Analog]
>
> 00:07.0 Audio device: nVidia Corporation Device 0774 (rev a1)
> Subsystem: Giga-byte Technology Device a002
> Flags: 66MHz, fast devsel, IRQ 21
> Memory at f8000000 (32-bit, non-prefetchable) [size=16K]
> Capabilities: <access denied>
> Kernel modules: snd-hda-intel
>
>
> I have tried to get the digital out working on this card, but it seems
> like there is a problem with the current kernel/deb package 2.6.26-1-amd64
>
> From what I have found (on the ubunto forums) (i am running debian :) )
> this has been fixed in 8.10 alpha 5 - which includes linux 2.6.27 (or .28).
>
> There has also been some mention that it is fixed in alsa 1.0.18rc3, we currently
> only have 1.0.17 (current stable). I have checked experimental but its not there either.
>
> Any one got any tip on who to compile up 1.0.18rc from the alsa site to work with 2.6.26-1-amd64
>
> Or any one else got a fix for this ???
>
>
> As a work around until the alsa stuff makes it into the debian repos, i found an old card
> sounds blaster audigy2 live
>
> Audigy2 [Audigy 2 Value [SB0400]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
>
> 01:07.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value
> Subsystem: Creative Labs Device 1001
> Flags: bus master, medium devsel, latency 32, IRQ 17
> I/O ports at 9400 [size=64]
> Capabilities: <access denied>
> Kernel driver in use: EMU10K1_Audigy
> Kernel modules: snd-emu10k1
>
> I have plugged in the coax and run a speaker-test with alsa, I only get sound on the left and right speakers
> i get nothing on the other speaker - base center surround.

I decided to just use it as is and it seems like all the speakers are working, the speaker-test program isn't :(

>
> I would like to have the default sounds come out the digital out, preferable with dmix, I had this before with
> /etc/asoundrc, but when I try the same thing with the sounds blaster it errors out saying there is only 2 channels.
>
>
> help
>
>
> Alex
>
>



--
"Earlier today, the Libyan government released Fathi Jahmi. She's a local government official who was imprisoned in 2002 for advocating free speech and democracy."

- George W. Bush
03/12/2004
citing Jahmi, who is a man, in a speech paying tribute to women reformers during International Women's Week, Washington, D.C.


All times are GMT. The time now is 05:09 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.