FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 09-30-2008, 11:48 AM
Rich Healey
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Peter Van Biesen wrote:
> Hi,
>
> I'm trying to setup a dom0 starting from a debian testing installation. I installed testing, then installed the 2.6.18 kernel from stable and the hypervisor from testing. After a reboot xen is now up and running. I now want to use clvm. So I install redhat-cluster-suite and clvm. This installs the kernel modules for the 2.6.26 and the 2.6.18 kernel. However, the modules for the 2.6.18 kernel are version 1.3x, while for the 2.6.26 kernel are 2.x . Needless to say, cman will not start.
>
> I then tried to compile de kernel module for my 2.6.18 kernel from source using the module-assistant. This fails on lm_interface.h, which is not in the 2.6.18 source tree.
>
> Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?
>
> Kindest regards,
>
> Peter.

Why exactly do you want to use the Etch kernel?

- --
Rich Healey - iTReign .'`. / healey.rich@gmail.com
Developer / Systems Admin : :' : / healey.rich@itreign.com
AIM: richohealey33 `. `' / richo@psych0tik.net
MSN: bitchohealey@hotmail.com `- / richohealey@hellboundhackers.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkjiEfoACgkQLeTfO4yBSAcu4wCgkrY6FSZJtJ CqEN2dquDtA+rh
pX4AoMO3MyqECH4ZlgdD4PwKXFP0zsu8
=5SIq
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-30-2008, 11:54 AM
Ferenc Wagner
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

Peter Van Biesen <peter.vanbiesen@vaph.be> writes:

> Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?

Clvm 2.02.06 is in Etch, so it surely runs on 2.6.18.
--
Feri.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-30-2008, 11:55 AM
Peter Van Biesen
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

Because you can't use a newer kernel as a xen dom0 kernel. The only working dom0 kernel ( at the moment ) is a 2.6.18 afaik.

Kindest regards,

Peter.

On Tuesday 30 September 2008 13:48:10 Rich Healey wrote:
> Peter Van Biesen wrote:
> > Hi,
> >
> > I'm trying to setup a dom0 starting from a debian testing installation. I installed testing, then installed the 2.6.18 kernel from stable and the hypervisor from testing. After a reboot xen is now up and running. I now want to use clvm. So I install redhat-cluster-suite and clvm. This installs the kernel modules for the 2.6.26 and the 2.6.18 kernel. However, the modules for the 2.6.18 kernel are version 1.3x, while for the 2.6.26 kernel are 2.x . Needless to say, cman will not start.
> >
> > I then tried to compile de kernel module for my 2.6.18 kernel from source using the module-assistant. This fails on lm_interface.h, which is not in the 2.6.18 source tree.
> >
> > Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?
> >
> > Kindest regards,
> >
> > Peter.
>
> Why exactly do you want to use the Etch kernel?
>
> --
> Rich Healey - iTReign .'`. / healey.rich@gmail.com
> Developer / Systems Admin : :' : / healey.rich@itreign.com
> AIM: richohealey33 `. `' / richo@psych0tik.net
> MSN: bitchohealey@hotmail.com `- / richohealey@hellboundhackers.org
> ?: blackhole.pca.dfn.de: Connection refused
> gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused
>
>



--
Peter Van Biesen
Sysadmin VAPH

tel: +32 (0) 2 225 85 70
fax: +32 (0) 2 225 85 88
e-mail: peter.vanbiesen@vaph.be
PGP: http://www.vaph.be/pgpkeys

Opgelet ! De domeinnaam van het Vlaams Agentschap is vanaf heden
vaph.be. Dit betekent dat u uw correspondent kan bereiken via
voornaam.naam@vaph.be. Gelieve aub dit aan te passen in uw adresboek.

DISCLAIMER
-------------------------------------------------------------------------------
De personeelsleden van het agentschap doen hun best om in e-mails
betrouwbare informatie te geven.
Toch kan niemand rechten doen gelden op basis van deze inhoud.
Als in de e-mail een stellingname voorkomt, is dat niet noodzakelijk het
standpunt van het agentschap.
Rechtsgeldige beslissingen of officiele standpunten worden alleen per
brief toegestuurd.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-30-2008, 12:12 PM
Peter Van Biesen
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

Indeed. But the kernel module is a 1.3 :

ii redhat-cluster-modules-2.6.18-6-xen-amd64 2.6.18+1.03.00-7+etch4 Redhat Cluster infrastructure modules for Linux 2.6.18 on AMD64
ii redhat-cluster-modules-2.6.26-1-amd64 2.6.26+2.20080801-3 Redhat Cluster infrastructure for Linux 2.6.26 on AMD64

clvmd refuses to start with error :
Sep 30 14:01:35 bxl086 kernel: CMAN 1.03.00 (built Jan 29 2008 20:43:36) installed
Sep 30 14:01:35 bxl086 kernel: NET: Registered protocol family 30
Sep 30 14:01:35 bxl086 kernel: DLM 1.03.00 (built Jan 29 2008 20:43:47) installed
Sep 30 14:01:35 bxl086 kernel: Lock_Harness 1.03.00 (built Jan 29 2008 20:44:16) installed
Sep 30 14:01:35 bxl086 kernel: Lock_DLM (built Jan 29 2008 20:43:52) installed
Sep 30 14:01:35 bxl086 ccsd[6367]: Starting ccsd 2.03.06:
Sep 30 14:01:35 bxl086 ccsd[6367]: Built: Aug 30 2008 17:32:14
Sep 30 14:01:35 bxl086 ccsd[6367]: Copyright (C) Red Hat, Inc. 2004-2008 All rights reserved.
Sep 30 14:01:36 bxl086 ccsd[6367]: /etc/cluster/cluster.conf (cluster name = XenCluster02, version = 1) found.
Sep 30 14:01:39 bxl086 ccsd[6367]: Initial status:: Quorate
Sep 30 14:01:40 bxl086 dlm_controld[6382]: No /sys/kernel/config/dlm, is the dlm loaded?
Sep 30 14:01:40 bxl086 gfs_controld[6384]: /proc/misc: No entry for dlm_plock found
Sep 30 14:01:40 bxl086 gfs_controld[6384]: /proc/misc: No entry for lock_dlm_plock found
Sep 30 14:01:40 bxl086 gfs_controld[6384]: Is dlm missing from kernel? No control device.
Sep 30 14:01:41 bxl086 qdiskd[6393]: <info> Quorum Daemon Initializing
Sep 30 14:01:41 bxl086 qdiskd[6393]: <crit> Initialization failed
Sep 30 14:01:47 bxl086 clvmd: Unable to create lockspace for CLVM: Invalid argument

That's the reason I'm trying to compile the 2.20080801 version of the cluster modules for 2.6.18 .

Has anybody got clvmd working with a 2.6.18 kernel ? Or is the error above due to something else ?

Kindest regards,

Peter.

On Tuesday 30 September 2008 13:54:21 Ferenc Wagner wrote:
> Peter Van Biesen <peter.vanbiesen@vaph.be> writes:
>
> > Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?
>
> Clvm 2.02.06 is in Etch, so it surely runs on 2.6.18.



--
Peter Van Biesen
Sysadmin VAPH

tel: +32 (0) 2 225 85 70
fax: +32 (0) 2 225 85 88
e-mail: peter.vanbiesen@vaph.be
PGP: http://www.vaph.be/pgpkeys

Opgelet ! De domeinnaam van het Vlaams Agentschap is vanaf heden
vaph.be. Dit betekent dat u uw correspondent kan bereiken via
voornaam.naam@vaph.be. Gelieve aub dit aan te passen in uw adresboek.

DISCLAIMER
-------------------------------------------------------------------------------
De personeelsleden van het agentschap doen hun best om in e-mails
betrouwbare informatie te geven.
Toch kan niemand rechten doen gelden op basis van deze inhoud.
Als in de e-mail een stellingname voorkomt, is dat niet noodzakelijk het
standpunt van het agentschap.
Rechtsgeldige beslissingen of officiele standpunten worden alleen per
brief toegestuurd.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-30-2008, 12:39 PM
"Mariusz Sielicki"
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

2008/9/30 Peter Van Biesen <peter.vanbiesen@vaph.be>:
> Because you can't use a newer kernel as a xen dom0 kernel. The only working dom0 kernel ( at the moment ) is a 2.6.18 afaik.


On Lenny I've got linux-image-2.6.26-1-xen-686.
Lenny will be stable just a moment, may by its time to dist-upgrade ?



>
> Kindest regards,
>
> Peter.
>
> On Tuesday 30 September 2008 13:48:10 Rich Healey wrote:
>> Peter Van Biesen wrote:
>> > Hi,
>> >
>> > I'm trying to setup a dom0 starting from a debian testing installation. I installed testing, then installed the 2.6.18 kernel from stable and the hypervisor from testing. After a reboot xen is now up and running. I now want to use clvm. So I install redhat-cluster-suite and clvm. This installs the kernel modules for the 2.6.26 and the 2.6.18 kernel. However, the modules for the 2.6.18 kernel are version 1.3x, while for the 2.6.26 kernel are 2.x . Needless to say, cman will not start.
>> >
>> > I then tried to compile de kernel module for my 2.6.18 kernel from source using the module-assistant. This fails on lm_interface.h, which is not in the 2.6.18 source tree.
>> >
>> > Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?
>> >
>> > Kindest regards,
>> >
>> > Peter.
>>
>> Why exactly do you want to use the Etch kernel?
>>
>> --
>> Rich Healey - iTReign .'`. / healey.rich@gmail.com
>> Developer / Systems Admin : :' : / healey.rich@itreign.com
>> AIM: richohealey33 `. `' / richo@psych0tik.net
>> MSN: bitchohealey@hotmail.com `- / richohealey@hellboundhackers.org
>> ?: blackhole.pca.dfn.de: Connection refused
>> gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused
>>
>>
>
>
>
> --
> Peter Van Biesen
> Sysadmin VAPH
>
> tel: +32 (0) 2 225 85 70
> fax: +32 (0) 2 225 85 88
> e-mail: peter.vanbiesen@vaph.be
> PGP: http://www.vaph.be/pgpkeys
>
> Opgelet ! De domeinnaam van het Vlaams Agentschap is vanaf heden
> vaph.be. Dit betekent dat u uw correspondent kan bereiken via
> voornaam.naam@vaph.be. Gelieve aub dit aan te passen in uw adresboek.
>
> DISCLAIMER
> -------------------------------------------------------------------------------
> De personeelsleden van het agentschap doen hun best om in e-mails
> betrouwbare informatie te geven.
> Toch kan niemand rechten doen gelden op basis van deze inhoud.
> Als in de e-mail een stellingname voorkomt, is dat niet noodzakelijk het
> standpunt van het agentschap.
> Rechtsgeldige beslissingen of officiele standpunten worden alleen per
> brief toegestuurd.
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
>
>

Best regards.
Mariusz Sielicki


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-30-2008, 12:57 PM
Peter Van Biesen
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

The linux-image-2.6.26-1-xen-686 only works as a domu, not a dom0. For a dom0 you still need a 2.6.18 kernel.

Or are you running a 2.6.26 kernel as a dom0 ? - in which case I'm very interested !

All my non-xen machines are dist-upgraded. I suspect the 2.6.18 kernel to remain in the repository until a newer dom0 kernel becomes available.

Kindest regards,

Peter.

On Tuesday 30 September 2008 14:39:32 Mariusz Sielicki wrote:
> 2008/9/30 Peter Van Biesen <peter.vanbiesen@vaph.be>:
> > Because you can't use a newer kernel as a xen dom0 kernel. The only working dom0 kernel ( at the moment ) is a 2.6.18 afaik.
>
>
> On Lenny I've got linux-image-2.6.26-1-xen-686.
> Lenny will be stable just a moment, may by its time to dist-upgrade ?
>
>
>
> >
> > Kindest regards,
> >
> > Peter.
> >
> > On Tuesday 30 September 2008 13:48:10 Rich Healey wrote:
> >> Peter Van Biesen wrote:
> >> > Hi,
> >> >
> >> > I'm trying to setup a dom0 starting from a debian testing installation. I installed testing, then installed the 2.6.18 kernel from stable and the hypervisor from testing. After a reboot xen is now up and running. I now want to use clvm. So I install redhat-cluster-suite and clvm. This installs the kernel modules for the 2.6.26 and the 2.6.18 kernel. However, the modules for the 2.6.18 kernel are version 1.3x, while for the 2.6.26 kernel are 2.x . Needless to say, cman will not start.
> >> >
> >> > I then tried to compile de kernel module for my 2.6.18 kernel from source using the module-assistant. This fails on lm_interface.h, which is not in the 2.6.18 source tree.
> >> >
> >> > Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?
> >> >
> >> > Kindest regards,
> >> >
> >> > Peter.
> >>
> >> Why exactly do you want to use the Etch kernel?
> >>
> >> --
> >> Rich Healey - iTReign .'`. / healey.rich@gmail.com
> >> Developer / Systems Admin : :' : / healey.rich@itreign.com
> >> AIM: richohealey33 `. `' / richo@psych0tik.net
> >> MSN: bitchohealey@hotmail.com `- / richohealey@hellboundhackers.org
> >> ?: blackhole.pca.dfn.de: Connection refused
> >> gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused
> >>
> >>
> >
> >
> >
> > --
> > Peter Van Biesen
> > Sysadmin VAPH
> >
> > tel: +32 (0) 2 225 85 70
> > fax: +32 (0) 2 225 85 88
> > e-mail: peter.vanbiesen@vaph.be
> > PGP: http://www.vaph.be/pgpkeys
> >
> > Opgelet ! De domeinnaam van het Vlaams Agentschap is vanaf heden
> > vaph.be. Dit betekent dat u uw correspondent kan bereiken via
> > voornaam.naam@vaph.be. Gelieve aub dit aan te passen in uw adresboek.
> >
> > DISCLAIMER
> > -------------------------------------------------------------------------------
> > De personeelsleden van het agentschap doen hun best om in e-mails
> > betrouwbare informatie te geven.
> > Toch kan niemand rechten doen gelden op basis van deze inhoud.
> > Als in de e-mail een stellingname voorkomt, is dat niet noodzakelijk het
> > standpunt van het agentschap.
> > Rechtsgeldige beslissingen of officiele standpunten worden alleen per
> > brief toegestuurd.
> >
> >
> > --
> > To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> > with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> >
> >
>
> Best regards.
> Mariusz Sielicki
>
>



--
Peter Van Biesen
Sysadmin VAPH

tel: +32 (0) 2 225 85 70
fax: +32 (0) 2 225 85 88
e-mail: peter.vanbiesen@vaph.be
PGP: http://www.vaph.be/pgpkeys

Opgelet ! De domeinnaam van het Vlaams Agentschap is vanaf heden
vaph.be. Dit betekent dat u uw correspondent kan bereiken via
voornaam.naam@vaph.be. Gelieve aub dit aan te passen in uw adresboek.

DISCLAIMER
-------------------------------------------------------------------------------
De personeelsleden van het agentschap doen hun best om in e-mails
betrouwbare informatie te geven.
Toch kan niemand rechten doen gelden op basis van deze inhoud.
Als in de e-mail een stellingname voorkomt, is dat niet noodzakelijk het
standpunt van het agentschap.
Rechtsgeldige beslissingen of officiele standpunten worden alleen per
brief toegestuurd.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-30-2008, 01:03 PM
"Mariusz Sielicki"
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

2008/9/30 Peter Van Biesen <peter.vanbiesen@vaph.be>:
> The linux-image-2.6.26-1-xen-686 only works as a domu, not a dom0. For a dom0 you still need a 2.6.18 kernel.
>
> Or are you running a 2.6.26 kernel as a dom0 ? - in which case I'm very interested !

You have right. After I've posted my message I check debian version. I
have dom0 on Etch (2.6.18 kernel).
Sorry for my mistake.

Lenny with linux-image-2.6.26-1-xen-686 kernel not starting.

>
> All my non-xen machines are dist-upgraded. I suspect the 2.6.18 kernel to remain in the repository until a newer dom0 kernel becomes available.
>
> Kindest regards,
>
> Peter.
>
> On Tuesday 30 September 2008 14:39:32 Mariusz Sielicki wrote:
>> 2008/9/30 Peter Van Biesen <peter.vanbiesen@vaph.be>:
>> > Because you can't use a newer kernel as a xen dom0 kernel. The only working dom0 kernel ( at the moment ) is a 2.6.18 afaik.
>>
>>
>> On Lenny I've got linux-image-2.6.26-1-xen-686.
>> Lenny will be stable just a moment, may by its time to dist-upgrade ?
>>
>>
>>
>> >
>> > Kindest regards,
>> >
>> > Peter.
>> >
>> > On Tuesday 30 September 2008 13:48:10 Rich Healey wrote:
>> >> Peter Van Biesen wrote:
>> >> > Hi,
>> >> >
>> >> > I'm trying to setup a dom0 starting from a debian testing installation. I installed testing, then installed the 2.6.18 kernel from stable and the hypervisor from testing. After a reboot xen is now up and running. I now want to use clvm. So I install redhat-cluster-suite and clvm. This installs the kernel modules for the 2.6.26 and the 2.6.18 kernel. However, the modules for the 2.6.18 kernel are version 1.3x, while for the 2.6.26 kernel are 2.x . Needless to say, cman will not start.
>> >> >
>> >> > I then tried to compile de kernel module for my 2.6.18 kernel from source using the module-assistant. This fails on lm_interface.h, which is not in the 2.6.18 source tree.
>> >> >
>> >> > Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?
>> >> >
>> >> > Kindest regards,
>> >> >
>> >> > Peter.
>> >>
>> >> Why exactly do you want to use the Etch kernel?
>> >>
>> >> --
>> >> Rich Healey - iTReign .'`. / healey.rich@gmail.com
>> >> Developer / Systems Admin : :' : / healey.rich@itreign.com
>> >> AIM: richohealey33 `. `' / richo@psych0tik.net
>> >> MSN: bitchohealey@hotmail.com `- / richohealey@hellboundhackers.org
>> >> ?: blackhole.pca.dfn.de: Connection refused
>> >> gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused
>> >>
>> >>
>> >
>> >
>> >
>> > --
>> > Peter Van Biesen
>> > Sysadmin VAPH
>> >
>> > tel: +32 (0) 2 225 85 70
>> > fax: +32 (0) 2 225 85 88
>> > e-mail: peter.vanbiesen@vaph.be
>> > PGP: http://www.vaph.be/pgpkeys
>> >
>> > Opgelet ! De domeinnaam van het Vlaams Agentschap is vanaf heden
>> > vaph.be. Dit betekent dat u uw correspondent kan bereiken via
>> > voornaam.naam@vaph.be. Gelieve aub dit aan te passen in uw adresboek.
>> >
>> > DISCLAIMER
>> > -------------------------------------------------------------------------------
>> > De personeelsleden van het agentschap doen hun best om in e-mails
>> > betrouwbare informatie te geven.
>> > Toch kan niemand rechten doen gelden op basis van deze inhoud.
>> > Als in de e-mail een stellingname voorkomt, is dat niet noodzakelijk het
>> > standpunt van het agentschap.
>> > Rechtsgeldige beslissingen of officiele standpunten worden alleen per
>> > brief toegestuurd.
>> >
>> >
>> > --
>> > To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
>> > with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
>> >
>> >
>>
>> Best regards.
>> Mariusz Sielicki
>>
>>
>
>
>
> --
> Peter Van Biesen
> Sysadmin VAPH
>
> tel: +32 (0) 2 225 85 70
> fax: +32 (0) 2 225 85 88
> e-mail: peter.vanbiesen@vaph.be
> PGP: http://www.vaph.be/pgpkeys
>
> Opgelet ! De domeinnaam van het Vlaams Agentschap is vanaf heden
> vaph.be. Dit betekent dat u uw correspondent kan bereiken via
> voornaam.naam@vaph.be. Gelieve aub dit aan te passen in uw adresboek.
>
> DISCLAIMER
> -------------------------------------------------------------------------------
> De personeelsleden van het agentschap doen hun best om in e-mails
> betrouwbare informatie te geven.
> Toch kan niemand rechten doen gelden op basis van deze inhoud.
> Als in de e-mail een stellingname voorkomt, is dat niet noodzakelijk het
> standpunt van het agentschap.
> Rechtsgeldige beslissingen of officiele standpunten worden alleen per
> brief toegestuurd.
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 10-01-2008, 01:16 AM
Rich Healey
 
Default Debian testing + xen 3.2.1 + dom0 kernel 2.6.18 + clvm 2.x -> impossible ?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Peter Van Biesen wrote:
> Because you can't use a newer kernel as a xen dom0 kernel. The only working dom0 kernel ( at the moment ) is a 2.6.18 afaik.
>
> Kindest regards,
>
> Peter.
>
> On Tuesday 30 September 2008 13:48:10 Rich Healey wrote:
>> Peter Van Biesen wrote:
>>> Hi,
>>>
>>> I'm trying to setup a dom0 starting from a debian testing installation. I installed testing, then installed the 2.6.18 kernel from stable and the hypervisor from testing. After a reboot xen is now up and running. I now want to use clvm. So I install redhat-cluster-suite and clvm. This installs the kernel modules for the 2.6.26 and the 2.6.18 kernel. However, the modules for the 2.6.18 kernel are version 1.3x, while for the 2.6.26 kernel are 2.x . Needless to say, cman will not start.
>>>
>>> I then tried to compile de kernel module for my 2.6.18 kernel from source using the module-assistant. This fails on lm_interface.h, which is not in the 2.6.18 source tree.
>>>
>>> Is it really impossible to run clvm 2.x on a dom0 ? Or am i missing something ? Has anybody used clvm with xen ?
>>>
>>> Kindest regards,
>>>
>>> Peter.
>> Why exactly do you want to use the Etch kernel?

I see, apologies for the blunt reply.

Rich

- --
Rich Healey - iTReign .'`. / healey.rich@gmail.com
Developer / Systems Admin : :' : / healey.rich@itreign.com
AIM: richohealey33 `. `' / richo@psych0tik.net
MSN: bitchohealey@hotmail.com `- / richohealey@hellboundhackers.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkjiz2QACgkQLeTfO4yBSAe+owCfYmXRAiEngA 5uYjr/S5j5fh2c
mcYAoLMeSM/smM9u0rVt2HMm9oEqClEf
=CW57
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 09:16 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org