FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 09-27-2008, 01:46 PM
Bogdan
 
Default run superkaramba apps on debian sid

Hello,

I cannot run any superkaramba theme on my *debian sid* with KDE 4.1. It
says there are some components missing:


"SuperKaramba cannot continue to run this theme.One or more of the
required components of the Kross scripting architecture is not
installed. Please consult this theme's documentation and install the
necessary Kross components."



Here some konsole output for the paddock theme:

superkaramba(5308) Karamba::Karamba: "/home/bogdan/.superkaramba/paddock.rc"
superkaramba(5308) ThemesDlg::addThemeToList: addThemeToList() file:
"/home/bogdan/download/paddock.theme"
superkaramba(5308) Karamba::startKaramba: Loading script module:
"paddock.py"




I think my problem is that I don't have "*kdelibs4-dev*" installed, but
whenever I try to install it i get this:



#apt-get install kdelibs-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting kdelibs4-dev instead of kdelibs-dev
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdelibs4-dev: Depends: libarts1-dev (>= 1.5.0) but it is not going to
be installed

Depends: libasound2-dev but it is not going to be installed
E: Broken packages


I just installed *kdelibs5-dev* but the problem won't go away.
Does any of you guys know a workaround for this? Or should I just be
patient?


Thanks,
Bogdan


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-27-2008, 02:31 PM
Vadim Rootckovsky
 
Default run superkaramba apps on debian sid

Hi!
In KDE 4.1 Plasma "emulates" SuperKaramba, that's why some themes
and apps won't work. Use plasmoids or Plasma themes

kdelibs4-dev needs Arts (libarts1-dev), but in KDE 4 Arts is replaced by
Phonon, so what you really need is kdelibs5-dev.
Be patient =)


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-27-2008, 05:33 PM
Bogdan
 
Default run superkaramba apps on debian sid

Vadim Rootckovsky wrote:

Hi!
In KDE 4.1 Plasma "emulates" SuperKaramba, that's why some themes
and apps won't work. Use plasmoids or Plasma themes


kdelibs4-dev needs Arts (libarts1-dev), but in KDE 4 Arts is replaced by
Phonon, so what you really need is kdelibs5-dev.
Be patient =)






Hello,

Thanks for your answer. I guess patience is all I'm left with . I
tried installing a plasmoid by compiling it but I'm still not lucky:


CMake Error at
/usr/share/kde4/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:53
(MESSAGE):
Could not find REQUIRED package Plasma
Call Stack (most recent call first):
/usr/share/kde4/apps/cmake/modules/FindPlasma.cmake:30
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:9 (find_package)

Weird, since "which plasma" gives me:
/usr/bin/plasma

What I have installed is this:

#dpkg -l | grep kdelibs
ii kdelibs-bin 4:4.1.1-1
executables for all KDE 4 core applications
ii kdelibs-data 4:3.5.9.dfsg.1-6
core shared data for all KDE applications
ii kdelibs4c2a 4:3.5.9.dfsg.1-6
core libraries and binaries for all KDE applications
ii kdelibs5 4:4.1.1-1
core libraries for all KDE 4 applications
ii kdelibs5-data 4:4.1.1-1
core shared data for all KDE 4 applications
ii kdelibs5-dev 4:4.1.1-1
development files for the KDE 4 core libraries

#dpkg -l | grep plasma
ii kdebase-plasma 4:4.1.1-1
plasma widgets from the KDE 4 base applications module.
ii kdeplasma-addons 4:4.1.0-1
plasmoids for KDE 4 Plasma - main package
ii kdeplasma-addons-data 4:4.1.0-1
plasmoids for KDE 4 Plasma - data files
ii kdeplasma-addons-libs4 4:4.1.0-1
plasmoids for KDE 4 Plasma - public libraries
ii libplasma2 4:4.1.1-2
library for the KDE 4 Plasma desktop



But since I'm on testing, I think it's fair enough not to complain to
much .



Cheers,

--
ing. Bogdan MARIAN
Timisoara, ROMANIA
E-mail: bogdan.dumitru.marian@gmail.com
E-mail: mendingo84@gmail.com


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 09-27-2008, 06:02 PM
Vadim Rootckovsky
 
Default run superkaramba apps on debian sid

On 27 September 2008 20:33:48 Bogdan wrote:

> I tried installing a plasmoid by compiling it but I'm still not lucky:
Try installing kdebase-workspace-dev - this might help. But it didn't
actually work for me =)
Compiled plasmoids in .deb worked fine, but when I try to compile it from
source, I get an error:
---------------------------------------------
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1054
(message):
Qt compiled without support for -fvisibility=hidden. This will break
plugins and linking of some applications. Please fix your Qt installation.
---------------------------------------------

Googling was not successful (maybe my fault?), but I found some version of
kde-workspace-dev for Fedora, but nothing for Debian. Please, show me the way
to compile new fancy plasmoids
As Plasma is still in heavy development, maybe it's worth compiling it from
svn?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 01:49 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org