FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-27-2008, 11:16 PM
Marc Shapiro
 
Default Printing from GIMP

Thomas Preud'homme wrote:

Le dimanche 27 juillet 2008, Marc Shapiro a écrit :


I recently purchased a new printer and drivers were not available for
it in Etch, which I am running. Gutenprint 5.0.2 has the necessary
drivers and I compiled it from source and the printer works great.
My problem is that there are no 'Print' options on the GIMP menus. I

am running the version of GIMP from the Debian Etch repository. How
do I get Debian's GIMP to recognize the compiled from source
gutenprint 5.0.2 and allow me to print directly from GIMP.

--
Marc Shapiro
mshapiro_42@yahoo.com



Silly question but to you have gimp-print installed ?

Gutenprint is what used to be called gimp-print. So, yes, I have
gutenprint 5.0.2 installed from sources. No, I do not have the Debian
package 'gimp-print' (which is gutenprint 5.0.0) installed. I needed
the newer version to get the drivers for my printer. I just checked in
Lenny and Sid. Both have the gutenprint-doc package for gimp-print
5.0.2, but neither of them actually have the gimp-print 5.0.2 package.
So I have no choice but to compile from sources, which seems to leave me
without the print option on the menus.


Any help will be appreciated.

--
Marc Shapiro
mshapiro_42@yahoo.com




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-27-2008, 11:21 PM
Thomas Preud'homme
 
Default Printing from GIMP

Le lundi 28 juillet 2008, Marc Shapiro a écrit*:
> Thomas Preud'homme wrote:
> > Le dimanche 27 juillet 2008, Marc Shapiro a écrit :
> >> I recently purchased a new printer and drivers were not available
> >> for it in Etch, which I am running. Gutenprint 5.0.2 has the
> >> necessary drivers and I compiled it from source and the printer
> >> works great. My problem is that there are no 'Print' options on
> >> the GIMP menus. I am running the version of GIMP from the Debian
> >> Etch repository. How do I get Debian's GIMP to recognize the
> >> compiled from source gutenprint 5.0.2 and allow me to print
> >> directly from GIMP.
> >>
> >> --
> >> Marc Shapiro
> >> mshapiro_42@yahoo.com
> >
> > Silly question but to you have gimp-print installed ?
>
> Gutenprint is what used to be called gimp-print. So, yes, I have
> gutenprint 5.0.2 installed from sources. No, I do not have the
> Debian package 'gimp-print' (which is gutenprint 5.0.0) installed. I
> needed the newer version to get the drivers for my printer. I just
> checked in Lenny and Sid. Both have the gutenprint-doc package for
> gimp-print 5.0.2, but neither of them actually have the gimp-print
> 5.0.2 package. So I have no choice but to compile from sources, which
> seems to leave me without the print option on the menus.

gimp-print is marked as conflict in sid/testing version of gimp so I
think gimp now provides gimp-print. Maybe you could try backporting
gimp from testing.

>
> Any help will be appreciated.

No other idea for the moment but hey, it's late.

>
> --
> Marc Shapiro
> mshapiro_42@yahoo.com



--
Thomas Preud'homme

Why Debian : http://www.debian.org/intro/why_debian
 
Old 07-28-2008, 12:54 AM
Marc Shapiro
 
Default Printing from GIMP

Thomas Preud'homme wrote:

Le lundi 28 juillet 2008, Marc Shapiro a écrit :


Thomas Preud'homme wrote:


Le dimanche 27 juillet 2008, Marc Shapiro a écrit :


I recently purchased a new printer and drivers were not available
for it in Etch, which I am running. Gutenprint 5.0.2 has the
necessary drivers and I compiled it from source and the printer
works great. My problem is that there are no 'Print' options on
the GIMP menus. I am running the version of GIMP from the Debian
Etch repository. How do I get Debian's GIMP to recognize the
compiled from source gutenprint 5.0.2 and allow me to print
directly from GIMP.

--
Marc Shapiro
mshapiro_42@yahoo.com


Silly question but to you have gimp-print installed ?


Gutenprint is what used to be called gimp-print. So, yes, I have
gutenprint 5.0.2 installed from sources. No, I do not have the
Debian package 'gimp-print' (which is gutenprint 5.0.0) installed. I
needed the newer version to get the drivers for my printer. I just
checked in Lenny and Sid. Both have the gutenprint-doc package for
gimp-print 5.0.2, but neither of them actually have the gimp-print
5.0.2 package. So I have no choice but to compile from sources, which
seems to leave me without the print option on the menus.



gimp-print is marked as conflict in sid/testing version of gimp so I
think gimp now provides gimp-print. Maybe you could try backporting
gimp from testing.




Any help will be appreciated.



No other idea for the moment but hey, it's late.

On further searching, I see that, starting with Lenny, there is a
'gimp-gutenprint' package which is the gutenprint 5.0.2 package. So if
I hang in there until Lenny goes stable, I can use the Debian package
for gimp and gimp-gutenprint. That might get my menu options back.


--
Marc Shapiro
mshapiro_42@yahoo.com




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-28-2008, 03:49 PM
Andrew Sackville-West
 
Default Printing from GIMP

On Sun, Jul 27, 2008 at 01:43:11PM -0700, Marc Shapiro wrote:
> I recently purchased a new printer and drivers were not available for it
> in Etch, which I am running. Gutenprint 5.0.2 has the necessary drivers
> and I compiled it from source and the printer works great. My problem
> is that there are no 'Print' options on the GIMP menus. I am running
> the version of GIMP from the Debian Etch repository. How do I get
> Debian's GIMP to recognize the compiled from source gutenprint 5.0.2 and
> allow me to print directly from GIMP.

where does that compile install the gutenprint binaries? It's possibly
in a different location than gimp expects thus it's not found. It may
be as simple as linking to the location gimp expects? That's just a
random guess.

A
 
Old 07-29-2008, 08:35 AM
Marc Shapiro
 
Default Printing from GIMP

Andrew Sackville-West wrote:

On Sun, Jul 27, 2008 at 01:43:11PM -0700, Marc Shapiro wrote:

I recently purchased a new printer and drivers were not available for it
in Etch, which I am running. Gutenprint 5.0.2 has the necessary drivers
and I compiled it from source and the printer works great. My problem
is that there are no 'Print' options on the GIMP menus. I am running
the version of GIMP from the Debian Etch repository. How do I get
Debian's GIMP to recognize the compiled from source gutenprint 5.0.2 and
allow me to print directly from GIMP.



where does that compile install the gutenprint binaries? It's possibly
in a different location than gimp expects thus it's not found. It may
be as simple as linking to the location gimp expects? That's just a
random guess.

A

If you mean all of the libs, they are in /usr/local/lib/. I tried
making a link to each of them from /usr/lib, but that didn't help. Does
anyone know where the Debian version of gimp 2.2 puts its various files?


--
Marc Shapiro
mshapiro_42@yahoo.com




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-29-2008, 09:11 AM
"Thomas Preud'homme"
 
Default Printing from GIMP

The Tuesday 29 July 2008 10:35:17 Marc Shapiro, you wrote*:
> Andrew Sackville-West wrote:
> > On Sun, Jul 27, 2008 at 01:43:11PM -0700, Marc Shapiro wrote:
> >> I recently purchased a new printer and drivers were not available for it
> >> in Etch, which I am running. Gutenprint 5.0.2 has the necessary drivers
> >> and I compiled it from source and the printer works great. My problem
> >> is that there are no 'Print' options on the GIMP menus. I am running
> >> the version of GIMP from the Debian Etch repository. How do I get
> >> Debian's GIMP to recognize the compiled from source gutenprint 5.0.2 and
> >> allow me to print directly from GIMP.
> >
> > where does that compile install the gutenprint binaries? It's possibly
> > in a different location than gimp expects thus it's not found. It may
> > be as simple as linking to the location gimp expects? That's just a
> > random guess.
> >
> > A
>
> If you mean all of the libs, they are in /usr/local/lib/. I tried
> making a link to each of them from /usr/lib, but that didn't help. Does
> anyone know where the Debian version of gimp 2.2 puts its various files?

See the attached files (plain text UTF-8 with Unix end lines) for dpkg -L of
gimp and gimp-gutenprint on Debian sid

>
> --
> Marc Shapiro
> mshapiro_42@yahoo.com





--
Thomas Preud'homme

Why debian : http://www.debian.org/intro/why_debian
/.
/usr
/usr/lib
/usr/lib/gimp
/usr/lib/gimp/2.0
/usr/lib/gimp/2.0/plug-ins
/usr/lib/gimp/2.0/plug-ins/nova
/usr/lib/gimp/2.0/plug-ins/plasma
/usr/lib/gimp/2.0/plug-ins/gee
/usr/lib/gimp/2.0/plug-ins/sharpen
/usr/lib/gimp/2.0/plug-ins/imagemap
/usr/lib/gimp/2.0/plug-ins/bmp
/usr/lib/gimp/2.0/plug-ins/compressor
/usr/lib/gimp/2.0/plug-ins/pix
/usr/lib/gimp/2.0/plug-ins/gih
/usr/lib/gimp/2.0/plug-ins/tiff-load
/usr/lib/gimp/2.0/plug-ins/neon
/usr/lib/gimp/2.0/plug-ins/psp
/usr/lib/gimp/2.0/plug-ins/cubism
/usr/lib/gimp/2.0/plug-ins/engrave
/usr/lib/gimp/2.0/plug-ins/struc
/usr/lib/gimp/2.0/plug-ins/laplace
/usr/lib/gimp/2.0/plug-ins/colormap-remap
/usr/lib/gimp/2.0/plug-ins/gif-save
/usr/lib/gimp/2.0/plug-ins/align_layers
/usr/lib/gimp/2.0/plug-ins/rotate
/usr/lib/gimp/2.0/plug-ins/screenshot
/usr/lib/gimp/2.0/plug-ins/smooth_palette
/usr/lib/gimp/2.0/plug-ins/postscript
/usr/lib/gimp/2.0/plug-ins/channel_mixer
/usr/lib/gimp/2.0/plug-ins/edge
/usr/lib/gimp/2.0/plug-ins/colortoalpha
/usr/lib/gimp/2.0/plug-ins/gbr
/usr/lib/gimp/2.0/plug-ins/AlienMap2
/usr/lib/gimp/2.0/plug-ins/psd-save
/usr/lib/gimp/2.0/plug-ins/pnm
/usr/lib/gimp/2.0/plug-ins/animationplay
/usr/lib/gimp/2.0/plug-ins/zealouscrop
/usr/lib/gimp/2.0/plug-ins/color_enhance
/usr/lib/gimp/2.0/plug-ins/fits
/usr/lib/gimp/2.0/plug-ins/gtm
/usr/lib/gimp/2.0/plug-ins/displace
/usr/lib/gimp/2.0/plug-ins/papertile
/usr/lib/gimp/2.0/plug-ins/c_astretch
/usr/lib/gimp/2.0/plug-ins/animoptimize
/usr/lib/gimp/2.0/plug-ins/destripe
/usr/lib/gimp/2.0/plug-ins/diffraction
/usr/lib/gimp/2.0/plug-ins/helpbrowser
/usr/lib/gimp/2.0/plug-ins/glob
/usr/lib/gimp/2.0/plug-ins/gflare
/usr/lib/gimp/2.0/plug-ins/oilify
/usr/lib/gimp/2.0/plug-ins/gee_zoom
/usr/lib/gimp/2.0/plug-ins/apply_lens
/usr/lib/gimp/2.0/plug-ins/png
/usr/lib/gimp/2.0/plug-ins/autocrop
/usr/lib/gimp/2.0/plug-ins/header
/usr/lib/gimp/2.0/plug-ins/softglow
/usr/lib/gimp/2.0/plug-ins/antialias
/usr/lib/gimp/2.0/plug-ins/autostretch_hsv
/usr/lib/gimp/2.0/plug-ins/print
/usr/lib/gimp/2.0/plug-ins/redeye
/usr/lib/gimp/2.0/plug-ins/lic
/usr/lib/gimp/2.0/plug-ins/pixelize
/usr/lib/gimp/2.0/plug-ins/uniteditor
/usr/lib/gimp/2.0/plug-ins/tiler
/usr/lib/gimp/2.0/plug-ins/lcms
/usr/lib/gimp/2.0/plug-ins/jpeg
/usr/lib/gimp/2.0/plug-ins/tiff-save
/usr/lib/gimp/2.0/plug-ins/warp
/usr/lib/gimp/2.0/plug-ins/threshold_alpha
/usr/lib/gimp/2.0/plug-ins/sample_colorize
/usr/lib/gimp/2.0/plug-ins/polar
/usr/lib/gimp/2.0/plug-ins/vinvert
/usr/lib/gimp/2.0/plug-ins/cartoon
/usr/lib/gimp/2.0/plug-ins/checkerboard
/usr/lib/gimp/2.0/plug-ins/tile
/usr/lib/gimp/2.0/plug-ins/script-fu
/usr/lib/gimp/2.0/plug-ins/ripple
/usr/lib/gimp/2.0/plug-ins/flarefx
/usr/lib/gimp/2.0/plug-ins/exchange
/usr/lib/gimp/2.0/plug-ins/fp
/usr/lib/gimp/2.0/plug-ins/flame
/usr/lib/gimp/2.0/plug-ins/randomize
/usr/lib/gimp/2.0/plug-ins/CML_explorer
/usr/lib/gimp/2.0/plug-ins/xjt
/usr/lib/gimp/2.0/plug-ins/sgi
/usr/lib/gimp/2.0/plug-ins/procedure-browser
/usr/lib/gimp/2.0/plug-ins/mblur
/usr/lib/gimp/2.0/plug-ins/gradmap
/usr/lib/gimp/2.0/plug-ins/deinterlace
/usr/lib/gimp/2.0/plug-ins/fractaltrace
/usr/lib/gimp/2.0/plug-ins/gqbist
/usr/lib/gimp/2.0/plug-ins/xwd
/usr/lib/gimp/2.0/plug-ins/retinex
/usr/lib/gimp/2.0/plug-ins/mosaic
/usr/lib/gimp/2.0/plug-ins/glasstile
/usr/lib/gimp/2.0/plug-ins/ccanalyze
/usr/lib/gimp/2.0/plug-ins/rcm
/usr/lib/gimp/2.0/plug-ins/blinds
/usr/lib/gimp/2.0/plug-ins/compose
/usr/lib/gimp/2.0/plug-ins/scatter_hsv
/usr/lib/gimp/2.0/plug-ins/bumpmap
/usr/lib/gimp/2.0/plug-ins/borderaverage
/usr/lib/gimp/2.0/plug-ins/maze
/usr/lib/gimp/2.0/plug-ins/film
/usr/lib/gimp/2.0/plug-ins/nlfilt
/usr/lib/gimp/2.0/plug-ins/vpropagate
/usr/lib/gimp/2.0/plug-ins/pagecurl
/usr/lib/gimp/2.0/plug-ins/spheredesigner
/usr/lib/gimp/2.0/plug-ins/xpm
/usr/lib/gimp/2.0/plug-ins/ifscompose
/usr/lib/gimp/2.0/plug-ins/mail
/usr/lib/gimp/2.0/plug-ins/FractalExplorer
/usr/lib/gimp/2.0/plug-ins/dog
/usr/lib/gimp/2.0/plug-ins/depthmerge
/usr/lib/gimp/2.0/plug-ins/unsharp
/usr/lib/gimp/2.0/plug-ins/sinus
/usr/lib/gimp/2.0/plug-ins/spread
/usr/lib/gimp/2.0/plug-ins/noisify
/usr/lib/gimp/2.0/plug-ins/sparkle
/usr/lib/gimp/2.0/plug-ins/despeckle
/usr/lib/gimp/2.0/plug-ins/hot
/usr/lib/gimp/2.0/plug-ins/shift
/usr/lib/gimp/2.0/plug-ins/video
/usr/lib/gimp/2.0/plug-ins/mapcolor
/usr/lib/gimp/2.0/plug-ins/tga
/usr/lib/gimp/2.0/plug-ins/CEL
/usr/lib/gimp/2.0/plug-ins/Lighting
/usr/lib/gimp/2.0/plug-ins/emboss
/usr/lib/gimp/2.0/plug-ins/sel2path
/usr/lib/gimp/2.0/plug-ins/help
/usr/lib/gimp/2.0/plug-ins/lens
/usr/lib/gimp/2.0/plug-ins/semiflatten
/usr/lib/gimp/2.0/plug-ins/illusion
/usr/lib/gimp/2.0/plug-ins/photocopy
/usr/lib/gimp/2.0/plug-ins/metadata
/usr/lib/gimp/2.0/plug-ins/max_rgb
/usr/lib/gimp/2.0/plug-ins/winicon
/usr/lib/gimp/2.0/plug-ins/curve_bend
/usr/lib/gimp/2.0/plug-ins/gimpressionist
/usr/lib/gimp/2.0/plug-ins/whirlpinch
/usr/lib/gimp/2.0/plug-ins/gfli
/usr/lib/gimp/2.0/plug-ins/raw
/usr/lib/gimp/2.0/plug-ins/sel_gauss
/usr/lib/gimp/2.0/plug-ins/mng
/usr/lib/gimp/2.0/plug-ins/gauss
/usr/lib/gimp/2.0/plug-ins/webbrowser
/usr/lib/gimp/2.0/plug-ins/plugin-browser
/usr/lib/gimp/2.0/plug-ins/wind
/usr/lib/gimp/2.0/plug-ins/desktop-link
/usr/lib/gimp/2.0/plug-ins/sobel
/usr/lib/gimp/2.0/plug-ins/faxg3
/usr/lib/gimp/2.0/plug-ins/tileit
/usr/lib/gimp/2.0/plug-ins/colorify
/usr/lib/gimp/2.0/plug-ins/convmatrix
/usr/lib/gimp/2.0/plug-ins/xbm
/usr/lib/gimp/2.0/plug-ins/pcx
/usr/lib/gimp/2.0/plug-ins/csource
/usr/lib/gimp/2.0/plug-ins/guillotine
/usr/lib/gimp/2.0/plug-ins/iwarp
/usr/lib/gimp/2.0/plug-ins/snoise
/usr/lib/gimp/2.0/plug-ins/newsprint
/usr/lib/gimp/2.0/plug-ins/pat
/usr/lib/gimp/2.0/plug-ins/poppler
/usr/lib/gimp/2.0/plug-ins/gfig
/usr/lib/gimp/2.0/plug-ins/blur
/usr/lib/gimp/2.0/plug-ins/psd-load
/usr/lib/gimp/2.0/plug-ins/svg
/usr/lib/gimp/2.0/plug-ins/sunras
/usr/lib/gimp/2.0/plug-ins/decompose
/usr/lib/gimp/2.0/plug-ins/dicom
/usr/lib/gimp/2.0/plug-ins/aa
/usr/lib/gimp/2.0/plug-ins/gif-load
/usr/lib/gimp/2.0/plug-ins/MapObject
/usr/lib/gimp/2.0/plug-ins/waves
/usr/lib/gimp/2.0/plug-ins/grid
/usr/lib/gimp/2.0/plug-ins/jigsaw
/usr/lib/gimp/2.0/plug-ins/wmf
/usr/lib/gimp/2.0/plug-ins/normalize
/usr/lib/gimp/2.0/environ
/usr/lib/gimp/2.0/environ/default.env
/usr/lib/gimp/2.0/interpreters
/usr/lib/gimp/2.0/interpreters/default.interp
/usr/lib/gimp/2.0/modules
/usr/lib/gimp/2.0/modules/libcolorsel_triangle.so
/usr/lib/gimp/2.0/modules/libcdisplay_lcms.so
/usr/lib/gimp/2.0/modules/libcdisplay_proof.so
/usr/lib/gimp/2.0/modules/libcolorsel_cmyk.la
/usr/lib/gimp/2.0/modules/libcolorsel_cmyk.so
/usr/lib/gimp/2.0/modules/libcolorsel_triangle.la
/usr/lib/gimp/2.0/modules/libcontroller_midi.so
/usr/lib/gimp/2.0/modules/libcdisplay_colorblind.so
/usr/lib/gimp/2.0/modules/libcolorsel_water.so
/usr/lib/gimp/2.0/modules/libcontroller_midi.la
/usr/lib/gimp/2.0/modules/libcdisplay_gamma.la
/usr/lib/gimp/2.0/modules/libcdisplay_proof.la
/usr/lib/gimp/2.0/modules/libcdisplay_colorblind.la
/usr/lib/gimp/2.0/modules/libcdisplay_highcontrast.so
/usr/lib/gimp/2.0/modules/libcdisplay_gamma.so
/usr/lib/gimp/2.0/modules/libcontroller_linux_input.la
/usr/lib/gimp/2.0/modules/libcdisplay_lcms.la
/usr/lib/gimp/2.0/modules/libcolorsel_water.la
/usr/lib/gimp/2.0/modules/libcdisplay_highcontrast.la
/usr/lib/gimp/2.0/modules/libcontroller_linux_input.so
/usr/bin
/usr/bin/gimp-2.4
/usr/bin/gimp-remote-2.4
/usr/bin/gimp-console-2.4
/usr/share
/usr/share/menu
/usr/share/menu/gimp
/usr/share/mime-info
/usr/share/mime-info/gimp.keys
/usr/share/doc
/usr/share/doc/gimp
/usr/share/doc/gimp/changelog.gz
/usr/share/doc/gimp/README.Debian
/usr/share/doc/gimp/changelog.Debian.gz
/usr/share/doc/gimp/NEWS.gz
/usr/share/doc/gimp/AUTHORS
/usr/share/doc/gimp/README
/usr/share/doc/gimp/README.MIDI
/usr/share/doc/gimp/NEWS.Debian.gz
/usr/share/doc/gimp/Wilber.xcf.gz.README
/usr/share/doc/gimp/Wilber_Construction_Kit.xcf.gz
/usr/share/doc/gimp/copyright
/usr/share/doc/gimp/Wilber.xcf.gz
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/gimp-remote-2.4.1.gz
/usr/share/man/man1/gimp-2.4.1.gz
/usr/share/applications
/usr/share/applications/gimp.desktop
/usr/share/application-registry
/usr/share/application-registry/gimp.applications
/usr/share/pixmaps
/usr/share/pixmaps/gimp.xpm
/usr/bin/gimp-remote
/usr/bin/gimp
/usr/bin/gimp-console
/usr/share/man/man1/gimp-console.1.gz
/usr/share/man/man1/gimp-remote.1.gz
/usr/share/man/man1/gimp.1.gz
/usr/share/man/man1/gimp-console-2.4.1.gz
/.
/usr
/usr/lib
/usr/lib/gimp
/usr/lib/gimp/2.0
/usr/lib/gimp/2.0/plug-ins
/usr/lib/gimp/2.0/plug-ins/gutenprint
/usr/share
/usr/share/doc
/usr/share/doc/gutenprint
/usr/share/doc/gutenprint/samples
/usr/share/doc/gutenprint/samples/colorbars4.png
/usr/share/doc/gutenprint/samples/colorsweep.png
/usr/share/doc/gimp-gutenprint
/usr/share/doc/gimp-gutenprint/FAQ.html
/usr/share/doc/gimp-gutenprint/copyright
/usr/share/doc/gimp-gutenprint/README.Debian
/usr/share/doc/gimp-gutenprint/README.gz
/usr/share/doc/gimp-gutenprint/changelog.Debian.gz
/usr/share/doc/gimp-gutenprint/changelog.gz
 

Thread Tools




All times are GMT. The time now is 04:02 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org