FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-20-2008, 10:03 AM
"Jabka Atu"
 
Default Image created by simple-cdd work in qemu but not in real life

Howdy,...

I created an image using simple-cdd and tested in qemu.
It worked fine (all went as it should).

When i burn it on a cd and reboot from it :
the image stuck saying :
"Uncompressing Linux... OK,booting the kernel"


if i press alt+f4 i can see the logs (but can't see any errors).
alt+f2/f3 allow shell (ash)

i also tried manualy starting d-i but i don't know yet how to use simple-cdd configurations :
so it will use presed postinst etc from /cdrom/simple-cdd


What am i doing wrong ?
 
Old 07-21-2008, 07:33 AM
"Jabka Atu"
 
Default Image created by simple-cdd work in qemu but not in real life

On Sun, Jul 20, 2008 at 3:53 PM, Harry Jede <walk2sun@arcor.de> wrote:

Am Sonntag, 20. Juli 2008 12:03 schrieb Jabka Atu:

> Howdy,...

>

> I created an image using simple-cdd and tested in qemu.

> It worked fine (all went as it should).

>

> When i burn it on a cd and reboot from it :

> the image stuck saying :

> "Uncompressing Linux... OK,booting the kernel"

>

> if i press alt+f4 i can see the logs (but can't see any errors).

> alt+f2/f3 allow shell (ash)

I don't know what went wrong. But if your CD works with qemu and not

with a real PC, you may use a serial console in qemu, which is not

connected to your real PC?



Best thing you may do, to track the problem is,

boot in qemu with priority=medium or low, load the ssh-client udeb and

execute the shell udeb from the menu. You must boot in text mode, to

make this work.



Then post the content of /proc/cmdline

and the content of your profiles/*postinst



then one may see if there are any mistakes


Problem solved.

for some reason simple-cdd sets it derfault input output to serial console.
To fix it should add the parmeter use_serial_console="false" into profiles/yourprofile.conf.

Or pass Console=tty0 at boot (install console=tty0)

*
 

Thread Tools




All times are GMT. The time now is 01:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org