FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 12-05-2007, 09:09 AM
Kostas Magkos
 
Default aacraid and smp kernel: SCSI hang

Greetings all,

Our main server is an Opteron system with an Adaptec SATA RAID 2410SA
controller and 4x 250GB Seagate Barracuda disks attached to it, forming
a RAID-5 and a RAID-0 container. The system is running sarge with the
latest 2.6.8 kernel (2.6.8-13-amd64-k8).

We recently upgraded the server with a second Opteron CPU. When we tried
to boot the system with the SMP kernel it gave the following messages
just after the login prompt and hung:

Nov 9 09:52:58 myhost kernel: aacraid: Host adapter reset request. SCSI
hang ?
Nov 9 09:52:58 myhost kernel: aacraid: Host adapter reset request. SCSI
hang ?
Nov 9 09:53:32 myhost kernel: aacraid: SCSI bus appears hung

Sarge 2.6.8 kernels contain aacraid 1.1.2-lk2. I managed to compile and
install version 1.1.5-2400 (downloaded from Adaptec's site) but without
any luck, the system still hangs.

Please note that aacraid 1.1.5-2400 has been used in the single CPU
system (i.e. before the addition of the second CPU) for quite some time,
without any problems.

Has anyone else faced a similar situation?

A google search revealed this is an old bug, dated back to 2003 but with
no clear solution whatsoever.

Any help would be much appreciated. In the time being I have two
options, either remove the second cpu or remove the raid controller,
both of which suck :-).

Some technical details
-----------------------
Motherboard: Tyan Thunder K8WE
CPU: 2x AMD Opteron 246
RAM: 2x 1GB Kingston DDR PC3200 ECC
RAID Controller: Adaptec 2410SA
HDD: 4x 250GB Seagate Barracuda 7200.8 SATA

user@myhost:~$ uname -ra
Linux myhost -smp #1 Sat Jun 9 16:52:03 UTC 2007 x86_64 GNU/Linux


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 03-23-2012, 04:30 PM
Joey L
 
Default aacraid and smp kernel: SCSI hang

did you have any issues with the video on the ibm 3650 ?
I am having a wierd problem where i disabled the gdm3 from loading -
now i can not get the text console on the server.
You know the login screen in text mode on the server is not visiable -
but can login to server from other workstations.
I thought i sent you this email before...but do not knwo if you got it.
thanks
mjh

On Wed, Mar 14, 2012 at 9:58 AM, Joey L <mjh2000@gmail.com> wrote:
> thanks a bunch!
>
> On Wed, Mar 14, 2012 at 9:46 AM, Kostas Magkos <kmag@iit.demokritos.gr> wrote:
>> If you are running squeeze you shouldn't be searching for the module.
>>
>> What you see on this webpage is the Adaptec Storage Manager (ASM) which
>> is the software to manage the controller. The aacraid module (which is
>> needed for the kernel to access the controller and thus the raid
>> containers) should be included in the stock squeeze kernel. At least
>> this is the case for our 2410sa. I believe both controllers (2820sa and
>> 2410sa) are accessed through the same module, but I'm not sure. You
>> should check.
>>
>> A good place for getting help and searching for solutions is the Adaptec
>> Support Knowledgebase at:
>> http://ask.adaptec.com
>>
>> As a matter of fact, I did use ASK quite recently (last summer) and
>> while our controller is really old they, worked with me and helped me
>> figure out what was messing up our setup. The support guy even gave me a
>> link to download a version of ASM that wasn't in the download page of
>> the 2410sa, compatible with debian.
>>
>> Regards,
>> Kostas
>>
>> Joey L wrote:
>>> thanks for the quick reply back - do you know where i can get the
>>> latest module for debian squeeze x86 ?
>>> There are so many on the site and that i have found and do not know
>>> which is which..
>>> http://www.adaptec.com/en-us/downloads/storage_manager/sm/productid=aar-2820sa&dn=adaptec+serial+ata+ii+raid+2820sa.html
>>>
>>> thanks
>>>
>>> On Wed, Mar 14, 2012 at 7:01 AM, Kostas Magkos <kmag@iit.demokritos.gr> wrote:
>>>
>>>> Hi there,
>>>>
>>>> I've scrolled back my notes and found that this was an issue with sarge
>>>> and aacraid module prior to 1.1.5.-2400. This was solved as soon as we
>>>> upgraded to etch (etch comes with aacraid 1.1.5-2409). As I can recall,
>>>> the system had a rather arbitrary behaviour while running sarge: most of
>>>> the times it would fail to boot, but sometimes it would reach the login
>>>> prompt and then run steadily until the next reboot.
>>>>
>>>> For the record I can't remember getting any answers for this.
>>>>
>>>> Hope that helps a bit,
>>>> Kostas
>>>>
>>>> Joey L wrote:
>>>>
>>>>> hi..i am getting the same issue on ibm 3650 - did you get any answers
>>>>> or found solution ?
>>>>>
>>>>> thanks
>>>>> mj
>>>>>
>>>>> On Wed, Dec 5, 2007 at 5:09 AM, Kostas Magkos <kmag@iit.demokritos.gr> wrote:
>>>>>
>>>>>
>>>>>> Greetings all,
>>>>>>
>>>>>> Our main server is an Opteron system with an Adaptec SATA RAID 2410SA
>>>>>> controller and 4x 250GB Seagate Barracuda disks attached to it, forming
>>>>>> a RAID-5 and a RAID-0 container. The system is running sarge with the
>>>>>> latest 2.6.8 kernel (2.6.8-13-amd64-k8).
>>>>>>
>>>>>> We recently upgraded the server with a second Opteron CPU. When we tried
>>>>>> to boot the system with the SMP kernel it gave the following messages
>>>>>> just after the login prompt and hung:
>>>>>>
>>>>>> Nov 9 09:52:58 myhost kernel: aacraid: Host adapter reset request. SCSI
>>>>>> hang ?
>>>>>> Nov 9 09:52:58 myhost kernel: aacraid: Host adapter reset request. SCSI
>>>>>> hang ?
>>>>>> Nov 9 09:53:32 myhost kernel: aacraid: SCSI bus appears hung
>>>>>>
>>>>>> Sarge 2.6.8 kernels contain aacraid 1.1.2-lk2. I managed to compile and
>>>>>> install version 1.1.5-2400 (downloaded from Adaptec's site) but without
>>>>>> any luck, the system still hangs.
>>>>>>
>>>>>> Please note that aacraid 1.1.5-2400 has been used in the single CPU
>>>>>> system (i.e. before the addition of the second CPU) for quite some time,
>>>>>> *without any problems.
>>>>>>
>>>>>> Has anyone else faced a similar situation?
>>>>>>
>>>>>> A google search revealed this is an old bug, dated back to 2003 but with
>>>>>> no clear solution whatsoever.
>>>>>>
>>>>>> Any help would be much appreciated. In the time being I have two
>>>>>> options, either remove the second cpu or remove the raid controller,
>>>>>> both of which suck :-).
>>>>>>
>>>>>> Some technical details
>>>>>> -----------------------
>>>>>> Motherboard: Tyan Thunder K8WE
>>>>>> CPU: 2x AMD Opteron 246
>>>>>> RAM: 2x 1GB Kingston DDR PC3200 ECC
>>>>>> RAID Controller: Adaptec 2410SA
>>>>>> HDD: 4x 250GB Seagate Barracuda 7200.8 SATA
>>>>>>
>>>>>> user@myhost:~$ uname -ra
>>>>>> Linux myhost -smp #1 Sat Jun 9 16:52:03 UTC 2007 x86_64 GNU/Linux
>>>>>>
>>>>>>
>>>>>> --
>>>>>> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
>>>>>> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
>>>>>>
>>>>>>
>>>>>>
>>>> --
>>>> Konstantinos Magkos, MSc
>>>> Information Systems Engineer
>>>> ...................................
>>>> Networks Laboratory,
>>>> Institute of Informatics & Telecommunications,
>>>> National Centre for Scientific Research "Demokritos"
>>>> ...................................
>>>> 153 10 Agia Paraskevi,
>>>> Athens, Greece
>>>> tel: +30 21 06503125
>>>> fax: +30 21 06543606
>>>> nic-hdl: KM1706-RIPE
>>>> http://www.ariadne-t.gr
>>>> http://www.iit.demokritos.gr
>>>> ....................................
>>>>
>>>>
>>
>> --
>> Konstantinos Magkos, MSc
>> Information Systems Engineer
>> ...................................
>> Networks Laboratory,
>> Institute of Informatics & Telecommunications,
>> National Centre for Scientific Research "Demokritos"
>> ...................................
>> 153 10 Agia Paraskevi,
>> Athens, Greece
>> tel: +30 21 06503125
>> fax: +30 21 06543606
>> nic-hdl: KM1706-RIPE
>> http://www.ariadne-t.gr
>> http://www.iit.demokritos.gr
>> ....................................
>>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAK3ER7ty0yShNhAVJ4YnU7xnf2pSaGnd6NkG2BA4e2kC0KVAa w@mail.gmail.com">http://lists.debian.org/CAK3ER7ty0yShNhAVJ4YnU7xnf2pSaGnd6NkG2BA4e2kC0KVAa w@mail.gmail.com
 

Thread Tools




All times are GMT. The time now is 08:18 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org