FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-13-2008, 03:40 PM
Hugo Vanwoerkom
 
Default prob. w. wordpress + php5

Hi,

Sid has dropped apache in favor of apache2.

Apache2 does not have php4 support, only php5.

But WordPress, in particular the Textile 2cb plugin, has a bug in it
using php5 that makes enumerated lists come out wrong.


I have the version of sid with apache + php4 on a mirror.

I want to install my system from scratch using the most recent sid but
stay with apache + php4 from my mirror.


How would I do that?

It's either that or change the plugin because it is no longer supported
by its author.




Hugo.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-13-2008, 04:24 PM
Freddy Freeloader
 
Default prob. w. wordpress + php5

Hugo Vanwoerkom wrote:

Hi,

Sid has dropped apache in favor of apache2.

Apache2 does not have php4 support, only php5.

But WordPress, in particular the Textile 2cb plugin, has a bug in it
using php5 that makes enumerated lists come out wrong.


I have the version of sid with apache + php4 on a mirror.

I want to install my system from scratch using the most recent sid but
stay with apache + php4 from my mirror.


How would I do that?

It's either that or change the plugin because it is no longer
supported by its author.




Hugo.


The wordpress package in Sid will work with php5. Here's the output
from "apt-cache show wordpress":


Package: wordpress
Priority: optional
Section: web
Installed-Size: 5032
Maintainer: Andrea De Iacovo <andrea.de.iacovo@gmail.com>
Architecture: all
Version: 2.5.1-4
Depends: apache2 | httpd, virtual-mysql-client, libapache2-mod-php5 |
php5 | php5-cgi | libapache2-mod-php4 | php4 | php4-cgi, php5-mysql |
php4-mysql, libphp-phpmailer (>= 1.73-4), php5-gd | php4-gd,
libjs-prototype, libjs-scriptaculous, tinymce (>= 3.0.7)

Suggests: virtual-mysql-server
Conflicts: mysql-server (<< 4.0.20-8)
Filename: pool/main/w/wordpress/wordpress_2.5.1-4_all.deb
Size: 1038376
MD5sum: 145d5509ea4b4067dded3ebd7736ffe9
SHA1: 08ce30c3d5e015ef7af2b5b2e02adee93659e322
SHA256: 43e390691e0725f1aacd6f3af6fe057d02c7d6afd776cb35f0 253bcec8754ea7
Description: weblog manager
WordPress is a full featured web blogging tool:
* Instant publishing (no rebuilding)
* Comment pingback support with spam protection
* Non-crufty URLs
* Themable
* Plugin support
.
This package includes French language support.
Homepage: http://wordpress.org
Tag: implemented-in:hp, interface::web, web::blog


Looks to me like wordpress will run on php4 or php5.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-13-2008, 04:27 PM
Freddy Freeloader
 
Default prob. w. wordpress + php5

Freddy Freeloader wrote:

Hugo Vanwoerkom wrote:

Hi,

Sid has dropped apache in favor of apache2.

Apache2 does not have php4 support, only php5.

But WordPress, in particular the Textile 2cb plugin, has a bug in it
using php5 that makes enumerated lists come out wrong.


I have the version of sid with apache + php4 on a mirror.

I want to install my system from scratch using the most recent sid
but stay with apache + php4 from my mirror.


How would I do that?

It's either that or change the plugin because it is no longer
supported by its author.




Hugo.


The wordpress package in Sid will work with php5. Here's the output
from "apt-cache show wordpress":


Package: wordpress
Priority: optional
Section: web
Installed-Size: 5032
Maintainer: Andrea De Iacovo <andrea.de.iacovo@gmail.com>
Architecture: all
Version: 2.5.1-4
Depends: apache2 | httpd, virtual-mysql-client, libapache2-mod-php5 |
php5 | php5-cgi | libapache2-mod-php4 | php4 | php4-cgi, php5-mysql |
php4-mysql, libphp-phpmailer (>= 1.73-4), php5-gd | php4-gd,
libjs-prototype, libjs-scriptaculous, tinymce (>= 3.0.7)

Suggests: virtual-mysql-server
Conflicts: mysql-server (<< 4.0.20-8)
Filename: pool/main/w/wordpress/wordpress_2.5.1-4_all.deb
Size: 1038376
MD5sum: 145d5509ea4b4067dded3ebd7736ffe9
SHA1: 08ce30c3d5e015ef7af2b5b2e02adee93659e322
SHA256: 43e390691e0725f1aacd6f3af6fe057d02c7d6afd776cb35f0 253bcec8754ea7
Description: weblog manager
WordPress is a full featured web blogging tool:
* Instant publishing (no rebuilding)
* Comment pingback support with spam protection
* Non-crufty URLs
* Themable
* Plugin support
.
This package includes French language support.
Homepage: http://wordpress.org
Tag: implemented-in:hp, interface::web, web::blog


Looks to me like wordpress will run on php4 or php5.


Never mind. Brain fart on my part.




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-13-2008, 07:29 PM
Hugo Vanwoerkom
 
Default prob. w. wordpress + php5

Hugo Vanwoerkom wrote:

Hi,

Sid has dropped apache in favor of apache2.

Apache2 does not have php4 support, only php5.

But WordPress, in particular the Textile 2cb plugin, has a bug in it
using php5 that makes enumerated lists come out wrong.


I have the version of sid with apache + php4 on a mirror.

I want to install my system from scratch using the most recent sid but
stay with apache + php4 from my mirror.


How would I do that?

It's either that or change the plugin because it is no longer supported
by its author.





What lists look like in WP with php5 and the Textile 2cb plugin:

http://www.esnips.com/doc/1b9a0609-b5ea-4c6b-bb60-081ecd3a9e17/WP-with-php5

what they look like with php5 and that plugin:

http://www.esnips.com/doc/414fdd8a-0c93-4169-a3d3-63c2d99ddf38/WP-with-php4

Clearly different: I prefer to stay with php4!

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-14-2008, 05:38 PM
Hugo Vanwoerkom
 
Default prob. w. wordpress + php5

Hugo Vanwoerkom wrote:

Hugo Vanwoerkom wrote:

Hi,

Sid has dropped apache in favor of apache2.

Apache2 does not have php4 support, only php5.

But WordPress, in particular the Textile 2cb plugin, has a bug in it
using php5 that makes enumerated lists come out wrong.


I have the version of sid with apache + php4 on a mirror.

I want to install my system from scratch using the most recent sid but
stay with apache + php4 from my mirror.


How would I do that?

It's either that or change the plugin because it is no longer
supported by its author.





What lists look like in WP with php5 and the Textile 2cb plugin:

http://www.esnips.com/doc/1b9a0609-b5ea-4c6b-bb60-081ecd3a9e17/WP-with-php5

what they look like with php5 and that plugin:

http://www.esnips.com/doc/414fdd8a-0c93-4169-a3d3-63c2d99ddf38/WP-with-php4

Clearly different: I prefer to stay with php4!



There actually is another option, that "fixes" the problem:

http://www.esnips.com/doc/cabed293-7a0f-447b-8856-22d77f325470/WP-with-php5---Corrected

It involves writing a program to correct the ending of all itemized and
enumerated lists by inserting a comment: <!-- -->


Mysql has a terrific dump program that creates a text file of the entire
db and puts all the posts on one line that begins with INSERT INTO
'wp_posts'


The program would go into that one line and change all the endings.

And Sid will merrily upgrade with php5 and I don't care!


Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 10:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org