FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-12-2008, 07:55 PM
Shachar Or
 
Default Behavior of 'ptitude -t' in dependencies?

Hello!

package 'foo' from etch-backports depends on package 'bar' from either etch or
etch-backports.
Both packages are available to apt from both etch and etch-backports.

When I type 'aptitude -t etch-backports install foo', which version of 'bar'
will be installed, the etch one or the etch-backports one?

Love!
--
Shachar Or | שחר אור
http://ox.freeallweb.org/


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-12-2008, 08:24 PM
"Eugene V. Lyubimkin"
 
Default Behavior of 'ptitude -t' in dependencies?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Shachar Or wrote:
> Hello!
>
> package 'foo' from etch-backports depends on package 'bar' from either etch or
> etch-backports.
> Both packages are available to apt from both etch and etch-backports.
>
> When I type 'aptitude -t etch-backports install foo', which version of 'bar'
> will be installed, the etch one or the etch-backports one?
>
> Love!
- From repo with greater priority, If I recall correctly.

- --
Eugene V. Lyubimkin aka JackYF, Ukrainian C++ developer.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIeRMGchorMMFUmYwRAvf9AKCJuQBCC8MeYBuYn/gPNUAvd3CfqgCdFTQw
XoCkfu2+qVJKz3ZgwLZF6PI=
=3eiq
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-13-2008, 11:02 AM
Andrei Popescu
 
Default Behavior of 'ptitude -t' in dependencies?

On Sat,12.Jul.08, 22:55:02, Shachar Or wrote:
> Hello!
>
> package 'foo' from etch-backports depends on package 'bar' from either etch or
> etch-backports.
> Both packages are available to apt from both etch and etch-backports.
>
> When I type 'aptitude -t etch-backports install foo', which version of 'bar'
> will be installed, the etch one or the etch-backports one?

Try adding the -V (capital v) switch to see the version numbers. Maybe
-s (simulate) could also help.

Regards,
Andrei
--
If you can't explain it simply, you don't understand it well enough.
(Albert Einstein)
 

Thread Tools




All times are GMT. The time now is 04:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org