FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 07-10-2008, 03:56 PM
Bonnel Christophe
 
Default net problem, some apps not connecting

hi,

hum, it looks like a ttl or mtu problem.

Do you use PPPoA for your internet connection ?

Try to open a google page with a web browser. If it works, enter a word
for a search (it should work) and now click on one of the links (it
should not work). If all this works, you have a mtu problem. I don't
have here the solution but i may be something like this to add to your
gateway firewall :
$IPTABLES -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS
--clamp-mss-to-pmtu


It can also be a ttl problem. I'm not a specialist but you can search on
the debian-amd64 mailing list on april 2008 the subject "NAT and
IPTABLES problem". It can help you if the first method doesn't work.


Hope this helps

Christophe


Enrique Morfin a écrit :

Hi!

I have a g4 notebook. It had not been connected to any network for a while.
Now i tried to conect to a network.
The problem is the same in any network (wired or wireless, at home or work). So is not the network.
It have dual boot (linux-osX). The problem is just in linux, so is not the hardware.
It must be some configuration problem.

The symptoms:

It "can't conecct" to any other computer.

I have tried the following browsers: iceweasel, iceape, konqueror, opera, lynx and links.
All have failed conecting to any webpage.

I have tried to connect via ssh (ssh, slogin, scp) to any other box in the net, all have failed. (I can't connect either to that box) Simply, ther is no answer.

You can say it is the connection or dns or something, BUT:

I can ping any other computer. Even the gateway or dns.

If i type: "host mail.yahoo.com" or "dig mail.yahoo.com" or "host www.hotmail.com" or any other with host or dig, i get the answer.

If i type "nc any.ip.in.net 22" i get the ssh answer (SSH-2.0-OpenSSH_4.3p2 Debian-9)

If i type "wget http://www.google.com" I get the index.html that is google page. I can wget any page or file.

I can "aptitude update" and "aptitude safe-upgrade" whitout any trouble.

So the box is connecting to the net with some apps, but other apps are not connecting.

There is no iptables nor proxies. There is any fixed arp table.

The problem is the same if i connect the box direct to other box and i tried to connect via ssh or webpage.

Any ideas? Some config file i'm missing?

Thanks.










--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 11:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org