Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Package requirements installation (http://www.linux-archive.org/debian-user/119949-package-requirements-installation.html)

Daniel Burrows 07-06-2008 05:01 PM

Package requirements installation
 
On Sun, Jul 06, 2008 at 11:21:03AM -0500, Ron Johnson <ron.l.johnson@cox.net> was heard to say:
> > gthread-2.0
>
> This is the tricky one.

It's part of libglib2.0-dev.

daniel@alpaca:~$ dpkg -S /usr/lib/pkgconfig/gthread-2.0.pc
libglib2.0-dev: /usr/lib/pkgconfig/gthread-2.0.pc

Daniel


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Nigel Henry 07-06-2008 05:09 PM

Package requirements installation
 
On Sunday 06 July 2008 18:21, Ron Johnson wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 07/06/08 10:34, Rodolfo Medina wrote:
> > During the installation of gnome-mplayer, at the `./configure' step it is
> > complained the lack of the following packages:
> >
> > gtk+-2.0
>
> You need to install libgtk2.0-dev.
>
>
> $ apt-cache search libgtk | grep 2. | grep dev | sort
> libgtk-directfb-2.0-dev - Development files for the GTK+ library -
> DirectFB version
> libgtk1.2-dev - Development files for the GIMP Toolkit
> libgtk2.0-dev - Development files for the GTK+ library
> libgtkada2-dev - Development files for libgtkada2
> libgtkdatabox-0.8.2-dev - A Gtk+ library to display large amounts of
> numerical data
> libgtkextra-x11-2.0-dev - A useful set of widgets for GTK+
> (development files)
> libgtkgl2.0-dev - OpenGL area for GTK (development files)
> libgtkglextmm-x11-1.2-dev - C++ bindings for GtkGLExt (Development
> files)
> libgtkhtml2-dev - HTML rendering/editing library - development files
> libgtkmm-2.4-dev - C++ wrappers for GTK+ 2.4 (development files)
> libgtkmm-dev - C++ wrapper for GTK+ 1.2 (development files)
> libgtksourceview2.0-dev - development files for the GTK+ syntax
> highlighting widget
> libgtksourceviewmm-2.0-dev - C++ binding of GtkSourceView -
> development files
>
> > glib-2.0
>
> Similarly, libglib2.0-dev.
>
> $ apt-cache search libglib | grep 2. | grep dev | sort
> libglib1.2-dev - The GLib library of C routines (development)
> libglib2.0-dev - Development files for the GLib library
> libglibmm-2.4-dev - C++ wrapper for the GLib toolkit (development files)
>
> > gthread-2.0
>
> This is the tricky one.

From a Google on gthread-2.0, it appears to be one of the installed files when
you install libglib2.0-dev, which I verified in synaptic for installed files
on my Lenny install.
/usr/include/glib-2.0/glib/gthread.h
and further down the list of installed files
/usr/lib/libgthread-2.0.la
and further down again
/usr/lib/pkgconfig/gthread-2.0.pc

Nigel.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 08:33 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.