Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   how to enable framebuffer (http://www.linux-archive.org/debian-user/118190-how-enable-framebuffer.html)

Can-Hua Chen 07-03-2008 11:10 AM

how to enable framebuffer
 
I am using Inter810 driver.
I tried:
modprobe i810 vram=16 xres=1024 yres=768 bpp=32 accel=1 mtrr=1.
After that I know the module did be loaded via "lsmod" command,
while /dev/fb0 was still missing.
I even "mknod /dev/fb0 c 29 0" according to a googled webpage,
but "mplayer -vo fbdev Some.avi" still say that "no such device".


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Richard Möhn 07-03-2008 04:32 PM

how to enable framebuffer
 
On Thu, Jul 03, 2008 at 07:10:13PM +0800, Can-Hua Chen wrote:
> I am using Inter810 driver.
> I tried:
> modprobe i810 vram=16 xres=1024 yres=768 bpp=32 accel=1 mtrr=1.
> After that I know the module did be loaded via "lsmod" command,
> while /dev/fb0 was still missing.
> I even "mknod /dev/fb0 c 29 0" according to a googled webpage,
> but "mplayer -vo fbdev Some.avi" still say that "no such device".

Hi,

try adding "vga=0xo" to the kernel line in the /boot/grub/menu.lst!
For "o" you have to type "318" for 24 bits or "314" for 16 bits.

Nice greetings,

Richard


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 07:00 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.