FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-18-2008, 04:30 PM
Hugo Vanwoerkom
 
Default iceweasel 3: favicon while tab is loading

Hi,


In sid's iceweasel 3 I notice a difference with iceweasel 2:

when a tab is loading the favicon shown would slowly rotate in version
2, but in version 3 it stays stuck at the beginning.


Searching bugzilla.mozilla.org I find nothing under "favicon", but it
clearly is a visible but minor bug.


Anybody else notice this behavior?

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-21-2008, 03:56 AM
Hugo Vanwoerkom
 
Default iceweasel 3: favicon while tab is loading

Hugo Vanwoerkom wrote:

Hi,


In sid's iceweasel 3 I notice a difference with iceweasel 2:

when a tab is loading the favicon shown would slowly rotate in version
2, but in version 3 it stays stuck at the beginning.


Searching bugzilla.mozilla.org I find nothing under "favicon", but it
clearly is a visible but minor bug.


Anybody else notice this behavior?



The latest FF3 nightly build apparently is called "minefield" and the
favicon works correcly there.


Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-21-2008, 04:15 PM
Hugo Vanwoerkom
 
Default iceweasel 3: favicon while tab is loading

Hugo Vanwoerkom wrote:

Hi,


In sid's iceweasel 3 I notice a difference with iceweasel 2:

when a tab is loading the favicon shown would slowly rotate in version
2, but in version 3 it stays stuck at the beginning.


Searching bugzilla.mozilla.org I find nothing under "favicon", but it
clearly is a visible but minor bug.




This works OK in FF3RC3.
Is it a debian bug?

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-22-2008, 01:48 PM
Hugo Vanwoerkom
 
Default iceweasel 3: favicon while tab is loading

Hugo Vanwoerkom wrote:

Hi,


In sid's iceweasel 3 I notice a difference with iceweasel 2:

when a tab is loading the favicon shown would slowly rotate in version
2, but in version 3 it stays stuck at the beginning.


Searching bugzilla.mozilla.org I find nothing under "favicon", but it
clearly is a visible but minor bug.


Anybody else notice this behavior?




I filed a bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=487411

It was answered right away by Mike Hommey:

The most probable reason is that the new icon is an APNG, which
iceweasel 3 doesn't recognize, while firefox does. APNG is a torture of
the PNG standard, that was rejected by the PNG group, and official
libpng is probably not going to include APNG support for a while.
Firefox uses a bundled and heavily patched libpng, which we can't for
maintenability reasons.


So that explains it.

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-22-2008, 10:55 PM
Hugo Vanwoerkom
 
Default iceweasel 3: favicon while tab is loading

Hugo Vanwoerkom wrote:

Hi,


In sid's iceweasel 3 I notice a difference with iceweasel 2:

when a tab is loading the favicon shown would slowly rotate in version
2, but in version 3 it stays stuck at the beginning.


Searching bugzilla.mozilla.org I find nothing under "favicon", but it
clearly is a visible but minor bug.


Anybody else notice this behavior?



BTW, it's called the 'throbber'...


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-22-2008, 11:34 PM
"Damon L. Chesser"
 
Default iceweasel 3: favicon while tab is loading

On Sunday 22 June 2008 06:55:46 pm Hugo Vanwoerkom wrote:
> Hugo Vanwoerkom wrote:
> > Hi,
> >
> >
> > In sid's iceweasel 3 I notice a difference with iceweasel 2:
> >
> > when a tab is loading the favicon shown would slowly rotate in version
> > 2, but in version 3 it stays stuck at the beginning.
> >
> > Searching bugzilla.mozilla.org I find nothing under "favicon", but it
> > clearly is a visible but minor bug.
> >
> > Anybody else notice this behavior?
>
> BTW, it's called the 'throbber'...

That is also seen here.

--
Damon L. Chesser
damon@damtek.com
http://www.linkedin.com/in/dchesser
 
Old 06-24-2008, 04:11 PM
Hugo Vanwoerkom
 
Default iceweasel 3: favicon while tab is loading

Damon L. Chesser wrote:

On Sunday 22 June 2008 06:55:46 pm Hugo Vanwoerkom wrote:

Hugo Vanwoerkom wrote:

Hi,


In sid's iceweasel 3 I notice a difference with iceweasel 2:

when a tab is loading the favicon shown would slowly rotate in version
2, but in version 3 it stays stuck at the beginning.

Searching bugzilla.mozilla.org I find nothing under "favicon", but it
clearly is a visible but minor bug.

Anybody else notice this behavior?

BTW, it's called the 'throbber'...


That is also seen here.



Damon, its all explained in
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=487411

But I am not sure that it will ever work as in FF3

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-01-2008, 08:26 PM
Hugo Vanwoerkom
 
Default iceweasel 3: favicon while tab is loading

Hugo Vanwoerkom wrote:

Damon L. Chesser wrote:

On Sunday 22 June 2008 06:55:46 pm Hugo Vanwoerkom wrote:

Hugo Vanwoerkom wrote:

Hi,


In sid's iceweasel 3 I notice a difference with iceweasel 2:

when a tab is loading the favicon shown would slowly rotate in version
2, but in version 3 it stays stuck at the beginning.

Searching bugzilla.mozilla.org I find nothing under "favicon", but it
clearly is a visible but minor bug.

Anybody else notice this behavior?

BTW, it's called the 'throbber'...


That is also seen here.



Damon, its all explained in
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=487411

But I am not sure that it will ever work as in FF3



That bug is fixed by Mike Hommey and the bug is closed.
The throbbers look better than in FF3.
You need to install xulrunner-1.9 in order to have the fix installed.

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 11:19 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org