FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-10-2008, 10:35 PM
Aaron Hall
 
Default xpdf-utils vs. poppler-utils conflict prevents aptitude safe-upgrade

My sid box has cupsys and xpdf-utils installed (among a bunch of other
things). When I run "aptitude safe-upgrade", aptitude runs through its
normal prep, followed by many lines of "Resolving dependencies...",
followed by:

The following packages have unmet dependencies:
xpdf-utils: Conflicts: poppler-utils but 0.8.2-2 is to be installed.
poppler-utils: Conflicts: xpdf-utils but 3.02-1.3 is installed.

Then it exits. I can tell xpdf-utils and poppler-utils conflict; fine.
But xpdf-utils is already installed, poppler-utils is not. I thought
aptitude would normally let the already-installed xpdf-utils fulfill the
dependency and ignore poppler-utils. But it's not. So I thought that
something else might be trying to pull poppler-utils in, but:

frenesi: ~ % aptitude why poppler-utils
i cupsys Depends poppler-utils | xpdf-utils
frenesi: ~ % aptitude why xpdf-utils
i cupsys Depends poppler-utils | xpdf-utils

Further, "aptitude full-upgrade" doesn't seem to want to upgrade
xpdf-utils *or* install poppler-utils. "apt-cache policy xpdf-utils"
tells me I'm have the current xpdf-utils 3.02-1.3. So why is "aptitude
safe-upgrade" complaining and exiting?

I'm inclined to just run "full-upgrade" and be done with it. (I normally
run "safe-upgrade" first, then "full-upgrade", which is why I ran into
this. Is that superstitious?)

That said, I think I misunderstand something here, but I'm not sure
what. Not a killer problem, but I'd appreciate the enlightenment.

- Aaron

--
Aaron Hall : "We have to protect our children from
ahall@vitaphone.net : district attorneys."
: -- Georgia state senator Emanuel Jones


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-11-2008, 01:50 AM
Aaron Hall
 
Default xpdf-utils vs. poppler-utils conflict prevents aptitude safe-upgrade

On Tue, 10 Jun 2008, Daniel Burrows wrote:

> On Tue, Jun 10, 2008 at 05:35:18PM -0500, Aaron Hall
> <ahall@vitaphone.net> was heard to say:
>
> > My sid box has cupsys and xpdf-utils installed (among a bunch of other
> > things). When I run "aptitude safe-upgrade", aptitude runs through its
> > normal prep, followed by many lines of "Resolving dependencies...",
> > followed by:
> >
> > The following packages have unmet dependencies:
> > xpdf-utils: Conflicts: poppler-utils but 0.8.2-2 is to be installed.
> > poppler-utils: Conflicts: xpdf-utils but 3.02-1.3 is installed.
>
> [snip]
>
> I ran into this on my own computer recently. Unfortunately, it's not
> trivial to solve. The problem came up because of an interaction between
> the code to remove unused packages and the code to resolve dependencies:
> if a package is installed that requires something being removed because
> it's unused, the unused package will be put back on the system. That's
> fine, but the resolver doesn't know that, and so it produces a solution
> that breaks dependencies after it's applied.

Ah, I see now. Just for fun, I ran "aptitude unmarkauto xpdf-utils" to
keep it from getting removed, then "aptitude safe-upgrade", and indeed
it was happy.

(As an aside, I think it's wonderful that you're willing to take time
out to answer questions on this list. Thanks yet again.)

- Aaron

--
Aaron Hall : "Poor soul, very sad; her late husband,
ahall@vitaphone.net : you know, a very sad death -- eaten by
: missionaries, poor soul..."
: -- Rev. Wm. Spooner


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-13-2008, 03:13 AM
"Manon Metten"
 
Default xpdf-utils vs. poppler-utils conflict prevents aptitude safe-upgrade

Hi Aaron,

What's this for kind of 'aptitude why' command you used?

> frenesi: ~ % aptitude why poppler-utils
> i cupsys Depends poppler-utils | xpdf-utils

When I tried 'aptitude why poppler-utils', aptitude complained
'Unknown command "why"'.

I' running Etch (aptitude 0.4.4-4). Could this possibly be a Sid option?

Greetings, Manon.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 09:57 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org