FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-05-2008, 04:20 AM
"Tony Heal"
 
Default mounting an smbfs as non superuser

I am trying to mount an smbfs as the backup user and
something is not right. I can run this as root and it works fine


*


mount -t smbfs –o owner=backup -o lfs -o
username=administrator,password=XXXXXX //192.168.2.200/drobo /media/drobo/


*


yet when I mount it that way the backup user has no
permissions. If I try and mount it as the backup user I get a message stating
only root can do that.


*


mount: only root can do that


*


Anyone know how I can mount this so that the backup user can
write to it


*


Thank you


*


Tony Heal
 
Old 06-05-2008, 06:29 AM
Marc Shapiro
 
Default mounting an smbfs as non superuser

Tony Heal wrote:


I am trying to mount an smbfs as the backup user and something is not
right. I can run this as root and it works fine


mount -t smbfs –o owner=backup -o lfs -o
username=administrator,password=XXXXXX //192.168.2.200/drobo /media/drobo/


yet when I mount it that way the backup user has no permissions. If I
try and mount it as the backup user I get a message stating only root
can do that.


mount: only root can do that

Anyone know how I can mount this so that the backup user can write to it

I don't know if there is anything different about smbfs, but when I get
that message from mount it means either:


There is no entry in /etc/fstab for that filesystem/mountpoint combo
or
There is an fstab entry, but it does not have the user option

HTH

--
Marc Shapiro
mshapiro_42@yahoo.com




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-05-2008, 06:55 AM
"Mirco Piccin"
 
Default mounting an smbfs as non superuser

Hi all

On 6/5/08, Marc Shapiro <mshapiro_42@yahoo.com> wrote:
Tony Heal wrote:




I am trying to mount an smbfs as the backup user and something is not right. I can run this as root and it works fine



mount -t smbfs –o owner=backup -o lfs -o username=administrator,password=XXXXXX //192.168.2.200/drobo /media/drobo/




yet when I mount it that way the backup user has no permissions. If I try and mount it as the backup user I get a message stating only root can do that.



mount: only root can do that
Yeah.
*

Anyone know how I can mount this so that the backup user can write to it




I don't know if there is anything different about smbfs, but when I get that message from mount it means either:



There is no entry in /etc/fstab for that filesystem/mountpoint combo

or

There is an fstab entry, but it does not have the user option



Yes, a solution could be to add a fstab entry.

Another way is to use smbmount.
You need to set uid root smbmnt, smbmount, smbumount, mount, umount (chmod u+s ..).

And the mount the remote share with smbmount command:
smbmount //remoteshare /mount/point* -o username=user,password=password,workgroup=workgrou p

It works for me.
I use many remote shares, and the mount is related to some other scripts, so i prefer this way to the fstab edit.


Hope it helps you.
Regards
M
 
Old 06-06-2008, 12:02 AM
Andrew Reid
 
Default mounting an smbfs as non superuser

On Thursday 05 June 2008 00:20, Tony Heal wrote:
> I am trying to mount an smbfs as the backup user and something is not
> right. I can run this as root and it works fine
>
>
>
> mount -t smbfs -o owner=backup -o lfs -o
> username=administrator,password=XXXXXX //192.168.2.200/drobo /media/drobo/
>
>
>
> yet when I mount it that way the backup user has no permissions. If I try
> and mount it as the backup user I get a message stating only root can do
> that.
>
>
>
> mount: only root can do that
>
>
>
> Anyone know how I can mount this so that the backup user can write to it

I use smbmount for that. It's apt-gettable, and has a config file
where you can configure defaults so that the actual command you have
to issue is shorter.

-- A.

--
Andrew Reid / reidac@bellatlantic.net


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 07:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org