FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-04-2008, 08:01 AM
Eugen Wintersberger
 
Default Problem with Ubuntu printing on a Debian server

Hi there
I have a problem with printing from my Ubuntu (8.04) workstations on
network printers exported by a CUPS server running under Debian Etch.
On the Debian server the CUPS version is 1.2.7 while on the Ubuntu boxes
CUPS version is 1.3.7.

To be a bit more precise: printing with lp works fine from within a
terminal. However, all applications using the GNOME printing dialog fail
to print.

When I open the printing dialog lets say from evince i get the following
error message in the access_log on the Debian server:

- - [29/May/2008:10:28:09 +0200] "GET /printers/HPCLJ4550DN?all HTTP/1.1" 404 0 - -

if a network printer is activated by default (otherwise I get this
message after activating a network printer via mouse click).
When I try now to print the document the access_log on the Ubuntu client
gets the following message

- - [29/May/2008:10:32:13 +0200] "POST /printers/HPCLJ4550DN HTTP/1.1" 200 162889 Print-Job client-error-not-found

It seems that the GNOME printing dialog is making an error in the
printer request.
Has anyone an idea how to solve this problem?

regards
Eugen Wintersberger


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 06-04-2008, 04:13 PM
"Douglas A. Tutty"
 
Default Problem with Ubuntu printing on a Debian server

On Wed, Jun 04, 2008 at 10:01:27AM +0200, Eugen Wintersberger wrote:
[snip]
> if a network printer is activated by default (otherwise I get this
> message after activating a network printer via mouse click).
> When I try now to print the document the access_log on the Ubuntu client
> gets the following message
>
> - - [29/May/2008:10:32:13 +0200] "POST /printers/HPCLJ4550DN HTTP/1.1" 200 162889 Print-Job client-error-not-found
>
> It seems that the GNOME printing dialog is making an error in the
> printer request.
> Has anyone an idea how to solve this problem?

Sure. Don't use cups. Standard LPD with remote printing would work.
Gnome would print to the local queue which LPD would spit out to the
remote queue. If you like the CUPS print filters, you can still use
foomatic-printfilters with LPD. If you want fancy access controlls, use
LPRng.

Doug.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org