Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Laptop (http://www.linux-archive.org/debian-laptop/)
-   -   wl (broadcom-sta) and linux 2.6.38 (http://www.linux-archive.org/debian-laptop/504812-wl-broadcom-sta-linux-2-6-38-a.html)

Boris Bobrov 03-23-2011 07:04 PM

wl (broadcom-sta) and linux 2.6.38
 
Hello. A trouble appeared with linux 2.6.38.

lcpci:
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
# uname -a
Linux breton 2.6.38-1-686 #1 SMP Wed Mar 16 17:37:47 UTC 2011 i686 GNU/Linux

The trouble itself:
# iwlist eth1 scan
eth1 Failed to read scan data : Invalid argument
OR
eth1 No scan results

Wicd also doesn't see any available networks.
b43 detects network and connects to it. wl also worked with linux 2.6.37.

Am I the only one with this trouble?

--
WBR,
Boris.

Jerome BENOIT 03-23-2011 09:14 PM

wl (broadcom-sta) and linux 2.6.38
 
Hello,

actually I could not built the module (Wheezy Debian source package) against kernel 2.6.38 on my Squeeze box:
how did you build it ?

On the other hand, the module brcm80211 (kernel 2.6.38) seems to work now:
have you tried it ?



On 23/03/11 21:04, Boris Bobrov wrote:

Hello. A trouble appeared with linux 2.6.38.

lcpci:
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
# uname -a
Linux breton 2.6.38-1-686 #1 SMP Wed Mar 16 17:37:47 UTC 2011 i686 GNU/Linux

The trouble itself:
# iwlist eth1 scan
eth1 Failed to read scan data : Invalid argument
OR
eth1 No scan results

Wicd also doesn't see any available networks.
b43 detects network and connects to it. wl also worked with linux 2.6.37.

Am I the only one with this trouble?


Jerome





--
To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4D8A70D1.3040408@rezozer.net">http://lists.debian.org/4D8A70D1.3040408@rezozer.net

Boris Bobrov 03-24-2011 10:45 AM

wl (broadcom-sta) and linux 2.6.38
 
В сообщении от Четверг 24 марта 2011 03:14:41 автор Jerome BENOIT написал:
> Hello,
>
> actually I could not built the module (Wheezy Debian source package)
> against kernel 2.6.38 on my Squeeze box: how did you build it ?
>
Don't know. Built it with usual m-a a-i broadcom-sta

> On the other hand, the module brcm80211 (kernel 2.6.38) seems to work now:
> have you tried it ?
>
The module for my card is b43. Actually I am using it right now. It works, but
works bad. This is not only my problem, a lot of people who use it have the
same.

--
WBR,
Boris.

Duane Bielling 03-27-2011 02:51 PM

wl (broadcom-sta) and linux 2.6.38
 
On Thu, Mar 24, 2011 at 6:45 AM, Boris Bobrov <breton.linux@gmail.com> wrote:
>
> В сообщении от Четверг 24 марта 2011 03:14:41 автор Jerome BENOIT написал:

> > On the other hand, the module brcm80211 (kernel 2.6.38) seems to work now:
> > have you tried it ?
> >
> The module for my card is b43. Actually I am using it right now. It works, but
> works bad. This is not only my problem, a lot of people who use it have the
> same.

I have a BCM4321 which has not (historically) been supported by b43.
I have not tried brcm80211. What works for me (most of the time) is
the non-free wl module. While I would certainly prefer a free
solution, a non-free solution is somewhat acceptable in the interim.

http://wiki.debian.org/wl/ should take you where you need to go to
install the wl module and the 4312 is listed as being supported.

HTH.


--
To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTikXG9gLbDEq5zrENVB89shDX=z=fQ@mail.gmail.com ">http://lists.debian.org/BANLkTikXG9gLbDEq5zrENVB89shDX=z=fQ@mail.gmail.com


All times are GMT. The time now is 01:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.