FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 06-03-2008, 04:15 AM
Matt Taggart
 
Default Bug#466600: cpqarray followup

Following up on my recent mail about testing cpqarray RE: #466600

1.) I just tested with debian-40r3-i386-netinst.iso

In my previous lenny test a

time dd if=/dev/zero of=/dev/ida/c0d0 bs=1024k count=1024

took 2:50 which I felt was slow. The same test on the etch kernel took
3:04, so the etch kernel is even slower. On this reboot I was able to check
the controller settings and the 4 36gb/10k rpm drives are setup in RAID5,
maybe this speed is expected for hardware RAID5?

The etch install went fine, including the grub install, so the lenny grub
install error is a regression.

2.) After the etch install, I decided to first test etch-and-a-half. So I
upgraded to to etch-proposed-updates and then installed
linux-image-2.6.24-etchnhalf.1-686. It installed fine and rebooted fine. I
did the above dd test (on a different partition though) and it took 2:39, a
slight improvement, or 6.44mb/sec.

3.) Next I upgraded to sid and installed linux-image-2.6.25-2-686 and got
the following error

================================================== ======================
Setting up linux-image-2.6.25-2-686 (2.6.25-4) ...
Running depmod.
Finding valid ramdisk creators.
Using mkinitramfs-kpkg to build the ramdisk.
initrd.img(/boot/initrd.img-2.6.25-2-686
) points to /boot/initrd.img-2.6.25-2-686
(/boot/initrd.img-2.6.25-2-686) -- doing nothing at
/var/lib/dpkg/info/linux-image-2.6.25-2-686.postinst line 569.
vmlinuz(/boot/vmlinuz-2.6.25-2-686
) points to /boot/vmlinuz-2.6.25-2-686
(/boot/vmlinuz-2.6.25-2-686) -- doing nothing at /var/lib/dpkg/info/linux-i
mage-2.6.25-2-686.postinst line 569.
Running postinst hook script update-grub.
Searching for GRUB installation directory ... found: /boot/grub
grub-probe: error: Cannot find a GRUB drive for /dev/ida/c0d0p1. Check
your device.map.

User postinst hook script [update-grub] exited with value 1
dpkg: error processing linux-image-2.6.25-2-686 (--configure):
subprocess post-installation script returned error exit status 1
================================================== ======================

Same error as in d-i.

Checking /boot/grub/device.map, it only contains the fd0 line. Even if I
put the device back in devices.map, installing a kernel (and thus running
grub-probe) fails and also the device.map ends up with just fd0 again.

Downgrading grub to the etch version allows kernels to install properly,
although devices.map still only contains the fd0 line.

After linux-image-2.6.25-2-686 installed properly, it boots fine. So this
bug is fixed, but it looks like there's a new one in grub.

--
Matt Taggart
taggart@debian.org





--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 09:38 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org