Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Kernel (http://www.linux-archive.org/debian-kernel/)
-   -   Bug#408746: closed by maximilian attems ( snd* modules are not autoloaded when udev is installed) (http://www.linux-archive.org/debian-kernel/97823-bug-408746-closed-maximilian-attems-max-stro-snd-modules-not-autoloaded-when-udev-installed.html)

Vincent Lefevre 05-30-2008 12:31 AM

Bug#408746: closed by maximilian attems ( snd* modules are not autoloaded when udev is installed)
 
reopen 408746
found 408746 2.6.25-4
thanks

While I didn't have any problem with linux-image-2.6.25-2-powerpc 2.6.25-3
(at the same time, udev was installed due to dependencies, because I had
to replace the buggy yaird by initramfs-tools) just after installing it
and rebooting on it, the problem reappeared since, though I didn't change
anything in the config of the machine. However /dev/mixer disappeared for
an unknown reason (see below).

With 2.6.25-4:

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
ALSA snd_pcm_open error: No such file or directory
Error: Cannot open device alsa.

ay:~> lsmod
Module Size Used by
xt_multiport 3200 0
iptable_filter 3424 1
ip_tables 14832 1 iptable_filter
x_tables 17380 2 xt_multiport,ip_tables
ipv6 286556 35
dm_snapshot 20704 0
dm_mirror 28640 0
dm_mod 65960 2 dm_snapshot,dm_mirror
pcmcia 41584 0
firmware_class 10048 1 pcmcia
uninorth_agp 10760 1
agpgart 37020 1 uninorth_agp
evdev 13056 5
yenta_socket 28140 1
rsrc_nonstatic 11808 1 yenta_socket
pcmcia_core 42072 3 pcmcia,yenta_socket,rsrc_nonstatic
ext3 145416 2
jbd 50772 1 ext3
mbcache 8864 1 ext3
ide_cd_mod 37444 0
cdrom 37852 1 ide_cd_mod
ide_disk 16384 4
firewire_ohci 25988 0
sungem 33156 0
firewire_core 42072 1 firewire_ohci
crc_itu_t 1984 1 firewire_core
sungem_phy 11680 1 sungem
i2c_powermac 5504 0

When I did a lsmod just after installing linux-image-2.6.25-2-powerpc
2.6.25-3 and rebooting on this kernel on May 28:

Module Size Used by
snd_powermac 47096 1
snd_pcm_oss 46208 0
snd_mixer_oss 18240 2 snd_pcm_oss
snd_pcm 81060 2 snd_powermac,snd_pcm_oss
snd_timer 24964 1 snd_pcm
snd 59668 5 snd_powermac,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer
snd_page_alloc 10952 1 snd_pcm
soundcore 7716 2 snd
xt_multiport 3200 0
iptable_filter 3424 1
ip_tables 14832 1 iptable_filter
x_tables 17380 2 xt_multiport,ip_tables
ipv6 286556 35
ide_cd_mod 37444 0
cdrom 37852 1 ide_cd_mod
sungem 33156 0
sungem_phy 11680 1 sungem
firewire_ohci 25988 0
firewire_core 42072 1 firewire_ohci
crc_itu_t 1984 1 firewire_core
yenta_socket 28140 0
rsrc_nonstatic 11808 1 yenta_socket
pcmcia_core 42072 2 yenta_socket,rsrc_nonstatic
uninorth_agp 10760 1
agpgart 37020 1 uninorth_agp
sd_mod 29584 0
scsi_mod 159556 1 sd_mod
dm_snapshot 20704 0
dm_mirror 28640 0
dm_mod 65960 2 dm_snapshot,dm_mirror
ext3 145416 2
jbd 50772 1 ext3
mbcache 8864 1 ext3
ide_disk 16384 4
evdev 13056 4
i2c_powermac 5504 0
windfarm_core 12912 0

So, something has changed, but apparently not in the module config.
FYI, I currently have:

ay:~> ll /etc/mod*
-rw-r--r-- 1 root root 2471 2004-03-24 19:37:35 /etc/modprobe.devfs
-rw-r--r-- 1 root root 274 2007-01-19 05:47:03 /etc/modules
-rw-r--r-- 1 root root 9343 2006-08-05 23:22:55 /etc/modules.conf~
-rw-r--r-- 1 root root 271 2007-01-19 05:32:28 /etc/modules~

/etc/modprobe.d:
total 64
-rw-r--r-- 1 root root 4619 2008-04-05 05:06:14 aliases
-rw-r--r-- 1 root root 21669 2008-02-20 12:10:54 alsa-base
-rw-r--r-- 1 root root 156 2006-12-29 13:04:24 alsa-base-blacklist
drwxr-xr-x 2 root root 4096 2008-04-17 01:27:37 arch/
lrwxrwxrwx 1 root root 17 2008-04-17 01:27:37 arch-aliases -> arch/powerpc.pmac
-rw-r--r-- 1 root root 1406 2007-08-06 06:39:40 blacklist
-rw-r--r-- 1 root root 363 2004-03-24 19:37:35 crypto
-rw-r--r-- 1 root root 284 2007-08-06 06:39:40 display_class
-rw-r--r-- 1 root root 80 2004-08-30 11:50:19 local
lrwxrwxrwx 1 root root 21 2006-10-15 18:51:34 oss-compat -> /lib/oss-compat/linux
-rw-r--r-- 1 root root 363 2007-08-06 06:39:40 pnp-hotplug
-rw-r--r-- 1 root root 59 2006-08-06 20:15:20 sound

/etc/modutils:
total 16
-rw-r--r-- 1 root root 97 2003-04-17 07:35:44 apm
-rw-r--r-- 1 root root 760 2002-05-07 05:29:10 irda
-rw-r--r-- 1 root root 252 2001-09-29 14:53:46 ppp
-rw-r--r-- 1 root root 651 2001-11-08 02:36:41 setserial

As you can see, nothing has changed in these files recently.

I don't know if this is related (I've added comments inside brackets):

ay:~> grep pbbuttonsd /var/log/daemon.log
[reboot on May 28 03:25 - 2.6.25-3]
May 28 03:25:53 ay pbbuttonsd: INFO: Initialized: SysFS Backlight Driver
May 28 03:25:59 ay pbbuttonsd: INFO: Soundsystem requested: OSS and at least activated: OSS.
May 28 03:25:59 ay pbbuttonsd: INFO: saving of config enabled to /etc/pbbuttonsd.conf.
May 28 03:25:59 ay pbbuttonsd: INFO: pbbuttonsd 0.7.9: PowerBook G4 Titanium (Dec 2000) - PMU version: 12
May 28 03:26:07 ay pbbuttonsd: INFO: Script '/etc/power/pmcs-pbbuttonsd performance ac ' lauched but killed after 8 seconds
[lid closed and reopened on May 28 17:10]
May 28 17:10:08 ay pbbuttonsd: INFO: Script '/etc/power/pmcs-pbbuttonsd suspend ac ram' launched and exited normally
May 28 17:10:26 ay pbbuttonsd: INFO: Script '/etc/power/pmcs-pbbuttonsd resume ac ram' launched and exited normally
[reboot on May 29 15:55 - 2.6.25-3]
May 29 15:56:20 ay pbbuttonsd: INFO: Initialized: SysFS Backlight Driver
May 29 15:56:20 ay pbbuttonsd: ERROR: Can't open mixer device [/dev/mixer]. No such file or directory
May 29 15:56:20 ay pbbuttonsd: INFO: Soundsystem requested: OSS and at least activated: none.
May 29 15:56:20 ay pbbuttonsd: INFO: saving of config enabled to /etc/pbbuttonsd.conf.
May 29 15:56:21 ay pbbuttonsd: INFO: pbbuttonsd 0.7.9: PowerBook G4 Titanium (Dec 2000) - PMU version: 12
May 29 15:56:29 ay pbbuttonsd: INFO: Script '/etc/power/pmcs-pbbuttonsd performance ac ' launched and exited normally
[reboot on May 29 23:27 - 2.6.25-4]
May 29 23:27:35 ay pbbuttonsd: INFO: Initialized: SysFS Backlight Driver
May 29 23:27:35 ay pbbuttonsd: ERROR: Can't open mixer device [/dev/mixer]. No such file or directory
May 29 23:27:35 ay pbbuttonsd: INFO: Soundsystem requested: OSS and at least activated: none.
May 29 23:27:35 ay pbbuttonsd: INFO: saving of config enabled to /etc/pbbuttonsd.conf.
May 29 23:27:35 ay pbbuttonsd: INFO: pbbuttonsd 0.7.9: PowerBook G4 Titanium (Dec 2000) - PMU version: 12
May 29 23:27:43 ay pbbuttonsd: INFO: Script '/etc/power/pmcs-pbbuttonsd performance ac ' lauched but killed after 8 seconds

--
Vincent Lefèvre <vincent@vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Vincent Lefevre 05-30-2008 12:53 AM

Bug#408746: closed by maximilian attems ( snd* modules are not autoloaded when udev is installed)
 
On 2008-05-30 02:31:34 +0200, Vincent Lefevre wrote:
> However /dev/mixer disappeared for an unknown reason (see below).

I suppose that the cause is that the modules are not loaded.

If I type:

modprobe snd_aoa
modprobe snd-powermac

then sound is working again.

--
Vincent Lefèvre <vincent@vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Vincent Lefevre 05-30-2008 01:37 AM

Bug#408746: closed by maximilian attems ( snd* modules are not autoloaded when udev is installed)
 
Other users have the same problem:

http://lists.debian.org/debian-powerpc/2007/12/msg00047.html
http://lists.debian.org/debian-powerpc/2007/12/msg00066.html

--
Vincent Lefèvre <vincent@vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Moritz Muehlenhoff 11-13-2008 10:19 PM

Bug#408746: closed by maximilian attems ( snd* modules are not autoloaded when udev is installed)
 
On Fri, May 30, 2008 at 02:31:34AM +0200, Vincent Lefevre wrote:
> reopen 408746
> found 408746 2.6.25-4
> thanks
>
> While I didn't have any problem with linux-image-2.6.25-2-powerpc 2.6.25-3
> (at the same time, udev was installed due to dependencies, because I had
> to replace the buggy yaird by initramfs-tools) just after installing it
> and rebooting on it, the problem reappeared since, though I didn't change
> anything in the config of the machine. However /dev/mixer disappeared for
> an unknown reason (see below).

Does this error still occur with the current Lenny kernel?

Cheers,
Moritz



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Vincent Lefevre 01-02-2009 04:33 PM

Bug#408746: closed by maximilian attems ( snd* modules are not autoloaded when udev is installed)
 
found 408746 2.6.26-12
thanks

On 2008-11-14 00:19:46 +0100, Moritz Muehlenhoff wrote:
> Does this error still occur with the current Lenny kernel?

It still occurs with linux-image-2.6.26-1-powerpc 2.6.26-12.
The behavior is in fact documented here:

http://www.debian.org/releases/etch/debian-installer/index.en.html

the snd-powermac module is no longer loaded by default as it will
lock up some systems; you will need to add it to /etc/modules
manually

I don't know if it still locks some systems, though (the module
works correctly on my PowerBook G4 machine). Also, the above page
doesn't mention a bug report and I couldn't find any. So, IMHO,
the module should be removed from the blacklist.

--
Vincent Lefèvre <vincent@vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 10:02 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.