FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 06-29-2012, 08:35 PM
Zack Weinberg
 
Default Bug#679571: "modprobe: no module unix found in modules.dep"

Package: initramfs-tools
Version: 0.106
Severity: normal

No matter how I configure the initramfs, I always get the warning message

modprobe: no module unix found in modules.dep

on boot.

The configuration below is for my regular desktop, which has continuously
tracked unstable since before squeeze, and may therefore have Weird Shit
in it. However, I see exactly the same error message on a fresh install
of wheezy-to-be with all kernel-related configuration left at the
defaults, using this installer image:

aa4082a89b8ff92cf35fda56349069139243ea55 debian-wheezy-DI-a1-i386-businesscard.iso

-- Package-specific info:
-- initramfs sizes
-- /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.2.0-3-amd64 root=UUID=80eabe2b-76e2-4a6c-a00e-df8e6cc0dc1d ro quiet

-- resume
RESUME=UUID=0fbd36df-8e69-476f-9191-f74dcd10245b
-- /proc/filesystems
ext4
fuseblk

-- lsmod
Module Size Used by
nouveau 545197 3
video 17628 1 nouveau
ttm 48725 1 nouveau
drm_kms_helper 27227 1 nouveau
drm 167670 5 drm_kms_helper,ttm,nouveau
i2c_algo_bit 12841 1 nouveau
parport_pc 22364 0
bnep 17567 2
ppdev 12763 0
rfcomm 33656 0
bluetooth 119406 10 rfcomm,bnep
rfkill 19012 3 bluetooth
lp 17149 0
parport 31858 3 lp,ppdev,parport_pc
cpufreq_userspace 12576 0
cpufreq_stats 12866 0
cpufreq_conservative 13147 0
cpufreq_powersave 12454 0
pci_stub 12429 1
vboxpci 19103 0
vboxnetadp 25443 0
vboxnetflt 23608 1
vboxdrv 186009 4 vboxnetflt,vboxnetadp,vboxpci
binfmt_misc 12957 1
microcode 25793 0
fuse 61981 1
joydev 17266 0
usb_storage 43870 0
uas 13296 0
hid_microsoft 12627 0
usbhid 36379 0
hid 81288 2 usbhid,hid_microsoft
snd_hda_codec_realtek 188797 1
snd_hda_intel 26345 2
snd_hda_codec 78031 2 snd_hda_intel,snd_hda_codec_realtek
snd_hwdep 13186 1 snd_hda_codec
snd_pcm 63900 2 snd_hda_codec,snd_hda_intel
snd_page_alloc 13003 2 snd_pcm,snd_hda_intel
snd_seq 45093 0
snd_seq_device 13176 1 snd_seq
snd_timer 22917 2 snd_seq,snd_pcm
snd 52850 12 snd_timer,snd_seq_device,snd_seq,snd_pcm,snd_hwdep ,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek
soundcore 13065 1 snd
sr_mod 21899 0
cdrom 35401 1 sr_mod
uhci_hcd 26865 0
acpi_cpufreq 12935 0
mperf 12453 1 acpi_cpufreq
ehci_hcd 40215 0
usbcore 128498 6 ehci_hcd,uhci_hcd,usbhid,uas,usb_storage
mxm_wmi 12473 1 nouveau
iTCO_wdt 17081 0
iTCO_vendor_support 12704 1 iTCO_wdt
i2c_i801 16870 0
i2c_core 23876 5 i2c_i801,i2c_algo_bit,drm,drm_kms_helper,nouveau
pcspkr 12579 0
wmi 13243 1 mxm_wmi
r8169 46980 0
processor 28157 1 acpi_cpufreq
thermal_sys 18040 2 processor,video
coretemp 12898 0
mii 12675 1 r8169
psmouse 64455 0
serio_raw 12931 0
evdev 17562 10
usb_common 12354 1 usbcore
button 12937 1 nouveau
crc32c_intel 12747 0
ext4 350411 2
crc16 12343 2 ext4,bluetooth
jbd2 62015 1 ext4
mbcache 13065 1 ext4
sd_mod 36136 4
crc_t10dif 12348 1 sd_mod
ata_generic 12479 0
ata_piix 29535 3
libata 140589 2 ata_piix,ata_generic
scsi_mod 162372 5 libata,sd_mod,sr_mod,uas,usb_storage

-- /etc/initramfs-tools/modules

-- /etc/kernel-img.conf
# Kernel image management overrides
# See kernel-img.conf(5) for details
do_symlinks = no
do_bootloader = no
do_initrd = yes
link_in_boot = no

-- /etc/initramfs-tools/initramfs.conf
MODULES=most
BUSYBOX=y
KEYMAP=n
COMPRESS=gzip
BOOT=local
DEVICE=
NFSROOT=auto

-- /etc/initramfs-tools/update-initramfs.conf
update_initramfs=yes
backup_initramfs=no

-- /sys/block
sda
sdb
sr0

-- mkinitramfs hooks
/etc/initramfs-tools/hooks/:

/usr/share/initramfs-tools/hooks:
busybox
dmsetup
fuse
iscan_data
keymap
klibc
kmod
ntfs_3g
thermal
udev


-- System Information:
Debian Release: wheezy/sid
APT prefers unstable
APT policy: (501, 'unstable'), (500, 'testing'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages initramfs-tools depends on:
ii cpio 2.11-8
ii klibc-utils 2.0.1-1
ii kmod 9-1
ii module-init-tools 9-1
ii udev 175-3.1

Versions of packages initramfs-tools recommends:
ii busybox 1:1.20.0-4

Versions of packages initramfs-tools suggests:
pn bash-completion <none>

-- no debconf information



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120629203504.4243.72421.reportbug@moxana.local
 
Old 06-30-2012, 07:07 AM
Michael Prokop
 
Default Bug#679571: "modprobe: no module unix found in modules.dep"

* Zack Weinberg [Fri Jun 29, 2012 at 01:35:04PM -0700]:

> No matter how I configure the initramfs, I always get the warning message

> modprobe: no module unix found in modules.dep

> on boot.
[...]

This is #654282 (package udev)

regards,
-mika-
 

Thread Tools




All times are GMT. The time now is 01:49 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org