FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 03-29-2012, 09:53 PM
Jonathan Nieder
 
Default Bug#666156: kernel fails to build correctly on PPC due to w-lan-module

Hi Andreas,

Andreas Glaeser wrote:

> The current kernel sources in testing failed to build. The error message said
> 'net/wireless/cfg80211.0' failed to load (LD) and 'debian/stamp/build/kernel Error 2'. So
> I disabled all the wireless lan driver-modules, because I do not need them anyway. This
> helped. Then
[...]

This message contained two bug reports. I'm going to focus on the one
that won a place on the subject line and ignore the other one.

Please attach your .config and a log from the broken build. (Just
running "debian/rules build" should be enough to reproduce the error
and hence the interesting part of the log.)

Thanks,
Jonathan



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120329215331.GA26941@burratino">http://lists.debian.org/20120329215331.GA26941@burratino
 
Old 04-05-2012, 04:32 PM
Andreas Glaeser
 
Default Bug#666156: kernel fails to build correctly on PPC due to w-lan-module

On Thu, 29 Mar 2012 16:53:31 -0500
Jonathan Nieder <jrnieder@gmail.com> wrote:

> Hi Andreas,
>
> Andreas Glaeser wrote:
>
> > The current kernel sources in testing failed to build. The error message said
> > 'net/wireless/cfg80211.0' failed to load (LD) and 'debian/stamp/build/kernel Error
> > 2'. So I disabled all the wireless lan driver-modules, because I do not need them
> > anyway. This helped. Then
> [...]
>
> This message contained two bug reports. I'm going to focus on the one
> that won a place on the subject line and ignore the other one.
>
> Please attach your .config and a log from the broken build. (Just
> running "debian/rules build" should be enough to reproduce the error
> and hence the interesting part of the log.)
>
> Thanks,
> Jonathan

'debian/rules build' really did not produce much informative output upon having done
'make clean'. So I tried to reproduce the problem by rebuilding [see attachments
'build-*'. Before the re-build I reconfigured the kernel-source with all w-lan modules and
options enabled except debug-ones [see attached 'config-3.2.12g4eg-breprod.gz']. In spite
of unchanged kernel-source this was unsuccessful, it built OK.The result is a workable
kernel-image with the 'silent-boot'-feature described in the original report, the part of
it you are ignoring, and a yellow dyed screen. So it should be safe now to close this bug.

Greetings

Andreas
 

Thread Tools




All times are GMT. The time now is 10:11 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org