FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 02-13-2012, 01:27 PM
stef schip
 
Default Bug#659521: bug confirmed on debian testing installation

I confirm the bug
on my laptop, equipped with AR9285 (module ath9k) wireless chip.

the laptop (samsung N220 netbook) has a fairly clean debian testing installation,

after kernel upgrade from 3.1.0-1-686-pae to 3.2.0-1-686-pae connection to a wifi router with WEP encryption (*) does not work anymore.
i can setup the interface with manual ifconfig / iwconfig commands, no errors are reported,


some wireless functionality is present, for example running "iwlist
wlan0 scan" gives me router wifi channel, executing 'iwconfig wlan0'
shows me the wifi interface is associated with the router, so everything
seems correct. But no packets are transmitted nor received over the
wireless link.



I have manually installed the older 3.1.0-2 kernel (vmlinuz,
initrd, /lib/modules/3.1.0-1-686-pae stuff) , added a menu entry in
grub,
rebooting the laptop with the older kernel fixes the problem, the wifi network works as it used to do before the kernel upgrade.


---
.(*) i know
, wep is broken and flawed and should be avoided, i know the risk, and
the environment where i use this old router is safe enough
the router does not support newer protocols (WPA) and i dont want to spend money :-)
 

Thread Tools




All times are GMT. The time now is 01:39 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org