FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 02-06-2012, 03:58 AM
Jonathan Nieder
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

Hi Ben,

Ben Finney wrote:

> On the same system, selecting Linux 2.6.32-5-amd64 (from the GRUB menu)
> results in uncorrupted display also.
>
> So the problem is restricted to Linux 3.1.0-1 on this system.

Does this happen with version 3.2.4-1 from sid, too? Can you bisect?

Even a few tests of versions halfway between from
http://snapshot.debian.org/ can help a lot in narrowing down the cause
of this particular regression.

See http://bugs.debian.org/607194 and the bugs merged with it for some
background.

Thanks and hope that helps,
Jonathan



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120206045831.GB3407@burratino">http://lists.debian.org/20120206045831.GB3407@burratino
 
Old 02-06-2012, 10:50 AM
Ben Finney
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

package src:linux-2.6
found 658764 3.1.8-2
found 658764 3.2.4-1
thanks

On 05-Feb-2012, Jonathan Nieder wrote:
> Does this happen with version 3.2.4-1 from sid, too?

I'm confused about which version to get; the names are weird:

Unpacking linux-image-3.2.0-1-amd64 (from .../linux-image-3.2.0-1-amd64_3.2.4-1_amd64.deb)

So that's either 3.2.0 or 3.2.4, I'm not sure.

Whichever one that is, the same problem occurs.

> Can you bisect?

I'll try to do so.

> Even a few tests of versions halfway between from
> http://snapshot.debian.org/ can help a lot in narrowing down the cause of
> this particular regression.

Okay. Which dates would be of interest for bisecting between Linux 2.6.32
and 3.1.0 packages?

--
“People are very open-minded about new things, as long as |
` they're exactly like the old ones.” —Charles F. Kettering |
_o__) |
Ben Finney <ben@benfinney.id.au>
 
Old 02-06-2012, 12:13 PM
Ben Hutchings
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

On Mon, Feb 06, 2012 at 10:50:37PM +1100, Ben Finney wrote:
> package src:linux-2.6
> found 658764 3.1.8-2
> found 658764 3.2.4-1
> thanks
>
> On 05-Feb-2012, Jonathan Nieder wrote:
> > Does this happen with version 3.2.4-1 from sid, too?
>
> I'm confused about which version to get; the names are weird:
>
> Unpacking linux-image-3.2.0-1-amd64 (from .../linux-image-3.2.0-1-amd64_3.2.4-1_amd64.deb)
>
> So that's either 3.2.0 or 3.2.4, I'm not sure.
[...]

It's really 3.2.4, but the release reported by 'uname -r' will be
'3.2.0-1-amd64'. We leave out the '.4' so that it is not necessary to
rebuild out-of-tree modules for each stable update, but we have to
substitute something to avoid breaking programs that expect three
dotted numbers at the start.

Ben.

--
Ben Hutchings
We get into the habit of living before acquiring the habit of thinking.
- Albert Camus



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120206131344.GY12704@decadent.org.uk">http://lists.debian.org/20120206131344.GY12704@decadent.org.uk
 
Old 02-26-2012, 07:37 AM
Ben Finney
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

On 06-Feb-2012, Ben Finney wrote:
> On 05-Feb-2012, Jonathan Nieder wrote:
> > Can you bisect?
>
> I'll try to do so.
>
> > Even a few tests of versions halfway between from
> > http://snapshot.debian.org/ can help a lot in narrowing down the cause
> > of this particular regression.
>
> Okay. Which dates would be of interest for bisecting between Linux 2.6.32
> and 3.1.0 packages?

I'm confused by what you want me to do. The page at
<URL:http://snapshot.debian.org/binary/linux-image-2.6-amd64/> lists many
packages, and I don't really know how to satisfy the dependencies of what I
download from there.

Can you give me some more specific requests for tests you would like me to
run, and how to get the packages you want me to test?

--
“It is not enough to have a good mind. The main thing is to use |
` it well.” —Rene Descartes |
_o__) |
Ben Finney <ben@benfinney.id.au>
 
Old 02-26-2012, 07:43 AM
Jonathan Nieder
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

Ben Finney wrote:
>> On 05-Feb-2012, Jonathan Nieder wrote:

>>> Can you bisect?
[...]
> I'm confused by what you want me to do. The page at
> <URL:http://snapshot.debian.org/binary/linux-image-2.6-amd64/> lists many
> packages, and I don't really know how to satisfy the dependencies of what I
> download from there.

Easier to work from <http://snapshot.debian.org/package/linux-2.6/>.

linux-image-2.6-amd64 is just a dependency package and does not
contain the kernel itself.

Thanks and hope that helps,
Jonathan



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120226084329.GF3030@burratino">http://lists.debian.org/20120226084329.GF3030@burratino
 
Old 02-26-2012, 07:55 AM
Ben Finney
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

On 26-Feb-2012, Jonathan Nieder wrote:

> Easier to work from <http://snapshot.debian.org/package/linux-2.6/>.

Okay. So which package versions are of particular interest to test?

--
“Everything is futile.” —Marvin of Borg |
` |
_o__) |
Ben Finney <ben@benfinney.id.au>
 
Old 02-26-2012, 07:58 AM
Jonathan Nieder
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

Ben Finney wrote:
> On 26-Feb-2012, Jonathan Nieder wrote:

>> Easier to work from <http://snapshot.debian.org/package/linux-2.6/>.
>
> Okay. So which package versions are of particular interest to test?

If bisecting? The version halfway between the newest known-good and oldest
known-bad version.



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120226085832.GA10241@burratino">http://lists.debian.org/20120226085832.GA10241@burratino
 
Old 02-26-2012, 11:12 PM
Ben Finney
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

package linux-2.6
found 658764 2.6.38-3
thanks

On 06-Feb-2012, Ben Finney wrote:
> On 05-Feb-2012, Jonathan Nieder wrote:
> > Can you bisect?
>
> I'll try to do so.
>
> > Even a few tests of versions halfway between from
> > http://snapshot.debian.org/ can help a lot in narrowing down the cause
> > of this particular regression.

I have done some bisecting; I've shown that this occurs in version 2.6.38-3
and not in version 2.6.32-31.

Details from my notes:

* http://snapshot.debian.org/archive/debian/20110401T000000Z/

* Install linux-image-2.6.32-5-amd64, version 2.6.32-31.
* Initial Linux console: normal.
* Framebuffer text console: no signal to monitor.
* Graphics console: normal.
* gnome-shell mode: fallback, no acceleration.

* http://snapshot.debian.org/archive/debian/20110508T152014Z/

* Install linux-image-2.6.38-2-amd64, version 2.6.38-3.
* Initial Linux console: normal.
* Framebuffer text console: coloured pixel noise from to to middle, remainder blank.
* Graphics console: coloured pixel noise near bottom, remainder blank.

--
“I bought a self learning record to learn Spanish. I turned it |
` on and went to sleep; the record got stuck. The next day I |
_o__) could only stutter in Spanish.” —Steven Wright |
Ben Finney <ben@benfinney.id.au>
 
Old 02-28-2012, 10:21 AM
Ben Finney
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

package linux-2.6
found 658764 3.2.6-1
thanks

I have installed ‘linux-image-3.2.0-1-amd64’ version 3.2.6-1 now that it is
in Wheezy, and confirmed the same behaviour.

--
“First things first, but not necessarily in that order.” —The |
` Doctor, _Doctor Who_ |
_o__) |
Ben Finney <ben@benfinney.id.au>
 
Old 03-12-2012, 07:53 PM
Ben Finney
 
Default Bug#658764: free ATI driver corrupts output on Radeon HD 6310

package linux-2.6
found 658764 3.2.9-1
thanks

I have installed ‘linux-image-3.2.0-2-amd64’ version 3.2.9-1 now that it is
in Wheezy, and confirmed the same behaviour.

Is the range of version information enough now to narrow down the source of
the problem? What can I do to help you get this problem fixed?

--
“Natural catastrophes are rare, but they come often enough. We |
` need not force the hand of nature.” —Carl Sagan, _Cosmos_, 1980 |
_o__) |
Ben Finney <ben@benfinney.id.au>



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120312205351.GM5951@benfinney.id.au">http://lists.debian.org/20120312205351.GM5951@benfinney.id.au
 

Thread Tools




All times are GMT. The time now is 01:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org