Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Kernel (http://www.linux-archive.org/debian-kernel/)
-   -   Bug#652955: Naming inconsistancy? can cause dkms/m-a problems (http://www.linux-archive.org/debian-kernel/612707-bug-652955-naming-inconsistancy-can-cause-dkms-m-problems.html)

David Baron 12-22-2011 07:38 AM

Bug#652955: Naming inconsistancy? can cause dkms/m-a problems
 
On Thursday 26 Kislev 5772 10:17:12 Jonathan Nieder wrote:
> tags 652955 + moreinfo
> quit
>
> Hi David,
>
> David Baron wrote:
> > If I have the same kernel version installed for both i686 and amd64, for
> > example. The debian nvidia kernel modules will dkms successfully on both
> > while the debian virtualbox kernel modules will dkms only for one of
> > them.
>
> Please supply details, including the error message.
>

I had removed the headers for the kernel
Reinstalling them (running the 32-bit kernel):

...Selecting previously unselected package linux-headers-3.1.0-1-amd64.
(Reading database ... 522370 files and directories currently installed.)
Unpacking linux-headers-3.1.0-1-amd64 (from .../linux-headers-3.1.0-1-
amd64_3.1.5-1_i386.deb) ...
Setting up linux-headers-3.1.0-1-amd64 (3.1.5-1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.1.0-1-amd64

Good news! Module version 4.1.6_Debian for vboxdrv.ko
exactly matches what is already found in kernel 3.1.0-1-amd64.
DKMS will not replace this module.
You may override by specifying --force.

Good news! Module version 4.1.6_Debian for vboxnetadp.ko
exactly matches what is already found in kernel 3.1.0-1-amd64.
DKMS will not replace this module.
You may override by specifying --force.

Good news! Module version 4.1.6_Debian for vboxnetflt.ko
exactly matches what is already found in kernel 3.1.0-1-amd64.
DKMS will not replace this module.
You may override by specifying --force.
Error! Module version 4.1.6_Debian for vboxpci.ko
is not newer than what is already found in kernel 3.1.0-1-amd64
(4.1.6_Debian).
You may override by specifying --force.

Yesterday when I was in that kernel, it did not load these modules so they may
be built for the wrong architecture. Next time I boot up the 64 bit kernel, I
will try again.

(That pci module fails in all the kernels. I generally only need the vboxdrv
module.)



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201112221038.21095.d_baron@012.net.il">http://lists.debian.org/201112221038.21095.d_baron@012.net.il


All times are GMT. The time now is 05:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.