FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 08-29-2011, 12:19 PM
Sean Finney
 
Default Bug#639691: nfs-utils: Needs versioned build-dep on libnfsidmap-dev >= 0.24

Package: nfs-utils
Version: 1.2.4-1
Severity: normal

The upstream m4/autofoo only enables nfsidmapd related stuff if it
finds certain api functions available, which after some investigation
appears to have been introduced in 0.24.

This will otherwise cause FTBFS's for anyone wanting to backport to an
older debian/ubuntu release, as I've just found out, due to commit 3d3bc354
which unconditionally tries to install manpages and binaries for it.

I suggest eitehr adding the strict build-deps, or alternatively making
the dh logic a bit smarter for whether it should attempt to install them.


-- System Information:
Debian Release: 6.0.2
APT prefers stable
APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-xen-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF8, LC_CTYPE=en_US.UTF8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110829121916.25276.46234.reportbug@localhost.loc aldomain">http://lists.debian.org/20110829121916.25276.46234.reportbug@localhost.loc aldomain
 

Thread Tools




All times are GMT. The time now is 10:07 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org