On Tue, Jun 21, 2011 at 10:34:12AM +0200, Ales Kozumplik wrote:
> On 06/20/2011 07:11 PM, Brian C. Lane wrote:
> >I don't like using 'string' here since it could be a module name.
> >Admittedly, one that shouldn't be used.
> I renamed it to 'setup_arg'.
> >I'd also like to see dracutSetupString() renamed to something like
> >dracutSetupArgs() -- I was a bit confused as to what was happening since
> >I thought the return value was a string, not a set.
> Right, renamed to dracutSetupArgs everywhere.
> >These changes are fairly extensive, so it would probably be a good idea
> >to cover them with some unit tests to make sure something hasn't been
> I thought about that but it is split over several modules and needs
> a lot of different objects to be instantiated and none of them are
> under the test harness yet. Perhaps on master once the bootloader
> has unit tests.
Sounds reasonable. Ack
Brian C. Lane | Anaconda Team | IRC: bcl #anaconda | Port Orchard, WA (PST8PDT)
Anaconda-devel-list mailing list