Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Kernel (http://www.linux-archive.org/debian-kernel/)
-   -   Bug#619298: Please enable CONFIG_TARGET_CORE for >= 2.6.38-1-amd64 (http://www.linux-archive.org/debian-kernel/504357-bug-619298-please-enable-config_target_core-2-6-38-1-amd64.html)

Edison Wong 03-20-2011 06:23 AM

Bug#619298: Please enable CONFIG_TARGET_CORE for >= 2.6.38-1-amd64
 
Package: linux-2.6
Version: 2.6.38-1
Severity: wishlist
Tags: sid

Please consider enabling CONFIG_TARGET_CORE, so lio-utils from http://linux-iscsi.org/ can function with:

--- /boot/config-2.6.38-1-amd64 2011-03-17 01:45:06.000000000 +0800
+++ /usr/src/linux-source-2.6.38/.config 2011-03-20 14:33:04.995029263 +0800
@@ -1852,7 +1852,10 @@ CONFIG_DM_MULTIPATH_QL=m
CONFIG_DM_MULTIPATH_ST=m
CONFIG_DM_DELAY=m
CONFIG_DM_UEVENT=y
-# CONFIG_TARGET_CORE is not set
+CONFIG_TARGET_CORE=m
+CONFIG_TCM_IBLOCK=m
+CONFIG_TCM_FILEIO=m
+CONFIG_TCM_PSCSI=m
CONFIG_FUSION=y
CONFIG_FUSION_SPI=m
CONFIG_FUSION_FC=m

-- Package-specific info:
** Kernel log: boot messages should be attached


-- System Information:
Debian Release: wheezy/sid
APT prefers testing
APT policy: (700, 'testing'), (650, 'stable'), (600, 'unstable'), (550, 'experimental'), (500, 'squeeze-updates')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38 (SMP w/4 CPU cores)
Locale: LANG=en_HK.UTF-8, LC_CTYPE=en_HK.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages linux-image-2.6.38-1-amd64 depends on:
ii debconf [debconf-2.0] 1.5.38 Debian configuration management sy
ii initramfs-tools [linux-initra 0.98.8 tools for generating an initramfs
ii linux-base 3 Linux image base package
ii module-init-tools 3.12-1 tools for managing Linux kernel mo

Versions of packages linux-image-2.6.38-1-amd64 recommends:
ii firmware-linux-free 3 Binary firmware for various driver

Versions of packages linux-image-2.6.38-1-amd64 suggests:
ii grub-pc 1.98+20100804-14 GRand Unified Bootloader, version
ii linux-doc-2.6.38 2.6.38-1 Linux kernel specific documentatio

Versions of packages linux-image-2.6.38-1-amd64 is related to:
pn firmware-bnx2 <none> (no description available)
pn firmware-bnx2x <none> (no description available)
pn firmware-ipw2x00 <none> (no description available)
pn firmware-ivtv <none> (no description available)
pn firmware-iwlwifi <none> (no description available)
ii firmware-linux 0.29 Binary firmware for various driver
ii firmware-linux-nonfree 0.29 Binary firmware for various driver
pn firmware-qlogic <none> (no description available)
pn firmware-ralink <none> (no description available)
pn xen-hypervisor <none> (no description available)

-- debconf information:
linux-image-2.6.38-1-amd64/prerm/removing-running-kernel-2.6.38-1-amd64: true
linux-image-2.6.38-1-amd64/postinst/ignoring-do-bootloader-2.6.38-1-amd64:
linux-image-2.6.38-1-amd64/postinst/missing-firmware-2.6.38-1-amd64:
linux-image-2.6.38-1-amd64/postinst/depmod-error-initrd-2.6.38-1-amd64: false



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110320072351.29308.59559.reportbug@vms01.pantare i-design.com">http://lists.debian.org/20110320072351.29308.59559.reportbug@vms01.pantare i-design.com

Ben Hutchings 03-29-2011 03:52 AM

Bug#619298: Please enable CONFIG_TARGET_CORE for >= 2.6.38-1-amd64
 
On Sun, 2011-03-20 at 15:23 +0800, Edison Wong wrote:
> Package: linux-2.6
> Version: 2.6.38-1
> Severity: wishlist
> Tags: sid
>
> Please consider enabling CONFIG_TARGET_CORE, so lio-utils from
> http://linux-iscsi.org/ can function with:
[...]

Are you interested in packaging lio-utils?

Ben.

--
Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.


All times are GMT. The time now is 07:34 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.