FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 11-05-2010, 06:31 PM
Lakos Dániel
 
Default lenny - cannot start openvz since upgrade (linux-image-2.6.26-2-openvz-amd64) - kernel bug

Kernel:
linux-image-2.6.26-2-openvz-amd64 (2.6.26-25lenny1)

# /etc/init.d/vz start
Starting OpenVZ: failed to load module vzmon..failed

# modprobe vzmon
FATAL: Error inserting vzmon
(/lib/modules/2.6.26-2-openvz-amd64/kernel/kernel/ve/vzmon.ko): Unknown
symbol in module, or unknown parameter (see dmesg)

# dmesg
vzmon: Unknown symbol compat_alloc_user_space

Tried to downgrade to 2.6.26-1, and removed 2.6.26-2, but it loads 2.6.26-2.
Boot with linux-image-2.6.26-1-openvz-amd64.
# uname -a
Linux vga 2.6.26-2-openvz-amd64 #1 SMP Tue Mar 9 23:10:10 UTC 2010
x86_64 GNU/Linux


--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4CD45BAA.7050603@freemail.hu">http://lists.debian.org/4CD45BAA.7050603@freemail.hu
 
Old 11-06-2010, 06:47 PM
Jose R R
 
Default lenny - cannot start openvz since upgrade (linux-image-2.6.26-2-openvz-amd64) - kernel bug

2010/11/5 maximilian attems <max@stro.at>
>
> On Fri, Nov 05, 2010 at 08:31:54PM +0100, Lakos Dániel wrote:
> >
> > Kernel:
> > linux-image-2.6.26-2-openvz-amd64 (2.6.26-25lenny1)
> >
> > # /etc/init.d/vz start
> > Starting OpenVZ: failed to load module vzmon..failed
> >
> > # modprobe vzmon
> > FATAL: Error inserting vzmon
> > (/lib/modules/2.6.26-2-openvz-amd64/kernel/kernel/ve/vzmon.ko): Unknown
> > symbol in module, or unknown parameter (see dmesg)
> >
> > # dmesg
> > vzmon: Unknown symbol compat_alloc_user_space
> >
> > Tried to downgrade to 2.6.26-1, and removed 2.6.26-2, but it loads 2.6.26-2.
> > Boot with linux-image-2.6.26-1-openvz-amd64.
> > # uname -a
> > Linux vga 2.6.26-2-openvz-amd64 #1 SMP Tue Mar 9 23:10:10 UTC 2010
> > x86_64 GNU/Linux
>
> did you try to reboot? should cure aboves.

Indeed > Unknown symbol in module,< I have encountered this partial
message after operations in core components but those (error messages)
disappear and system is fine after reboot.

Cheers!



--
Jose R R
http://www.metztli-it.com
---------------------------------------------------------------------------------------------
IBM Lotus Symphony supported on GNU/Linux, Mac OS, and Windows.
---------------------------------------------------------------------------------------------
Daylight Saving Time in USA & Canada starts: Sunday 08 March 2010
---------------------------------------------------------------------------------------------


--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikSRSNg-f7ig_kgo3Q9aFC6UUW446FNAEYDXMUo@mail.gmail.com">ht tp://lists.debian.org/AANLkTikSRSNg-f7ig_kgo3Q9aFC6UUW446FNAEYDXMUo@mail.gmail.com
 

Thread Tools




All times are GMT. The time now is 12:25 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org