FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 11-03-2010, 10:29 AM
Matt Wallace
 
Default Issues with kssendmac and ks= whilst installing via PXELinux

Hi all,

I'm new to the list, so please forgive me if there is a more appropriate place
to ask.

I have a PXELinux configuration that looks as follows:

=============================

default linux
prompt 0
timeout 1
label linux
kernel /images/Centos-5.4-x86_64/vmlinuz
ipappend 2
append initrd=/images/Centos-5.4-x86_64/initrd.img ksdevice=bootif
lang= kssendmac text ks=http://192.168.122.1/api/kickstart/

=============================

If I run the following command (which according to Wireshark is sending the
exact same data as Anaconda except for the user agent), the webserver returns
the kickstart file to the terminal:

curl -0 -H "X-RHN-Provisioning-Mac_0: eth0 01:00:16:3e:5d:0f:2f"
http://192.168.122.1/api/kickstart/PxacIx06-kickstart

However Kickstart simply creates a "400 server error" and despite changing the
webserver logging to Debug mode, I can't seen any errors to help me resolve
this.

Does anyone know how I would start troubleshooting this?

Thanks,

Matt

_______________________________________________
Anaconda-devel-list mailing list
Anaconda-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/anaconda-devel-list
 

Thread Tools




All times are GMT. The time now is 07:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org