FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 09-24-2010, 02:03 PM
chevy
 
Default Bug#597952: initramfs-tools not up-dating correctly after aptitude full-upgrade today.

Package: initramfs-tools
Version: 0.98.3
Severity: important
Tags: l10n

After doing an aptitude update then aptitude full-upgrade, aptitude installed
two packages dnsmasq-base initramfs-tools. At the end of installing I recieved
the following error.

update-initramfs: Generating /boot/initrd.img-vmlinuz-2.6.32-5-openvz-amd64
grep: /boot/config-vmlinuz-2.6.32-5-openvz-amd64: No such file or directory
WARNING: missing /lib/modules/vmlinuz-2.6.32-5-openvz-amd64
Device driver support needs thus be built-in linux image!
FATAL: modules must be specified using absolute paths.
"vmlinuz-2.6.32-5-openvz-amd64" is a relative path
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
No such file or directory
WARNING: Couldn't open directory /tmp/mkinitramfs_71tuS0/lib/modules/2.6.32-5
-openvz-amd64: No such file or directory
FATAL: Could not open /tmp/mkinitramfs_71tuS0/lib/modules/2.6.32-5-openvz-
amd64/modules.dep.temp for writing: No such file or directory


I tryed doing an dpkg-reconfigure with the same results.

My real path is /lib/modules/2.6.32-5-openvz-amd64/modules.dep

-- Package-specific info:
-- initramfs sizes
-rw-r--r-- 1 root root 2.5M Sep 21 13:34 /boot/initrd.img-2.6.32-5-openvz-amd64
-rw-r--r-- 1 root root 2.6M Aug 22 23:31 /boot/initrd.img-2.6.32-trunk-amd64
-- /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-openvz-amd64 root=UUID=ae9c975f-317f-
4ee8-88d7-c99f409dddfa ro quiet




-- Package-specific info:
-- initramfs sizes
-rw-r--r-- 1 root root 2.5M Sep 21 13:34 /boot/initrd.img-2.6.32-5-openvz-amd64
-rw-r--r-- 1 root root 2.6M Aug 22 23:31 /boot/initrd.img-2.6.32-trunk-amd64
-- /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-openvz-amd64 root=UUID=ae9c975f-317f-4ee8-88d7-c99f409dddfa ro quiet

-- resume
RESUME=UUID=12518418-0a8f-46c1-ae30-a7f340c429fb
-- /proc/filesystems
ext3
fuseblk
udf
iso9660

-- lsmod
Module Size Used by
isofs 27480 0
nls_utf8 1208 0
udf 66324 0
crc_itu_t 1307 1 udf
hidp 11118 0
vzethdev 7253 0
vznetdev 17967 0
simfs 3039 0
vzrst 109518 0
vzcpt 96370 0
vzdquota 35030 0 [permanent]
vzmon 16285 4 vzethdev,vznetdev,vzrst,vzcpt
vboxnetadp 4209 0
vzdev 1824 4 vzethdev,vznetdev,vzdquota,vzmon
vboxnetflt 12525 0
xt_tcpudp 2319 0
xt_length 1164 0
xt_hl 1313 0
xt_tcpmss 1401 0
vboxdrv 1723495 2 vboxnetadp,vboxnetflt
xt_TCPMSS 2935 0
iptable_mangle 2881 0
iptable_filter 2322 0
xt_multiport 2267 0
xt_limit 1782 0
xt_dscp 1805 0
ipt_REJECT 1953 0
ip_tables 14107 2 iptable_mangle,iptable_filter
x_tables 13181 10 xt_tcpudp,xt_length,xt_hl,xt_tcpmss,xt_TCPMSS,xt_m ultiport,xt_limit,xt_dscp,ipt_REJECT,ip_tables
parport_pc 18855 0
ppdev 5046 0
lp 7478 0
parport 27954 3 parport_pc,ppdev,lp
sco 7209 2
bridge 40582 0
stp 1440 1 bridge
bnep 9379 2
rfcomm 29565 12
l2cap 24736 17 hidp,bnep,rfcomm
powernow_k8 10946 0
crc16 1319 1 l2cap
cpufreq_powersave 902 0
cpufreq_conservative 5162 0
cpufreq_stats 2659 0
cpufreq_userspace 1960 0
binfmt_misc 7133 1
fuse 50752 1
loop 11719 0
btusb 9833 2
bluetooth 41763 10 hidp,sco,bnep,rfcomm,l2cap,btusb
rfkill 12980 3 bluetooth
usbhid 33164 0
hid 62841 2 hidp,usbhid
snd_hda_codec_realtek 235570 0
snd_hda_intel 19955 4
snd_hda_codec 54244 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 5396 1 snd_hda_codec
snd_pcm_oss 32607 0
snd_mixer_oss 12622 1 snd_pcm_oss
snd_pcm 60519 4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_midi 4400 0
snd_rawmidi 15531 1 snd_seq_midi
snd_seq_midi_event 4628 1 snd_seq_midi
xhci 32909 0
ohci_hcd 19116 0
ehci_hcd 30911 0
snd_seq 42753 2 snd_seq_midi,snd_seq_midi_event
snd_timer 15598 3 snd_pcm,snd_seq
snd_seq_device 4493 3 snd_seq_midi,snd_rawmidi,snd_seq
usbcore 121858 6 btusb,usbhid,xhci,ohci_hcd,ehci_hcd
r8169 28749 0
sg 18680 0
edac_core 29245 0
snd 46462 17 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec, snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_ra wmidi,snd_seq,snd_timer,snd_seq_device
i2c_piix4 8328 0
soundcore 4598 1 snd
nls_base 6377 4 isofs,nls_utf8,udf,usbcore
nvidia 10874570 38
sr_mod 12682 0
mii 3210 1 r8169
edac_mce_amd 6401 0
snd_page_alloc 6201 2 snd_hda_intel,snd_pcm
i2c_core 15680 2 i2c_piix4,nvidia
ata_generic 2983 0
pata_atiixp 3457 1
cdrom 29415 1 sr_mod
pcspkr 1699 0
processor 30287 1 powernow_k8
button 4682 0
evdev 7368 15
ext3 106086 2
jbd 36845 1 ext3
mbcache 5050 1 ext3
sd_mod 29665 5
crc_t10dif 1276 1 sd_mod
ahci 32310 2
libata 133296 3 ata_generic,pata_atiixp,ahci
scsi_mod 121877 4 sg,sr_mod,sd_mod,libata
thermal 11754 0
thermal_sys 11942 2 processor,thermal

-- /etc/kernel-img.conf
# Kernel image management overrides
# See kernel-img.conf(5) for details
do_symlinks = yes
do_bootloader = yes
do_initrd = yes
link_in_boot = no

-- /etc/initramfs-tools/initramfs.conf
MODULES=most
BUSYBOX=y
KEYMAP=n
COMPRESS=gzip
BOOT=local
DEVICE=
NFSROOT=auto

-- /etc/initramfs-tools/update-initramfs.conf
update_initramfs=yes
backup_initramfs=no

-- mkinitramfs hooks
/etc/initramfs-tools/hooks/:

/usr/share/initramfs-tools/hooks:
busybox
dmsetup
keymap
klibc
thermal
udev


-- System Information:
Debian Release: squeeze/sid
APT prefers testing
APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-openvz-amd64 (SMP w/3 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages initramfs-tools depends on:
ii cpio 2.11-4 GNU cpio -- a program to manage ar
ii findutils 4.4.2-1 utilities for finding files--find,
ii klibc-utils 1.5.20-1 small utilities built with klibc f
ii module-init-tools 3.12-1 tools for managing Linux kernel mo
ii udev 160-1 /dev/ and hotplug management daemo

Versions of packages initramfs-tools recommends:
ii busybox 1:1.17.1-4 Tiny utilities for small and embed

Versions of packages initramfs-tools suggests:
ii bash-completion 1:1.2-2 programmable completion for the ba

-- no debconf information



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100924140344.3916.93978.reportbug@debian.ma.rr.c om">http://lists.debian.org/20100924140344.3916.93978.reportbug@debian.ma.rr.c om
 
Old 09-24-2010, 05:15 PM
maximilian attems
 
Default Bug#597952: initramfs-tools not up-dating correctly after aptitude full-upgrade today.

tags 597952 moreinfo unreproducible
stop

On Fri, Sep 24, 2010 at 10:03:44AM -0400, chevy wrote:
> Package: initramfs-tools
> Version: 0.98.3
> Severity: important
> Tags: l10n
>
> After doing an aptitude update then aptitude full-upgrade, aptitude installed
> two packages dnsmasq-base initramfs-tools. At the end of installing I recieved
> the following error.
>
> update-initramfs: Generating /boot/initrd.img-vmlinuz-2.6.32-5-openvz-amd64
> grep: /boot/config-vmlinuz-2.6.32-5-openvz-amd64: No such file or directory
> WARNING: missing /lib/modules/vmlinuz-2.6.32-5-openvz-amd64
> Device driver support needs thus be built-in linux image!
> FATAL: modules must be specified using absolute paths.
> "vmlinuz-2.6.32-5-openvz-amd64" is a relative path
> FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
> No such file or directory
> FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
> No such file or directory
> FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
> No such file or directory
> FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
> No such file or directory
> FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
> No such file or directory
> FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
> No such file or directory
> FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep:
> No such file or directory
> WARNING: Couldn't open directory /tmp/mkinitramfs_71tuS0/lib/modules/2.6.32-5
> -openvz-amd64: No such file or directory
> FATAL: Could not open /tmp/mkinitramfs_71tuS0/lib/modules/2.6.32-5-openvz-
> amd64/modules.dep.temp for writing: No such file or directory

what happened before? that log is truncated.


> I tryed doing an dpkg-reconfigure with the same results.
>
> My real path is /lib/modules/2.6.32-5-openvz-amd64/modules.dep
>
> -- Package-specific info:
> -- initramfs sizes
> -rw-r--r-- 1 root root 2.5M Sep 21 13:34 /boot/initrd.img-2.6.32-5-openvz-amd64
> -rw-r--r-- 1 root root 2.6M Aug 22 23:31 /boot/initrd.img-2.6.32-trunk-amd64
> -- /proc/cmdline
> BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-openvz-amd64 root=UUID=ae9c975f-317f-
> 4ee8-88d7-c99f409dddfa ro quiet

how was that image build?

please post output of these 2 commands:
sh -x /usr/sbin/mkinitramfs -o /tmp/foo 2.6.32-5-openvz-amd64

sh -x /usr/sbin/update-initramfs -u -k 2.6.32-5-openvz-amd64



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100924171527.GF5947@vostochny.stro.at">http://lists.debian.org/20100924171527.GF5947@vostochny.stro.at
 
Old 09-25-2010, 08:00 PM
maximilian attems
 
Default Bug#597952: initramfs-tools not up-dating correctly after aptitude full-upgrade today.

please keep bug report on cc, thanks.

On Fri, Sep 24, 2010 at 12:47:18PM -0700, George Stuart wrote:
>
>
> + ec2=0
> + ec3=0
> + [ 0 -ne 0 ]
> + [ 0 -ne 0 ]
> + [ 0 -ne 0 ]
> + [ -s /tmp/mkinitramfs-OL_T530Kv ]
> + [ n = y ]
> + rm -rf /tmp/mkinitramfs_SjKBkm
> + rm -rf /tmp/mkinitramfs-OL_T530Kv
> + exit 0

ok looks good.

> root@debian:/home/chevy# sh -x /usr/sbin/update-initramfs -u -k 2.6.32-5-openvz-amd64
> + rm -f /boot/initrd.img-2.6.32-5-openvz-amd64.dpkg-bak
> + return 0

same story here, so what is the trouble?

hmm please post full current apt log:
apt-get -f install

thanks



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100925200028.GB10090@vostochny.stro.at">http://lists.debian.org/20100925200028.GB10090@vostochny.stro.at
 
Old 09-27-2010, 07:28 PM
George Stuart
 
Default Bug#597952: initramfs-tools not up-dating correctly after aptitude full-upgrade today.

--- On Sat, 9/25/10, maximilian attems <max@stro.at> wrote:

From: maximilian attems <max@stro.at>
Subject: Re: Bug#597952: initramfs-tools not up-dating correctly after aptitude full-upgrade today.
To: "George Stuart" <chevy62_99@yahoo.com>
Cc: 597952@bugs.debian.org
Date: Saturday, September 25, 2010, 4:00 PM

please keep bug report on cc, thanks.

On Fri, Sep 24, 2010 at 12:47:18PM -0700, George Stuart wrote:
>
>
> + ec2=0
> + ec3=0
> + [ 0 -ne 0 ]
> + [ 0 -ne 0 ]
> + [ 0 -ne 0 ]
> + [ -s /tmp/mkinitramfs-OL_T530Kv ]
> + [ n = y ]
> + rm -rf /tmp/mkinitramfs_SjKBkm
> + rm -rf
/tmp/mkinitramfs-OL_T530Kv
> + exit 0

ok looks good.

> root@debian:/home/chevy# sh -x /usr/sbin/update-initramfs -u -k 2.6.32-5-openvz-amd64
> + rm -f /boot/initrd.img-2.6.32-5-openvz-amd64.dpkg-bak
> + return 0

same story here, so what is the trouble?

hmm please post full current apt log:
apt-get -f install

thanks

root@debian:/home/chevy# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@debian:/home/chevy#

this from /var/log/term.log may help
Log started: 2010-09-24 09:11:39
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ...
15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 148349 files and directories currently installed.)
Preparing to replace dnsmasq-base 2.55-1 (using .../dnsmasq-base_2.55-2_amd64.deb) ...
Unpacking replacement dnsmasq-base ...
Preparing to replace initramfs-tools 0.98.2 (using .../initramfs-tools_0.98.3_all.deb) ...
Unpacking replacement initramfs-tools ...
Processing triggers for man-db ...
Setting up dnsmasq-base (2.55-2) ...
Setting up initramfs-tools (0.98.3)
...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-vmlinuz-2.6.32-5-openvz-amd64
grep: /boot/config-vmlinuz-2.6.32-5-openvz-amd64: No such file or directory
WARNING: missing /lib/modules/vmlinuz-2.6.32-5-openvz-amd64
Device driver support needs thus be built-in linux image!
FATAL: modules must be specified using absolute paths.
"vmlinuz-2.6.32-5-openvz-amd64" is a relative path
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep: No such file or directory
FATAL: Could not load
/lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/vmlinuz-2.6.32-5-openvz-amd64/modules.dep: No such file or directory
WARNING: Couldn't open directory /tmp/mkinitramfs_71tuS0/lib/modules/2.6.32-5-openvz-amd64: No such file or directory
FATAL: Could not open /tmp/mkinitramfs_71tuS0/lib/modules/2.6.32-5-openvz-amd64/modules.dep.temp for writing: No such file or directory
Log ended: 2010-09-24 09:11:48

Log started: 2010-09-24 11:17:14
Log ended: 2010-09-24 11:17:14

This may or may not help. From /var/log/dpkg.log
2010-09-24 09:11:39 startup archives unpack
2010-09-24 09:11:41 upgrade dnsmasq-base 2.55-1 2.55-2
2010-09-24 09:11:41 status half-configured
dnsmasq-base 2.55-1
2010-09-24 09:11:41 status unpacked dnsmasq-base 2.55-1
2010-09-24 09:11:41 status half-installed dnsmasq-base 2.55-1
2010-09-24 09:11:41 status triggers-pending man-db 2.5.7-4
2010-09-24 09:11:41 status half-installed dnsmasq-base 2.55-1
2010-09-24 09:11:42 status half-installed dnsmasq-base 2.55-1
2010-09-24 09:11:42 status unpacked dnsmasq-base 2.55-2
2010-09-24 09:11:42 status unpacked dnsmasq-base 2.55-2
2010-09-24 09:11:42 upgrade initramfs-tools 0.98.2 0.98.3
2010-09-24 09:11:42 status half-configured initramfs-tools 0.98.2
2010-09-24 09:11:42 status unpacked initramfs-tools 0.98.2
2010-09-24 09:11:42 status half-installed initramfs-tools 0.98.2
2010-09-24 09:11:42 status half-installed initramfs-tools 0.98.2
2010-09-24 09:11:43 status half-installed initramfs-tools 0.98.2
2010-09-24 09:11:43 status unpacked initramfs-tools 0.98.3
2010-09-24 09:11:43 status unpacked initramfs-tools
0.98.3
2010-09-24 09:11:43 trigproc man-db 2.5.7-4 2.5.7-4
2010-09-24 09:11:43 status half-configured man-db 2.5.7-4
2010-09-24 09:11:44 status installed man-db 2.5.7-4
2010-09-24 09:11:45 startup packages configure
2010-09-24 09:11:45 configure dnsmasq-base 2.55-2 2.55-2
2010-09-24 09:11:45 status unpacked dnsmasq-base 2.55-2
2010-09-24 09:11:45 status half-configured dnsmasq-base 2.55-2
2010-09-24 09:11:45 status installed dnsmasq-base 2.55-2
2010-09-24 09:11:45 configure initramfs-tools 0.98.3 0.98.3
2010-09-24 09:11:45 status unpacked initramfs-tools 0.98.3
2010-09-24 09:11:45 status unpacked initramfs-tools 0.98.3
2010-09-24 09:11:45 status unpacked initramfs-tools 0.98.3
2010-09-24 09:11:45 status unpacked initramfs-tools 0.98.3
2010-09-24 09:11:45 status unpacked initramfs-tools 0.98.3
2010-09-24 09:11:45 status unpacked initramfs-tools 0.98.3
2010-09-24 09:11:45 status half-configured
initramfs-tools 0.98.3
2010-09-24 09:11:45 status installed initramfs-tools 0.98.3
2010-09-24 09:11:45 status triggers-pending initramfs-tools 0.98.3
2010-09-24 09:11:45 trigproc initramfs-tools 0.98.3 0.98.3
2010-09-24 09:11:45 status half-configured initramfs-tools 0.98.3
2010-09-24 09:11:48 status installed initramfs-tools 0.98.3
2010-09-24 14:14:46 startup archives unpack
2010-09-24 14:14:48 install mkisofs <none> 9:1.1.10-1
2010-09-24 14:14:48 status half-installed mkisofs 9:1.1.10-1
2010-09-24 14:14:48 status triggers-pending man-db 2.5.7-4
2010-09-24 14:14:48 status half-installed mkisofs 9:1.1.10-1
2010-09-24 14:14:48 status unpacked mkisofs 9:1.1.10-1
2010-09-24 14:14:48 status unpacked mkisofs 9:1.1.10-1
2010-09-24 14:14:48 trigproc man-db 2.5.7-4 2.5.7-4
2010-09-24 14:14:48 status half-configured man-db 2.5.7-4
2010-09-24 14:14:49 status installed man-db 2.5.7-4
2010-09-24 14:14:50 startup
packages configure
2010-09-24 14:14:50 configure mkisofs 9:1.1.10-1 9:1.1.10-1
2010-09-24 14:14:50 status unpacked mkisofs 9:1.1.10-1
2010-09-24 14:14:50 status half-configured mkisofs 9:1.1.10-1
2010-09-24 14:14:50 status installed mkisofs 9:1.1.10-1

Testing was installed on a new hard drive about a month ago with one error. Grub legacy and grub2 failed to install to the drive. Lilo would so the install was finished with that and then later I used aptitude to install grub and remove lilo. I believe lilo is gone from my system with the exception of the symlinks in the root directory.
Thanks
George*
 

Thread Tools




All times are GMT. The time now is 11:58 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org