FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 09-15-2010, 06:09 AM
Sedat Dilek
 
Default trunk-r16272: Fix up some configs and speakup patch broken for 2.6.36-rc4

Hi,

I already pointed out on IRC that some CONFIG_* has to be updated for
2.6.36-rc4.
See my attached patches.

As it might be important: My linux-2.6/debian directory is from trunk-r16272.

Unfortunately, the shipped speakup patch(es) are somehow broken:

sd@tbox:~/src/linux-2.6$ grep -i speakup BROKEN_speakup_build.log
LD drivers/staging/speakup/built-in.o
CC [M] drivers/staging/speakup/speakup_acntsa.o
CC [M] drivers/staging/speakup/speakup_acntpc.o
CC [M] drivers/staging/speakup/speakup_apollo.o
CC [M] drivers/staging/speakup/speakup_audptr.o
CC [M] drivers/staging/speakup/speakup_bns.o
CC [M] drivers/staging/speakup/speakup_dectlk.o
CC [M] drivers/staging/speakup/speakup_decext.o
CC [M] drivers/staging/speakup/speakup_dtlk.o
CC [M] drivers/staging/speakup/speakup_keypc.o
CC [M] drivers/staging/speakup/speakup_ltlk.o
CC [M] drivers/staging/speakup/speakup_soft.o
CC [M] drivers/staging/speakup/speakup_spkout.o
CC [M] drivers/staging/speakup/speakup_txprt.o
CC [M] drivers/staging/speakup/speakup_dummy.o
CC [M] drivers/staging/speakup/buffers.o
/home/sd/src/linux-2.6/linux-2.6.36-rc4/debian/build/source_i386_none/drivers/staging/speakup/buffers.c:
In function ‘speakup_start_ttys’:
/home/sd/src/linux-2.6/linux-2.6.36-rc4/debian/build/source_i386_none/drivers/staging/speakup/buffers.c:33:
error: ‘struct vc_data’ has no member named ‘vc_tty’
/home/sd/src/linux-2.6/linux-2.6.36-rc4/debian/build/source_i386_none/drivers/staging/speakup/buffers.c:34:
error: ‘struct vc_data’ has no member named ‘vc_tty’
/home/sd/src/linux-2.6/linux-2.6.36-rc4/debian/build/source_i386_none/drivers/staging/speakup/buffers.c:
In function ‘speakup_stop_ttys’:
/home/sd/src/linux-2.6/linux-2.6.36-rc4/debian/build/source_i386_none/drivers/staging/speakup/buffers.c:56:
error: ‘struct vc_data’ has no member named ‘vc_tty’
/home/sd/src/linux-2.6/linux-2.6.36-rc4/debian/build/source_i386_none/drivers/staging/speakup/buffers.c:57:
error: ‘struct vc_data’ has no member named ‘vc_tty’
make[7]: *** [drivers/staging/speakup/buffers.o] Fehler 1
make[6]: *** [drivers/staging/speakup] Fehler 2

Some days back, I looked into speakup GIT repository, so the extracted
patch seems to be correct on first sight but I guess no more fitting
to 2.6.36-rc4.
Might be it's fixed in the meantime in upstream GIT.

As a temporary workaround (using i386_none_686 for builds) I have
disabled speakup in:

[ debian/config/i386/none/config.686 ]
...
# CONFIG_DEBUG_HIGHMEM is not set

##
## file: drivers/staging/speakup/Kconfig
##
# CONFIG_SPEAKUP is not set
-EOF-

Hope I could help and you have time for a closer look into my reported issues.

Kind Regards,
- Sedat (aka dile{ks,X} on IRC) -

P.S.: Yes, I know 2.6.36-rc4 support is WIP (UNRELEASED).
From 244692cc6f6fad05d1058bf9ca123535d8014368 Mon Sep 17 00:00:00 2001
From: Sedat Dilek <sedat.dilek@gmail.com>
Date: Mon, 13 Sep 2010 05:46:38 +0200
Subject: [PATCH] Replace CONFIG_INOTIFY by CONFIG_FANOTIFY

---
debian/config/config | 6 +++++-
1 files changed, 5 insertions(+), 1 deletions(-)

diff --git a/debian/config/config b/debian/config/config
index 28336b2..398865a 100644
--- a/debian/config/config
+++ b/debian/config/config
@@ -3175,10 +3175,14 @@ CONFIG_DNOTIFY=y
##
## file: fs/notify/inotify/Kconfig
##
-CONFIG_INOTIFY=y
CONFIG_INOTIFY_USER=y

##
+## file: fs/notify/fanotify/Kconfig
+##
+CONFIG_FANOTIFY=y
+
+##
## file: fs/ntfs/Kconfig
##
CONFIG_NTFS_FS=m
--
1.7.2.3

From 2c329cbf3c17b46f6de91f2012b96489d91facfa Mon Sep 17 00:00:00 2001
From: Sedat Dilek <sedat.dilek@gmail.com>
Date: Mon, 13 Sep 2010 05:48:27 +0200
Subject: [PATCH] Unset CONFIG_MFD_WM8994

---
debian/config/config | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/debian/config/config b/debian/config/config
index 398865a..1de3909 100644
--- a/debian/config/config
+++ b/debian/config/config
@@ -1336,7 +1336,7 @@ CONFIG_MFD_SM501=m
CONFIG_HTC_PASIC3=m
CONFIG_TPS65010=m
CONFIG_MFD_WM8400=m
-CONFIG_MFD_WM8994=m
+# CONFIG_MFD_WM8994 is not set
# CONFIG_MFD_WM831X is not set
# CONFIG_MFD_WM8350_I2C is not set
CONFIG_MFD_PCF50633=m
--
1.7.2.3

From 52d1e96be23738ac627b3210de7cbaa11aa4a941 Mon Sep 17 00:00:00 2001
From: Sedat Dilek <sedat.dilek@gmail.com>
Date: Mon, 13 Sep 2010 05:50:22 +0200
Subject: [PATCH] Set CONFIG_INTEL_IDLE=y

Change from 'm' to CONFIG_INTEL_IDLE=y as it is now boolean.
---
debian/config/kernelarch-x86/config | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/debian/config/kernelarch-x86/config b/debian/config/kernelarch-x86/config
index 009fe14..5c793c1 100644
--- a/debian/config/kernelarch-x86/config
+++ b/debian/config/kernelarch-x86/config
@@ -536,9 +536,9 @@ CONFIG_BLK_DEV_TRM290=m
CONFIG_XEN_KBDDEV_FRONTEND=y

##
-## file: drivers/indle/Kconfig
+## file: drivers/idle/Kconfig
##
-CONFIG_INTEL_IDLE=m
+CONFIG_INTEL_IDLE=y

##
## file: drivers/input/gameport/Kconfig
--
1.7.2.3
 
Old 09-19-2010, 02:21 AM
Ben Hutchings
 
Default trunk-r16272: Fix up some configs and speakup patch broken for 2.6.36-rc4

On Wed, 2010-09-15 at 08:09 +0200, Sedat Dilek wrote:
> Hi,
>
> I already pointed out on IRC that some CONFIG_* has to be updated for
> 2.6.36-rc4.
> See my attached patches.
>
> As it might be important: My linux-2.6/debian directory is from
> trunk-r16272.
>
> Unfortunately, the shipped speakup patch(es) are somehow broken:

I've recently subscribed to the speakup list and have been encouraging
the developers to submit the drivers to staging.

In the course of that I was told that the speakup drivers in linux-2.6
are quite outdated, and, as you've seen, I've now updated them to match
the current speakup package.

[...]
> Some days back, I looked into speakup GIT repository, so the extracted
> patch seems to be correct on first sight but I guess no more fitting
> to 2.6.36-rc4.

I needed to add one more small patch.

> From 244692cc6f6fad05d1058bf9ca123535d8014368 Mon Sep 17 00:00:00 2001
> From: Sedat Dilek <sedat.dilek@gmail.com>
> Date: Mon, 13 Sep 2010 05:46:38 +0200
> Subject: [PATCH] Replace CONFIG_INOTIFY by CONFIG_FANOTIFY

fanotify is a new API, primarily for virus checkers, and we don't
necessarily want it. The important thing is the userland inotify
interface (INOTIFY_USER) which is still enabled.

[...]
> From 2c329cbf3c17b46f6de91f2012b96489d91facfa Mon Sep 17 00:00:00 2001
> From: Sedat Dilek <sedat.dilek@gmail.com>
> Date: Mon, 13 Sep 2010 05:48:27 +0200
> Subject: [PATCH] Unset CONFIG_MFD_WM8994

Why?

[...]
> From 52d1e96be23738ac627b3210de7cbaa11aa4a941 Mon Sep 17 00:00:00 2001
> From: Sedat Dilek <sedat.dilek@gmail.com>
> Date: Mon, 13 Sep 2010 05:50:22 +0200
> Subject: [PATCH] Set CONFIG_INTEL_IDLE=y
>
> Change from 'm' to CONFIG_INTEL_IDLE=y as it is now boolean.
[...]

Do we really trust that this driver is better than acpi_idle yet? (And
I really hate it when driver authors can't make them work as modules.)

Ben.

--
Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.
 

Thread Tools




All times are GMT. The time now is 03:56 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org