FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 07-25-2010, 06:27 AM
Török Edwin
 
Default Bug#590226: linux-tools-2.6: uninstallable

Package: linux-tools-2.6
Severity: normal

$ sudo aptitude install linux-tools-2.6
The following NEW packages will be installed:
linux-tools-2.6 linux-tools-2.6.32{ab}
0 packages upgraded, 2 newly installed, 0 to remove and 409 not upgraded.
Need to get 291kB of archives. After unpacking 549kB will be used.
The following packages have unmet dependencies:
linux-tools-2.6.32: Depends: binutils (< 2.20.2) but 2.20.51.20100617-1 is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) linux-tools-2.6 [Not Installed]
2) linux-tools-2.6.32 [Not Installed]

$ apt-cache policy binutils
binutils:
Installed: 2.20.51.20100617-1
Candidate: 2.20.51.20100617-1
Version table:
2.20.51.20100710-2 0
1 ftp://ftp.ro.debian.org experimental/main Packages
*** 2.20.51.20100617-1 0
100 /var/lib/dpkg/status
2.20.1-12 0
990 ftp://ftp.ro.debian.org unstable/main Packages
990 ftp://ftp.de.debian.org unstable/main Packages
500 ftp://ftp.ro.debian.org testing/main Packages

If I try to downgrade binutils it wants to remove gcc-4.5:
$ sudo apt-get install binutils=2.20.1-12 binutils-multiarch=2.20.1-12 binutils-dev=2.20.1-12
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
g++-4.5 gcc-4.5 libstdc++6-4.5-dev
The following packages will be DOWNGRADED:
binutils binutils-dev binutils-multiarch

Why does linux-tools-2.6 require a specific version of binutils?

-- System Information:
Debian Release: squeeze/sid
APT prefers unstable
APT policy: (990, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.35-rc6 (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100725062747.8534.26897.reportbug@deb0">http://lists.debian.org/20100725062747.8534.26897.reportbug@deb0
 
Old 07-25-2010, 12:12 PM
Ben Hutchings
 
Default Bug#590226: linux-tools-2.6: uninstallable

On Sun, 2010-07-25 at 09:27 +0300, Török Edwin wrote:
[...]
> Why does linux-tools-2.6 require a specific version of binutils?

It uses libbfd.

Ben.

--
Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.
 
Old 07-25-2010, 01:16 PM
Bastian Blank
 
Default Bug#590226: linux-tools-2.6: uninstallable

On Sun, Jul 25, 2010 at 01:12:42PM +0100, Ben Hutchings wrote:
> On Sun, 2010-07-25 at 09:27 +0300, Török Edwin wrote:
> [...]
> > Why does linux-tools-2.6 require a specific version of binutils?
> It uses libbfd.

Okay, so linux-2.6 is now part of a much larger bunch of tightly coupled
packages.

Bastian

--
You can't evaluate a man by logic alone.
-- McCoy, "I, Mudd", stardate 4513.3


--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100725131650.GA4026@wavehammer.waldi.eu.org">htt p://lists.debian.org/20100725131650.GA4026@wavehammer.waldi.eu.org
 
Old 07-25-2010, 01:30 PM
Julien Cristau
 
Default Bug#590226: linux-tools-2.6: uninstallable

On Sun, Jul 25, 2010 at 15:16:50 +0200, Bastian Blank wrote:

> On Sun, Jul 25, 2010 at 01:12:42PM +0100, Ben Hutchings wrote:
> > On Sun, 2010-07-25 at 09:27 +0300, Török Edwin wrote:
> > [...]
> > > Why does linux-tools-2.6 require a specific version of binutils?
> > It uses libbfd.
>
> Okay, so linux-2.6 is now part of a much larger bunch of tightly coupled
> packages.

perf in "bundling userspace utilities in the kernel source tree is a bad
idea" shocker.

Would it be possible to link it against libbfd.a instead?

Cheers,
Julien
 
Old 07-25-2010, 01:48 PM
Bastian Blank
 
Default Bug#590226: linux-tools-2.6: uninstallable

On Sun, Jul 25, 2010 at 03:30:42PM +0200, Julien Cristau wrote:
> Would it be possible to link it against libbfd.a instead?

I would just merge it into linux-kbuild-2.6, the only package building
userspace binaries.

Bastian

--
Conquest is easy. Control is not.
-- Kirk, "Mirror, Mirror", stardate unknown


--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100725134816.GA4505@wavehammer.waldi.eu.org">htt p://lists.debian.org/20100725134816.GA4505@wavehammer.waldi.eu.org
 
Old 07-25-2010, 04:13 PM
Ben Hutchings
 
Default Bug#590226: linux-tools-2.6: uninstallable

On Sun, 2010-07-25 at 15:30 +0200, Julien Cristau wrote:
> On Sun, Jul 25, 2010 at 15:16:50 +0200, Bastian Blank wrote:
>
> > On Sun, Jul 25, 2010 at 01:12:42PM +0100, Ben Hutchings wrote:
> > > On Sun, 2010-07-25 at 09:27 +0300, Török Edwin wrote:
> > > [...]
> > > > Why does linux-tools-2.6 require a specific version of binutils?
> > > It uses libbfd.
> >
> > Okay, so linux-2.6 is now part of a much larger bunch of tightly coupled
> > packages.
>
> perf in "bundling userspace utilities in the kernel source tree is a bad
> idea" shocker.
>
> Would it be possible to link it against libbfd.a instead?

This might be sensible, as it will otherwise be impossible to keep
linux-tools-* installed for a wide range of different kernel versions.
However we would need to discuss this with the FTP and security teams.

Ben.

--
Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.
 

Thread Tools




All times are GMT. The time now is 05:35 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org