Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Kernel (http://www.linux-archive.org/debian-kernel/)
-   -   Bug#589960: linux-source-2.6.34: iwlwifi-4965 firmware is no longer loaded since 2.6.34 (http://www.linux-archive.org/debian-kernel/402703-bug-589960-linux-source-2-6-34-iwlwifi-4965-firmware-no-longer-loaded-since-2-6-34-a.html)

Christoph Anton Mitterer 07-22-2010 02:34 PM

Bug#589960: linux-source-2.6.34: iwlwifi-4965 firmware is no longer loaded since 2.6.34
 
Package: linux-source-2.6.34
Version: 2.6.34-1~experimental.2
Severity: normal


Hi.

I'm using a custom kernel, where the IWL4965 drivers are compiled in statically. Also the system
uses initramfs images for booting.

Since 2.6.34, the WLAN device no longer works:
The device is correctly detected:
[ 1.094126] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 1.094347] iwlagn: Copyright(c) 2003-2010 Intel Corporation
[ 1.094566] iwlagn 0000:14:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 1.094740] iwlagn 0000:14:00.0: setting latency timer to 64
[ 1.094784] iwlagn 0000:14:00.0: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
[ 1.133993] iwlagn 0000:14:00.0: Tunable channels: 13 802.11bg, 19 802.11a channels
[ 1.134358] iwlagn 0000:14:00.0: irq 30 for MSI/MSI-X
[ 1.134814] iwlagn 0000:14:00.0: firmware: requesting iwlwifi-4965-2.ucode

however, the firmware cannot be loaded during boot:
[ 1.493944] iwlagn 0000:14:00.0: request for firmware file 'iwlwifi-4965-2.ucode' failed.
[ 1.494178] iwlagn 0000:14:00.0: no suitable firmware found!
[ 1.494529] iwlagn 0000:14:00.0: PCI INT A disabled

The firmware is not included in the initramfs image,.. but the strange thing now is:
It wasn't included in the 2.6.33 kernel initramfs either.


Has anything changed there in loding the firmwares?


Thanks,
Chris.



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100722143429.5510.37659.reportbug@heisenberg.sci entia.net">http://lists.debian.org/20100722143429.5510.37659.reportbug@heisenberg.sci entia.net

Ben Hutchings 07-22-2010 05:10 PM

Bug#589960: linux-source-2.6.34: iwlwifi-4965 firmware is no longer loaded since 2.6.34
 
On Thu, Jul 22, 2010 at 07:03:48PM +0200, Christoph Anton Mitterer wrote:
> Hi Ben.
>
>
> On Thu, 2010-07-22 at 16:21 +0100, Ben Hutchings wrote:
> > This is not a supported configuration. In theory you can use
> > CONFIG_FIRMWARE_IN_KERNEL to make this work, but I believe that requires
> > that the firmware images are included in the kernel source tree.
>
> Have you read the remaining info in the bug? I'd especially like to know
> whether it worked with 2.6.33.... just to understand the boot/firmware
> loading process better.

initramfs-tools relies on module information to work out which firmware
should be included in the initramfs. There is no way to get that
information for drivers included in a monolithic kernel. Further, some
drivers will request firmware when probing devices, before the initramfs
has even been mounted.

Ben.

--
Ben Hutchings
We get into the habit of living before acquiring the habit of thinking.
- Albert Camus



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100722171046.GG3331@decadent.org.uk">http://lists.debian.org/20100722171046.GG3331@decadent.org.uk


All times are GMT. The time now is 07:13 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.