FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 07-15-2010, 02:18 AM
Darren Hoo
 
Default Bug#534422: X hangs with blank screen when it is in use

I experienced blank screen with only cursor on the screen after resume
from suspension now and then before 2.6.32-17, but after I upgraded
to 2.6.32-17, X hangs with blank screen when it is in use. I am sure
whether it is related to this bug.

here's part of syslog:

Jul 15 09:58:24 debian kernel: [ 3153.980040]
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU
hung
Jul 15 09:58:24 debian kernel: [ 3153.980055] render error detected,
EIR: 0x00000000
Jul 15 09:58:24 debian kernel: [ 3153.980119]
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5
(awaiting 496217 at 496216)
Jul 15 09:58:36 debian kernel: [ 3165.549011]
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU
hung
Jul 15 09:58:36 debian kernel: [ 3165.549017] render error detected,
EIR: 0x00000000

and Xorg.log:
(EE) intel(0): Failed to submit batch buffer, expect rendering
corruption or even a frozen display: Input/output error.

this is a Thinkpad X60S
lspci:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML
and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME,
943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High
Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express
Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express
Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express
Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express
Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE
Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family)
SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet
Controller
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG
[Golan] Network Connection (rev 02)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b4)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 09)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro
Host Adapter (rev 18)



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTinbdiXDs4-ng5f7hLbs1RLi7EiqjVCAa8WrmEzJ@mail.gmail.com">http ://lists.debian.org/AANLkTinbdiXDs4-ng5f7hLbs1RLi7EiqjVCAa8WrmEzJ@mail.gmail.com
 
Old 07-15-2010, 08:38 AM
Julien Cristau
 
Default Bug#534422: X hangs with blank screen when it is in use

On Thu, Jul 15, 2010 at 10:18:29 +0800, Darren Hoo wrote:

> I experienced blank screen with only cursor on the screen after resume
> from suspension now and then before 2.6.32-17, but after I upgraded
> to 2.6.32-17, X hangs with blank screen when it is in use. I am sure
> whether it is related to this bug.
>
Please file your own bug.

> here's part of syslog:
>
> Jul 15 09:58:24 debian kernel: [ 3153.980040]
> [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU
> hung
> Jul 15 09:58:24 debian kernel: [ 3153.980055] render error detected,
> EIR: 0x00000000
> Jul 15 09:58:24 debian kernel: [ 3153.980119]
> [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5
> (awaiting 496217 at 496216)
> Jul 15 09:58:36 debian kernel: [ 3165.549011]
> [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU
> hung
> Jul 15 09:58:36 debian kernel: [ 3165.549017] render error detected,
> EIR: 0x00000000
>
> and Xorg.log:
> (EE) intel(0): Failed to submit batch buffer, expect rendering
> corruption or even a frozen display: Input/output error.
>
When filing your own bug, please include the following information:

What version of libdrm-intel1 and xserver-xorg-video-intel? Does that
still happen with the versions from experimental? What about the kernel
from experimental? Does the hang happen on resume, or when doing
something else (what?)?

If you reproduce with 2.6.34+, please grab i915_error_state from
/sys/kernel/debug/dri/0/ and include it in a bug report following
instructions at http://intellinuxgraphics.org/how_to_report_bug.html

Thanks,
Julien
 
Old 07-15-2010, 09:57 AM
Darren Hoo
 
Default Bug#534422: X hangs with blank screen when it is in use

On Thu, Jul 15, 2010 at 4:38 PM, Julien Cristau <jcristau@debian.org> wrote:
> On Thu, Jul 15, 2010 at 10:18:29 +0800, Darren Hoo wrote:
>
>> I experienced blank screen with only cursor on the screen after resume
>> from suspension now and then before *2.6.32-17, but after I *upgraded
>> to 2.6.32-17, X hangs with blank screen *when it is in use. I am sure
>> whether it is related to this bug.
>>
> Please file your own bug.
>
Sorry to have provided useless non-related information, Filing my own bug
will only waste more of your time to triage or merge of the bug.

> When filing your own bug, please include the following information:
>
> What version of libdrm-intel1 and xserver-xorg-video-intel? *Does that
> still happen with the versions from experimental? *What about the kernel
> from experimental? *Does the hang happen on resume, or when doing
> something else (what?)?
>
> If you reproduce with 2.6.34+, please grab i915_error_state from
> /sys/kernel/debug/dri/0/ and include it in a bug report following
> instructions at http://intellinuxgraphics.org/how_to_report_bug.html
>
I haven't experienced hang up for a while, Next time if the symptom reappears
I shall prepare my own bug report as detailed as possible following your guides
above. Thanks.



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTinM87kLNXRpmtsGlz5WYIv_6uwxuXyIisWQfMlk@mail .gmail.com">http://lists.debian.org/AANLkTinM87kLNXRpmtsGlz5WYIv_6uwxuXyIisWQfMlk@mail .gmail.com
 

Thread Tools




All times are GMT. The time now is 03:07 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org