FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 06-08-2010, 12:51 PM
Davi Diaz
 
Default Bug#585016: webcam not working

On Tuesday 08 June 2010 12:45:30 Bastian Blank wrote:
> severity 585016 minor
> tags 585016 moreinfo
> thanks
>
> Thank you for the information. But webcams are neither critical
> infrastructure nor does the logs show anything suspcicous.

Yes, you are right the logs do not show anything suspicious, but it does not
change the fact the cam does not work neither on ekiga, cheese nor xawtv, as
exposed in previous email.


> Also this package is outdated, so please update and use reportbug to add
> proper informations to the bug.

I reported the bug checking the last and current Debian squeeze package,
linux-image-2.6.32-3-amd64 (2.6.32-9)

Do you mean I must check if this bug is present too in the package at Debian
sid, linux-image-2.6.32-5-amd64 (2.6.32-15) ?



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201006081351.02828.davi@leals.com">http://lists.debian.org/201006081351.02828.davi@leals.com
 
Old 06-08-2010, 01:36 PM
David Goodenough
 
Default Bug#585016: webcam not working

On Tuesday 08 June 2010, Davi Diaz wrote:
> On Tuesday 08 June 2010 12:45:30 Bastian Blank wrote:
> > severity 585016 minor
> > tags 585016 moreinfo
> > thanks
> >
> > Thank you for the information. But webcams are neither critical
> > infrastructure nor does the logs show anything suspcicous.
>
> Yes, you are right the logs do not show anything suspicious, but it does
> not change the fact the cam does not work neither on ekiga, cheese
nor
> xawtv, as exposed in previous email.
Have you tried running the apps with:-

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

This forces the old v4l interface. I had a similar problem with getting
skype to use a webcam.

David
>
> > Also this package is outdated, so please update and use reportbug to
add
> > proper informations to the bug.
>
> I reported the bug checking the last and current Debian squeeze
package,
> linux-image-2.6.32-3-amd64 (2.6.32-9)
>
> Do you mean I must check if this bug is present too in the package at
> Debian sid, linux-image-2.6.32-5-amd64 (2.6.32-15) ?
>




--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201006081436.11949.david.goodenough@btconnect.com" >http://lists.debian.org/201006081436.11949.david.goodenough@btconnect.com
 
Old 06-08-2010, 03:12 PM
Davi Diaz
 
Default Bug#585016: webcam not working

David Goodenough wrote:
> Have you tried running the apps with:-
>
> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
>
> This forces the old v4l interface. I had a similar problem with getting
> skype to use a webcam.
>
> David




After rebooting it works. Both xawtv, ekiga and cheese work perfectly. I think
I had not rebooted after the Debian squeeze kernel update some days ago.

You can close this bug.

Thanks!



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201006081612.04261.davi@leals.com">http://lists.debian.org/201006081612.04261.davi@leals.com
 
Old 06-08-2010, 04:53 PM
Ben Hutchings
 
Default Bug#585016: webcam not working

On Tue, Jun 08, 2010 at 02:36:11PM +0100, David Goodenough wrote:
> On Tuesday 08 June 2010, Davi Diaz wrote:
> > On Tuesday 08 June 2010 12:45:30 Bastian Blank wrote:
> > > severity 585016 minor
> > > tags 585016 moreinfo
> > > thanks
> > >
> > > Thank you for the information. But webcams are neither critical
> > > infrastructure nor does the logs show anything suspcicous.
> >
> > Yes, you are right the logs do not show anything suspicious, but it does
> > not change the fact the cam does not work neither on ekiga, cheese
> nor
> > xawtv, as exposed in previous email.
> Have you tried running the apps with:-
>
> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
>
> This forces the old v4l interface. I had a similar problem with getting
> skype to use a webcam.
[...]

That isn't necessary for these applications as they are using gstreamer.
I've filed bugs against all the V4L1 applications I could find.

Ben.

--
Ben Hutchings
We get into the habit of living before acquiring the habit of thinking.
- Albert Camus



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100608165333.GP5306@decadent.org.uk">http://lists.debian.org/20100608165333.GP5306@decadent.org.uk
 

Thread Tools




All times are GMT. The time now is 01:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org