Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Kernel (http://www.linux-archive.org/debian-kernel/)
-   -   Bug#573490: drbd fails to load: "drbd: disagrees about version of symbol cn_add_callback" (http://www.linux-archive.org/debian-kernel/340146-bug-573490-drbd-fails-load-drbd-disagrees-about-version-symbol-cn_add_callback.html)

Tomas Pospisek 03-11-2010 07:43 PM

Bug#573490: drbd fails to load: "drbd: disagrees about version of symbol cn_add_callback"
 
Package: linux-2.6
Version: 2.6.26-21lenny4
Severity: critical

drbd fails to load and there goes my failover high available cluster...
*t


-- Package-specific info:
** Version:
Linux version 2.6.26-2-686 (Debian 2.6.26-21lenny4) (dannf@debian.org) (gcc version 4.1.3 20080704 (prerelease) (Debian 4.1.2-25)) #1 SMP Tue Mar 9 17:35:51 UTC 2010

** Command line:
root=/dev/sda6 ro console=tty0 console=ttyS0,115200n8

** Not tainted
** Kernel log:
[ 3.637885] hub 4-0:1.0: USB hub found
[ 3.637895] hub 4-0:1.0: 6 ports detected
[ 3.693311] megaraid: fw version:[516A] bios version:[H418]
[ 3.710308] hub 2-0:1.0: unable to enumerate USB device on port 1
[ 3.714272] scsi0 : LSI Logic MegaRAID driver
[ 3.721905] scsi[0]: scanning scsi channel 0 [Phy 0] for non-raid devices
[ 3.761772] usb usb4: New USB device found, idVendor=1d6b, idProduct=0002
[ 3.765777] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 3.774055] usb usb4: Product: EHCI Host Controller
[ 3.781775] usb usb4: Manufacturer: Linux 2.6.26-2-686 ehci_hcd
[ 3.787796] usb usb4: SerialNumber: 0000:00:1d.7
[ 3.798388] ICH5: IDE controller (0x8086:0x24db rev 0x02) at PCI slot 0000:00:1f.1
[ 3.805361] PIIX_IDE 0000:00:1f.1: enabling device (0005 -> 0007)
[ 3.813349] ACPI: Unable to derive IRQ for device 0000:00:1f.1
[ 3.819257] ICH5: not 100% native mode: will probe irqs later
[ 3.825442] ide0: BM-DMA at 0xfc00-0xfc07
[ 3.827731] ide1: BM-DMA at 0xfc08-0xfc0f
[ 3.832153] Probing IDE interface ide0...
[ 4.002933] usb 4-3: new high speed USB device using ehci_hcd and address 2
[ 4.157565] usb 4-3: configuration #1 chosen from 1 choice
[ 4.166602] hub 4-3:1.0: USB hub found
[ 4.173569] hub 4-3:1.0: 2 ports detected
[ 4.257100] hda: SAMSUNG CD-ROM SN-124, ATAPI CD/DVD-ROM drive
[ 4.279943] usb 4-3: New USB device found, idVendor=413c, idProduct=a001
[ 4.285574] usb 4-3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 4.811642] scsi 0:0:6:0: Processor PE/PV 1x2 SCSI BP 1.0 PQ: 0 ANSI: 2
[ 5.129518] hda: host max PIO4 wanted PIO255(auto-tune) selected PIO4
[ 5.129665] hda: UDMA/33 mode selected
[ 5.137469] Probing IDE interface ide1...
[ 5.770029] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[ 5.778425] ide1 at 0x170-0x177,0x376 on irq 15
[ 6.042916] No dock devices found.
[ 6.061215] libata version 3.00 loaded.
[ 6.083004] hda: ATAPI 24X CD-ROM drive, 128kB Cache
[ 6.088253] Uniform CD-ROM driver Revision: 3.20
[ 6.155945] scsi: waiting for bus probes to complete ...
[ 7.460859] scsi[0]: scanning scsi channel 1 [virtual] for logical drives
[ 7.464859] scsi 0:1:0:0: Direct-Access MegaRAID LD 0 RAID1 69G 516A PQ: 0 ANSI: 2
[ 7.500860] scsi 0:0:6:0: Attached scsi generic sg0 type 3
[ 7.504688] scsi 0:1:0:0: Attached scsi generic sg1 type 0
[ 7.521520] Driver 'sd' needs updating - please use bus_type methods
[ 7.525518] sd 0:1:0:0: [sda] 143114240 512-byte hardware sectors (73274 MB)
[ 7.533568] sd 0:1:0:0: [sda] Write Protect is off
[ 7.540143] sd 0:1:0:0: [sda] Mode Sense: 00 00 00 00
[ 7.540180] sd 0:1:0:0: [sda] Asking for cache data failed
[ 7.545523] sd 0:1:0:0: [sda] Assuming drive cache: write through
[ 7.549519] sd 0:1:0:0: [sda] 143114240 512-byte hardware sectors (73274 MB)
[ 7.557566] sd 0:1:0:0: [sda] Write Protect is off
[ 7.562414] sd 0:1:0:0: [sda] Mode Sense: 00 00 00 00
[ 7.562441] sd 0:1:0:0: [sda] Asking for cache data failed
[ 7.569398] sd 0:1:0:0: [sda] Assuming drive cache: write through
[ 7.574970] sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 >
[ 7.618048] sd 0:1:0:0: [sda] Attached SCSI disk
[ 7.873149] PM: Starting manual resume from disk
[ 7.898278] kjournald starting. Commit interval 5 seconds
[ 7.901106] EXT3-fs: mounted filesystem with ordered data mode.
[ 9.041328] udevd version 125 started
[ 9.416597] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
[ 9.776070] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 9.784247] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[ 9.880420] input: Power Button (FF) as /class/input/input0
[ 9.896414] ACPI: Power Button (FF) [PWRF]
[ 9.940220] EDAC MC: Ver: 2.1.0 Mar 9 2010
[ 10.000495] Contact your BIOS vendor to see if the E752x error registers can be safely un-hidden
[ 10.638351] ACPI Exception (video-1631): AE_NOT_FOUND, Evaluating _DOD [20080321]
[ 10.647586] input: Video Bus as /class/input/input1
[ 10.699347] ACPI: Video Device [EVGA] (multi-head: no rom: yes post: no)
[ 10.840751] input: PC Speaker as /class/input/input2
[ 11.058215] Error: Driver 'pcspkr' is already registered, aborting...
[ 11.149292] intel_rng: FWH not detected
[ 11.847190] Adding 1951856k swap on /dev/sda5. Priority:-1 extents:1 across:1951856k
[ 12.002662] EXT3 FS on sda6, internal journal
[ 13.476334] kjournald starting. Commit interval 5 seconds
[ 13.476334] EXT3 FS on sda7, internal journal
[ 13.476334] EXT3-fs: mounted filesystem with ordered data mode.
[ 13.495619] kjournald starting. Commit interval 5 seconds
[ 13.496333] EXT3 FS on sda8, internal journal
[ 13.496333] EXT3-fs: mounted filesystem with ordered data mode.
[ 13.511870] kjournald starting. Commit interval 5 seconds
[ 13.512333] EXT3 FS on sda9, internal journal
[ 13.512333] EXT3-fs: mounted filesystem with ordered data mode.
[ 14.004843] Ethernet Channel Bonding Driver: v3.2.5 (March 21, 2008)
[ 14.008105] bonding: ARP monitoring set to 1000 ms, validate none, with 2 target(s): 192.168.138.228 192.168.138.1
[ 14.049977] bonding: bond0: enslaving eth0 as a backup interface with an up link.
[ 14.056311] e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX
[ 14.134236] e100: eth2: e100_watchdog: link up, 100Mbps, full-duplex
[ 14.469376] NET: Registered protocol family 10
[ 14.471820] lo: Disabled Privacy Extensions
[ 16.151355] bonding: bond0: making interface eth0 the new active one.
[ 16.158086] bonding: bond0: eth0 is up and now the active interface
[ 16.185655] ipmi message handler version 39.2
[ 16.217601] IPMI System Interface driver.
[ 16.221666] ipmi_si: Trying SMBIOS-specified kcs state machine at i/o address 0xca8, slave address 0x20, irq 0
[ 16.368244] ipmi: Found new BMC (man_id: 0x0002a2, prod_id: 0x0000, dev_id: 0x20)
[ 16.374157] IPMI kcs interface initialized
[ 16.400576] ipmi device interface
[ 24.720404] bond0: no IPv6 routers present
[ 25.240395] eth2: no IPv6 routers present
[ 42.410056] drbd: disagrees about version of symbol cn_add_callback
[ 42.416406] drbd: Unknown symbol cn_add_callback

** Model information
not available

** Loaded modules:
Module Size Used by
cn 5344 0
ipmi_devintf 6216 4
ipmi_si 33228 2
ipmi_msghandler 29560 2 ipmi_devintf,ipmi_si
ipv6 235396 16
bonding 69604 0
ide_disk 10496 0
psmouse 32336 0
evdev 8000 0
serio_raw 4740 0
rng_core 3940 0
snd_pcm 62660 0
snd_timer 17800 1 snd_pcm
snd 45636 2 snd_pcm,snd_timer
soundcore 6368 1 snd
snd_page_alloc 7816 1 snd_pcm
pcspkr 2432 0
video 16464 0
output 2912 1 video
e752x_edac 10824 0
edac_core 36144 1 e752x_edac
button 6096 0
shpchp 25528 0
pci_hotplug 23460 1 shpchp
dcdbas 6272 0
ext3 105576 4
jbd 39476 1 ext3
mbcache 7108 1 ext3
sd_mod 22200 6
sg 26964 0
ide_cd_mod 27684 0
cdrom 30176 1 ide_cd_mod
ata_generic 4676 0
libata 140448 1 ata_generic
dock 8304 1 libata
piix 6568 0 [permanent]
ide_pci_generic 3908 0 [permanent]
floppy 47844 0
ide_core 96168 4 ide_disk,ide_cd_mod,piix,ide_pci_generic
ehci_hcd 28428 0
uhci_hcd 18672 0
usbcore 118192 3 ehci_hcd,uhci_hcd
megaraid_mbox 25872 5
scsi_mod 129548 4 sd_mod,sg,libata,megaraid_mbox
megaraid_mm 8284 1 megaraid_mbox
e100 28908 0
mii 4896 1 e100
e1000 102656 0
thermal 15228 0
processor 32576 1 thermal
fan 4196 0
thermal_sys 10856 4 video,thermal,processor,fan

-- System Information:
Debian Release: 5.0.4
APT prefers stable
APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/2 CPU cores)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.26-2-686 depends on:
ii debconf [debconf-2.0] 1.5.24 Debian configuration
management sy
ii initramfs-tools [linux-initra 0.92o tools for generating an
initramfs
ii module-init-tools 3.4-1 tools for managing Linux
kernel mo


Versions of packages linux-image-2.6.26-2-686 recommends:
ii libc6-i686 2.7-18lenny2 GNU C Library: Shared
libraries [i


Versions of packages linux-image-2.6.26-2-686 suggests:
ii grub 0.97-47lenny2 GRand Unified Bootloader
(Legacy v

pn linux-doc-2.6.26 <none> (no description available)

Versions of packages linux-image-2.6.26-2-686 is related to:
pn firmware-bnx2 <none> (no description available)
pn firmware-bnx2x <none> (no description available)
pn firmware-ipw2x00 <none> (no description available)
pn firmware-ivtv <none> (no description available)
pn firmware-iwlwifi <none> (no description available)
pn firmware-linux <none> (no description available)
pn firmware-linux-nonfree <none> (no description available)
pn firmware-qlogic <none> (no description available)
pn firmware-ralink <none> (no description available)

-- debconf information:
linux-image-2.6.26-2-686/postinst/bootloader-error-2.6.26-2-686:
shared/kernel-image/really-run-bootloader: true
linux-image-2.6.26-2-686/postinst/old-dir-initrd-link-2.6.26-2-686: true
linux-image-2.6.26-2-686/preinst/overwriting-modules-2.6.26-2-686: true
linux-image-2.6.26-2-686/postinst/bootloader-test-error-2.6.26-2-686:
linux-image-2.6.26-2-686/postinst/depmod-error-2.6.26-2-686: false
linux-image-2.6.26-2-686/preinst/bootloader-initrd-2.6.26-2-686: true
linux-image-2.6.26-2-686/preinst/abort-overwrite-2.6.26-2-686:
linux-image-2.6.26-2-686/preinst/abort-install-2.6.26-2-686:
linux-image-2.6.26-2-686/postinst/depmod-error-initrd-2.6.26-2-686: false
linux-image-2.6.26-2-686/postinst/create-kimage-link-2.6.26-2-686: true
linux-image-2.6.26-2-686/preinst/failed-to-move-modules-2.6.26-2-686:
linux-image-2.6.26-2-686/preinst/initrd-2.6.26-2-686:
linux-image-2.6.26-2-686/preinst/lilo-has-ramdisk:
linux-image-2.6.26-2-686/prerm/would-invalidate-boot-loader-2.6.26-2-686: true
linux-image-2.6.26-2-686/postinst/kimage-is-a-directory:
linux-image-2.6.26-2-686/postinst/old-initrd-link-2.6.26-2-686: true
linux-image-2.6.26-2-686/preinst/elilo-initrd-2.6.26-2-686: true
linux-image-2.6.26-2-686/preinst/lilo-initrd-2.6.26-2-686: true
linux-image-2.6.26-2-686/prerm/removing-running-kernel-2.6.26-2-686: true
linux-image-2.6.26-2-686/postinst/old-system-map-link-2.6.26-2-686: true




--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: alpine.DEB.2.00.1003112137550.2291@tpo-laptop">http://lists.debian.org/alpine.DEB.2.00.1003112137550.2291@tpo-laptop

dann frazier 03-11-2010 08:38 PM

Bug#573490: drbd fails to load: "drbd: disagrees about version of symbol cn_add_callback"
 
On Thu, Mar 11, 2010 at 09:43:45PM +0100, Tomas Pospisek wrote:
> Package: linux-2.6
> Version: 2.6.26-21lenny4
> Severity: critical
>
> drbd fails to load and there goes my failover high available cluster...
> *t

well, crap - we ignored that ABI change because google showed only an
old/deprecated module as an out-of-tree user, but we obviously missed
drbd. We'll work on an update to the drbd modules.



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100311213823.GA22353@lackof.org">http://lists.debian.org/20100311213823.GA22353@lackof.org

dann frazier 03-11-2010 10:02 PM

Bug#573490: drbd fails to load: "drbd: disagrees about version of symbol cn_add_callback"
 
tags 573490 + patch
affects 573490 drbd8-source
thanks

On Thu, Mar 11, 2010 at 02:38:23PM -0700, dann frazier wrote:
> On Thu, Mar 11, 2010 at 09:43:45PM +0100, Tomas Pospisek wrote:
> > Package: linux-2.6
> > Version: 2.6.26-21lenny4
> > Severity: critical
> >
> > drbd fails to load and there goes my failover high available cluster...
> > *t
>
> well, crap - we ignored that ABI change because google showed only an
> old/deprecated module as an out-of-tree user, but we obviously missed
> drbd. We'll work on an update to the drbd modules.

This patch builds for me, but I don't have a drbd setup. I'd
appreciate it if someone could test it :)

Tomas Pospisek 03-16-2010 06:45 AM

Bug#573490: drbd fails to load: "drbd: disagrees about version of symbol cn_add_callback"
 
Dann,

sorry for replying late - I just installed the new drbd8 modules:

Setting up drbd8-modules-2.6.26-2-686 (2.6.26+8.0.14-6+lenny3) ...
Setting up drbd8-modules-2.6-686 (2:2.6.26-6+lenny3) ...
Setting up drbd8-utils (2:8.0.14-2+lenny1) ...

together with the latest lenny4 kernel:

Setting up linux-image-2.6.26-2-686 (2.6.26-21lenny4)

and can confirm that they work again, and that the new drbd also works
together with the previous lenny versions of the kernel and of drbd -
namely with:


drbd8-modules-2.6.26-2-686 (2.6.26+8.0.14-6+lenny1)
linux-image-2.6.26-2-686 (2.6.26-21lenny3)


From my log:


... drbd0: conn( SyncSource -> Connected ) pdsk( Inconsistent -> UpToDate )

Thanks a lot!!!!!!!!!!!!!!

I guess then that kernel linux-image-2.6.26-2-686 (2.6.26-21lenny4) should
be conflicting with the previous, incompatible drbd package
<= drbd8-modules-2.6.26-2-686 (2.6.26+8.0.14-6+lenny3) in order to force
an upgrade to a compatible drbd package?


Thanks again,
*t

On Thu, 11 Mar 2010, dann frazier wrote:


tags 573490 + patch
affects 573490 drbd8-source
thanks

On Thu, Mar 11, 2010 at 02:38:23PM -0700, dann frazier wrote:

On Thu, Mar 11, 2010 at 09:43:45PM +0100, Tomas Pospisek wrote:

Package: linux-2.6
Version: 2.6.26-21lenny4
Severity: critical

drbd fails to load and there goes my failover high available cluster...
*t


well, crap - we ignored that ABI change because google showed only an
old/deprecated module as an out-of-tree user, but we obviously missed
drbd. We'll work on an update to the drbd modules.


This patch builds for me, but I don't have a drbd setup. I'd
appreciate it if someone could test it :)





--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: alpine.DEB.2.00.1003160836140.3907@tpo-laptop">http://lists.debian.org/alpine.DEB.2.00.1003160836140.3907@tpo-laptop


All times are GMT. The time now is 04:07 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.