FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 03-01-2010, 11:50 AM
Jens-Michael Hoffmann
 
Default Bug#572067: linux-libc-dev: Can not install, file conflict with libdrm

Package: linux-libc-dev
Version: 2.6.33-1~experimental.2
Severity: normal

When trying to install linux-libc-dev from experimental, dpkg shows the following error message:

dpkg: error processing /var/cache/apt/archives/linux-libc-dev_2.6.33-1~experimental.2_amd64.deb (--unpack):
trying to overwrite '/usr/include/drm/nouveau_drm.h', which is also in package libdrm-dev 0:2.4.18-2


-- System Information:
Debian Release: squeeze/sid
APT prefers unstable
APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.33 (SMP w/16 CPU cores)
Locale: LANG=de_DE, LC_CTYPE=de_DE (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/dash

-- no debconf information



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100301125000.5892.11396.reportbug@localhost.his. lan">http://lists.debian.org/20100301125000.5892.11396.reportbug@localhost.his. lan
 
Old 03-05-2010, 03:03 AM
Ben Hutchings
 
Default Bug#572067: linux-libc-dev: Can not install, file conflict with libdrm

On Mon, 2010-03-01 at 13:50 +0100, Jens-Michael Hoffmann wrote:
> Package: linux-libc-dev
> Version: 2.6.33-1~experimental.2
> Severity: normal
>
> When trying to install linux-libc-dev from experimental, dpkg shows the following error message:
>
> dpkg: error processing /var/cache/apt/archives/linux-libc-dev_2.6.33-1~experimental.2_amd64.deb (--unpack):
> trying to overwrite '/usr/include/drm/nouveau_drm.h', which is also in package libdrm-dev 0:2.4.18-2

It makes no sense to have the DRM headers split between libdrm-dev and
linux-libc-dev. I'm happy to have libdrm-dev provide them all. What do
you want to do?

Ben.

--
Ben Hutchings
Q. Which is the greater problem in the world today, ignorance or apathy?
A. I don't know and I couldn't care less.
 
Old 03-05-2010, 08:59 AM
Julien Cristau
 
Default Bug#572067: linux-libc-dev: Can not install, file conflict with libdrm

On Fri, Mar 5, 2010 at 04:03:15 +0000, Ben Hutchings wrote:

> On Mon, 2010-03-01 at 13:50 +0100, Jens-Michael Hoffmann wrote:
> > Package: linux-libc-dev
> > Version: 2.6.33-1~experimental.2
> > Severity: normal
> >
> > When trying to install linux-libc-dev from experimental, dpkg shows the following error message:
> >
> > dpkg: error processing /var/cache/apt/archives/linux-libc-dev_2.6.33-1~experimental.2_amd64.deb (--unpack):
> > trying to overwrite '/usr/include/drm/nouveau_drm.h', which is also in package libdrm-dev 0:2.4.18-2
>
> It makes no sense to have the DRM headers split between libdrm-dev and
> linux-libc-dev. I'm happy to have libdrm-dev provide them all. What do
> you want to do?
>
I think we should go back to libdrm-dev installing the headers. I sent
a patch to dri-devel a few days ago that makes libdrm install its
headers in $(includedir)/libdrm so they don't conflict with the ones
installed by the kernel, waiting for some feedback on that…

Cheers,
Julien
 

Thread Tools




All times are GMT. The time now is 10:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org