FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 02-26-2010, 10:49 AM
George Dunlap
 
Default Bug#571603: linux-image-2.6.26-2-xen-686: Dom0 crashes on newer hypervisors if msi interrupts are available

Package: linux-image-2.6.26-2-xen-686
Version: 2.6.26-21lenny3
Severity: normal
Tags: patch

The default Debian kernel dom0 will not boot on
hypervisors >= Xen 3.3 if MSI interrupts are available.

The reason for this is that one of the patches included
in the build (suse-200808...) has an incorrect structure
definition. (It was a structure used at some point during
development, but changed before the 3.3 release. The patch
was a snapshot of development after the initial change but
before the final version.)

The attached patch updates the msi code to the appropriate
(released, stable, forwards-compatible) structure definition,
so that the 2.6.26-xen kernel can boot on future hypervisors
(including the upcoming 4.0 release). I've already tested it
within the debian source build system.

A work-around is to add "pci=nosmi" on the kernel command line.

-- System Information:
Debian Release: 5.0.3
APT prefers stable
APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.26-2-xen-686 depends on:
ii initramfs-tools 0.92o tools for generating an initramfs
ii linux-modules-2.6. 2.6.26-21lenny3 Linux 2.6.26 modules on i686

Versions of packages linux-image-2.6.26-2-xen-686 recommends:
ii libc6-xen 2.7-18lenny2 GNU C Library: Shared libraries [X

Versions of packages linux-image-2.6.26-2-xen-686 suggests:
ii grub 0.97-47lenny2 GRand Unified Bootloader (Legacy v
pn linux-doc-2.6.26 <none> (no description available)

-- no debconf information
 

Thread Tools




All times are GMT. The time now is 08:32 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org