FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 02-13-2010, 10:41 AM
maximilian attems
 
Default Bug#544709: linux-image-2.6.30-1-686: /proc/acpi/button/lid/*/state always says "open"

tags 544709 moreinfo
stop

On Wed, 02 Sep 2009, Josue Abarca wrote:

> Package: linux-image-2.6.30-1-686
> Version: 2.6.30-6
> Severity: normal
>

can you reproduce with 2.6.32 ?

thanks for your feedback.



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-19-2010, 05:41 PM
Josue Abarca
 
Default Bug#544709: linux-image-2.6.30-1-686: /proc/acpi/button/lid/*/state always says "open"

On Sat, Feb 13, 2010 at 12:41:17PM +0100, maximilian attems wrote:
> tags 544709 moreinfo
> stop
>
> On Wed, 02 Sep 2009, Josue Abarca wrote:
>
> > Package: linux-image-2.6.30-1-686
> > Version: 2.6.30-6
> > Severity: normal
> >
>
> can you reproduce with 2.6.32 ?

Yes, I can.

Using linux-image-2.6.32-2-686 2.6.32-8


>
> thanks for your feedback.

thanks for your work.

--
Josué M. Abarca S.
Vos mereces Software Libre.
PGP key 4096R/70D8FB2A 2009-06-17
fingerprint = B3ED 4984 F65A 9AE0 6511 DAF4 756B EB4B 70D8 FB2A



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100219184107.GA3360@zumi.usac.edu.gt">http://lists.debian.org/20100219184107.GA3360@zumi.usac.edu.gt
 
Old 02-22-2010, 09:34 AM
maximilian attems
 
Default Bug#544709: linux-image-2.6.30-1-686: /proc/acpi/button/lid/*/state always says "open"

On Fri, 19 Feb 2010, Josue Abarca wrote:

> On Sat, Feb 13, 2010 at 12:41:17PM +0100, maximilian attems wrote:
> > can you reproduce with 2.6.32 ?
>
> Yes, I can.
>
> Using linux-image-2.6.32-2-686 2.6.32-8
>

please post output of:
cat /proc/acpi/video/*/DOS

also please check if you have hotkey-setup installed,
if it is installed, please nuke it and reboot.

your box seems newer as 8xx where this state can not be trusted at all:
http://patchwork.kernel.org/patch/78947/

thanks again for your feedback.




--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100222103401.GA5185@stro.at">http://lists.debian.org/20100222103401.GA5185@stro.at
 
Old 02-23-2010, 01:02 PM
Josue Abarca
 
Default Bug#544709: linux-image-2.6.30-1-686: /proc/acpi/button/lid/*/state always says "open"

On Mon, Feb 22, 2010 at 11:34:01AM +0100, maximilian attems wrote:
> On Fri, 19 Feb 2010, Josue Abarca wrote:
>
> > On Sat, Feb 13, 2010 at 12:41:17PM +0100, maximilian attems wrote:
> > > can you reproduce with 2.6.32 ?
> >
> > Yes, I can.
> >
> > Using linux-image-2.6.32-2-686 2.6.32-8
> >
>
> please post output of:
> cat /proc/acpi/video/*/DOS
>
> also please check if you have hotkey-setup installed,
> if it is installed, please nuke it and reboot.
>
> your box seems newer as 8xx where this state can not be trusted at all:
> http://patchwork.kernel.org/patch/78947/
>
> thanks again for your feedback.


Yes, I have hotkey-setup 0.1-23 installed.

with hotkey-setup installed
$ cat /proc/acpi/video/*/DOS
DOS setting: <7>
after a cold boot: lid switch not working.

After hibernate and waking the machine, the same
$ cat /proc/acpi/video/*/DOS
DOS setting: <7>
but lid switch is working.

after that, I removed the hotkey-setup package:
# apt-get purge hotkey-setup
# reboot
$ cat /proc/acpi/video/*/DOS
DOS setting: <0>

The lid switch is working
This is a great workaround for me.

But what is the problem?, is the bug in the hotkey-setup package?

Thanks a lot for your help.
--
Josué M. Abarca S.
Vos mereces Software Libre.
PGP key 4096R/70D8FB2A 2009-06-17
Huella de clave = B3ED 4984 F65A 9AE0 6511 DAF4 756B EB4B 70D8 FB2A



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100223140210.GA3503@rivendel">http://lists.debian.org/20100223140210.GA3503@rivendel
 
Old 02-23-2010, 01:10 PM
maximilian attems
 
Default Bug#544709: linux-image-2.6.30-1-686: /proc/acpi/button/lid/*/state always says "open"

reassign 544709 hotkey-setup
severity 544709 serious
stop

[ adding cc's in case this needs discussions. ]

On Tue, Feb 23, 2010 at 08:02:10AM -0600, Josue Abarca wrote:
> On Mon, Feb 22, 2010 at 11:34:01AM +0100, maximilian attems wrote:
> > On Fri, 19 Feb 2010, Josue Abarca wrote:
> >
> > > On Sat, Feb 13, 2010 at 12:41:17PM +0100, maximilian attems wrote:
> > > > can you reproduce with 2.6.32 ?
> > >
> > > Yes, I can.
> > >
> > > Using linux-image-2.6.32-2-686 2.6.32-8
> > >
> >
> > please post output of:
> > cat /proc/acpi/video/*/DOS
> >
> > also please check if you have hotkey-setup installed,
> > if it is installed, please nuke it and reboot.
> >
> > your box seems newer as 8xx where this state can not be trusted at all:
> > http://patchwork.kernel.org/patch/78947/
> >
> > thanks again for your feedback.
>
>
> Yes, I have hotkey-setup 0.1-23 installed.
>
> with hotkey-setup installed
> $ cat /proc/acpi/video/*/DOS
> DOS setting: <7>
> after a cold boot: lid switch not working.
>
> After hibernate and waking the machine, the same
> $ cat /proc/acpi/video/*/DOS
> DOS setting: <7>
> but lid switch is working.
>
> after that, I removed the hotkey-setup package:
> # apt-get purge hotkey-setup
> # reboot
> $ cat /proc/acpi/video/*/DOS
> DOS setting: <0>
>
> The lid switch is working
> This is a great workaround for me.
>
> But what is the problem?, is the bug in the hotkey-setup package?

indeed reassigning, this package is not fit for release
if it pokes that badly and tries to override linux-2.6
only had found out by luck on a google search of your trouble.

> Thanks a lot for your help.

thanks for your feedback and kind regards

--
maks


--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100223141057.GF15228@baikonur.stro.at">http://lists.debian.org/20100223141057.GF15228@baikonur.stro.at
 

Thread Tools




All times are GMT. The time now is 02:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org