FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 12-24-2008, 08:32 PM
Matt Taggart
 
Default Bug#497593: new iwlwifi firmware available

As of December 24, 2008, and according to

http://intellinuxwireless.org/?p=iwlwifi&n=downloads

The latest version for 3945 is 15.28.2.8
The latest version for 4965 is 228.57.2.23

It would be nice to get these updated in the non-free that will freeze
with lenny. I know the lenny kernel is frozen and that changing these
firmware blobs might introduce risk to people using these devices, I
think that because they are non-free the best option is to ship the
latest version for use with lenny for the following reasons.

* Ensure support for the most and newest devices
* Ensure support for new hardware for the longest amount of time
before users need to backport or install by hand
* Ensure (hopefully) the least number of upstream bugs
* If a user running the current version has a problem, they would just
be told to try the latest version. Better to provide the
latest version by default and if a user has a problem, tell them
to try an older version.
* Intel has their own QA process, debian shouldn't need to do it for
them (especially for firmware and without source)

Thanks,

--
Matt Taggart
taggart@debian.org



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-11-2009, 08:33 AM
David Robin
 
Default Bug#497593: new iwlwifi firmware available

Hi Matt,

watchout, the latest firmware are expected to be incompatible with the Wifi drivers included in Lenny (linux 2.6.26).
This is mentioned in the README file in the firmware distribution (cf. iwlwifi-3945-ucode-15.28.2.8/README.iwlwifi-3945-ucode).


For example, the latest 2.6.26 compatible releases are :
iwl3945 : 15.28.1.8
iwl4965 : 228.57.1.21

Anyway, the package may include later versions of the firmware too : it would be appreciated by Debian users compiling their own build of Linux 2.6.18 or later.


Regards,
David
 
Old 01-11-2009, 09:15 AM
Matt Taggart
 
Default Bug#497593: new iwlwifi firmware available

> Hi Matt,
>
> watchout, the latest firmware are expected to be incompatible with the Wifi
> drivers included in Lenny (linux 2.6.26).

Ah thanks for the heads up.

> This is mentioned in the README file in the firmware distribution (cf.
> iwlwifi-3945-ucode-15.28.2.8/README.iwlwifi-3945-ucode).
>
> For example, the latest 2.6.26 compatible releases are :
> iwl3945 : 15.28.1.8

This is slightly newer than the 15.28.1.6 in lenny.

> iwl4965 : 228.57.1.21

This is up to date.

> Anyway, the package may include later versions of the firmware too : it
> would be appreciated by Debian users compiling their own build of Linux
> 2.6.18 or later.

Yeah that's a good point. (and I think you mean .28, but anything newer
really)

--
Matt Taggart
taggart@debian.org





--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 10:22 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org