FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 12-20-2008, 02:36 PM
John Parejko
 
Default Bug#509269: linux-image-2.6.18-6-sparc64-smp: HIDDEV not included in sparc kernel image

Package: linux-image-2.6.18-6-sparc64-smp
Version: 2.6.18.dfsg.1-23etch1
Severity: important


In order to use the apcupsd package with a USB connected UPS, HIDDEV
must be included in the kernel, either built-in, or as a module. But
it is not in the default sparc kernel build at all.

Why was it removed from the kernel image?

I request that HIDDEV be reinserted as a module in the default sparc
kernel (both single-processor and smp builds), as these systems can
support usb (sometimes with an add-on PCI controller, as in my case),
unless there is a compelling reason to leave it out.

Thank you
John


-- System Information:
Debian Release: 4.0
APT prefers stable
APT policy: (500, 'stable')
Architecture: sparc (sparc64)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-6-sparc64-smp
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages linux-image-2.6.18-6-sparc64-smp depends on:
ii coreutils 5.97-5.3 The GNU core utilities
ii debconf [debconf-2.0] 1.5.11etch2 Debian configuration management sy
ii initramfs-tools [linux-initr 0.85i tools for generating an initramfs
ii module-init-tools 3.3-pre4-2 tools for managing Linux kernel mo

linux-image-2.6.18-6-sparc64-smp recommends no packages.

-- debconf information:
linux-image-2.6.18-6-sparc64-smp/postinst/depmod-error-2.6.18-6-sparc64-smp: false
linux-image-2.6.18-6-sparc64-smp/prerm/would-invalidate-boot-loader-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/preinst/failed-to-move-modules-2.6.18-6-sparc64-smp:
shared/kernel-image/really-run-bootloader: true
linux-image-2.6.18-6-sparc64-smp/preinst/overwriting-modules-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/postinst/old-system-map-link-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/postinst/create-kimage-link-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/preinst/abort-overwrite-2.6.18-6-sparc64-smp:
linux-image-2.6.18-6-sparc64-smp/preinst/initrd-2.6.18-6-sparc64-smp:
* linux-image-2.6.18-6-sparc64-smp/preinst/already-running-this-2.6.18-6-sparc64-smp:
linux-image-2.6.18-6-sparc64-smp/preinst/elilo-initrd-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/preinst/bootloader-initrd-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/preinst/lilo-initrd-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/postinst/kimage-is-a-directory:
linux-image-2.6.18-6-sparc64-smp/postinst/depmod-error-initrd-2.6.18-6-sparc64-smp: false
linux-image-2.6.18-6-sparc64-smp/postinst/old-dir-initrd-link-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/preinst/lilo-has-ramdisk:
linux-image-2.6.18-6-sparc64-smp/prerm/removing-running-kernel-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/postinst/old-initrd-link-2.6.18-6-sparc64-smp: true
linux-image-2.6.18-6-sparc64-smp/postinst/bootloader-test-error-2.6.18-6-sparc64-smp:
linux-image-2.6.18-6-sparc64-smp/postinst/bootloader-error-2.6.18-6-sparc64-smp:
linux-image-2.6.18-6-sparc64-smp/preinst/abort-install-2.6.18-6-sparc64-smp:



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 07:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org