FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 11-29-2008, 12:23 AM
Moritz Muehlenhoff
 
Default Bug#421779: linux-source-2.6.18: Poweroff doesn't work on Sony VAIO S4M

On Tue, May 01, 2007 at 02:28:28PM +0200, Marcello Maggioni wrote:
> Package: linux-source-2.6.18
> Version: 2.6.18.dfsg.1-12
> Severity: normal
>
>
> I've tried recompiling the kernel , playing with ACPI options (kernel
> configurations and acpi= parameters) , but POWEROFF doesn't work.
>
> When I do "shutdown -h now" the system starts powering off and then
> stops with the line :
>
> acpi_power_off called
>
> I've also tried the lastest mainline vanilla kernel 2.6.21.1 and I've
> got the same problem.
>
> I've also tried powering off by APM and what I've got is a black screen
> after shutdown -h now finish to umounting the filesystems , but the
> system remains on (Fan spinning and the screen is black , but the LCD
> backlight is still on).
>
> I will attach my dmesg in the next message .

Does this error still occur with more recent kernel versions?

If you're running Etch, could you try to reproduce this bug
with the 2.6.24 based kernel added in 4.0r4?
http://packages.qa.debian.org/l/linux-2.6.24.html

Cheers,
Moritz



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-29-2008, 01:28 AM
"Michele Cascella"
 
Default Bug#421779: linux-source-2.6.18: Poweroff doesn't work on Sony VAIO S4M

Hi,

On Sat, Nov 29, 2008 at 2:23 AM, Moritz Muehlenhoff <jmm@inutil.org> wrote:
>
> On Tue, May 01, 2007 at 02:28:28PM +0200, Marcello Maggioni wrote:
> > Package: linux-source-2.6.18
> > Version: 2.6.18.dfsg.1-12
> > Severity: normal
> >
> >
> > I've tried recompiling the kernel , playing with ACPI options (kernel
> > configurations and acpi= parameters) , but POWEROFF doesn't work.
> >
> > When I do "shutdown -h now" the system starts powering off and then
> > stops with the line :
> >
> > acpi_power_off called
> >
> > I've also tried the lastest mainline vanilla kernel 2.6.21.1 and I've
> > got the same problem.
> >
> > I've also tried powering off by APM and what I've got is a black screen
> > after shutdown -h now finish to umounting the filesystems , but the
> > system remains on (Fan spinning and the screen is black , but the LCD
> > backlight is still on).
> >
> > I will attach my dmesg in the next message .
>
> Does this error still occur with more recent kernel versions?
>

problems is fixed in 2.6.26 (but this kernel has other issues with the
sony S5 hw)

> If you're running Etch, could you try to reproduce this bug
> with the 2.6.24 based kernel added in 4.0r4?
> http://packages.qa.debian.org/l/linux-2.6.24.html

I'm running testing now. I think the kernel from etch-and-a-half is
not compatible with my HAL. I'll see if I can try it.

Regards,

Emme

>
> Cheers,
> Moritz
>
>
>
> --
> To unsubscribe, send mail to 421779-unsubscribe@bugs.debian.org.



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:20 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org