FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Kernel

 
 
LinkBack Thread Tools
 
Old 07-02-2008, 06:39 PM
Josh Triplett
 
Default Bug#489008: initramfs-tools: Does not work with labels containing '/'

Package: initramfs-tools
Version: 0.92b
Severity: important

(Severity important because it renders the system unbootable; not RC
because it does not apply to all configurations.)

The initramfs scripts cannot handle a label containing '/'. For
example, if I boot with root=LABEL=/alt-root , I get a message saying
the initramfs could not find /dev/disk/by-label//alt-root . From the
initramfs shell, "echo /dev/disk/by-label/*" showed
/dev/disk/by-label/x2falt-root . However, on the booted system I see
/dev/disk/by-label/alt-root.

Note that both /usr/share/initramfs-tools/init and
/usr/share/initramfs-tools/scripts/local-premount/resume deal with
labels.

- Josh Triplett



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 08-17-2008, 06:35 AM
Sven Joachim
 
Default Bug#489008: initramfs-tools: Does not work with labels containing '/'

On 2008-07-02 20:39 +0200, Josh Triplett wrote:

> The initramfs scripts cannot handle a label containing '/'.

Same here, with the label being "/". :-(

> For example, if I boot with root=LABEL=/alt-root , I get a message
> saying the initramfs could not find /dev/disk/by-label//alt-root .

Hm, I don't even get such a message, but simply "mount: No such device"
followed by three "mount: No such file or directory" messages before I
land in busybox.

> From the initramfs shell, "echo /dev/disk/by-label/*" showed
> /dev/disk/by-label/x2falt-root . However, on the booted system I see
> /dev/disk/by-label/alt-root.

Shouldn't that be /dev/disk/by-label/xf2alt-root? Except if you're
using zsh, which will convert xf2 to /.

Sven



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 08-24-2008, 02:59 PM
Martin Michlmayr
 
Default Bug#489008: initramfs-tools: Does not work with labels containing '/'

* Sven Joachim <svenjoac@gmx.de> [2008-08-17 08:35]:
> > From the initramfs shell, "echo /dev/disk/by-label/*" showed
> > /dev/disk/by-label/x2falt-root . However, on the booted system I see
> > /dev/disk/by-label/alt-root.
>
> Shouldn't that be /dev/disk/by-label/xf2alt-root? Except if you're
> using zsh, which will convert xf2 to /.

It's x2f (not xf2), and yes I can confirm that it shows up like this
in the installed system as well as in initramfs:

debian:~# cd /dev/disk/by-label/
debian:/dev/disk/by-label# ls
x2f x2fboot
debian:/dev/disk/by-label#

--
Martin Michlmayr
http://www.cyrius.com/



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:47 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org