Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian KDE (http://www.linux-archive.org/debian-kde/)
-   -   no window visible of newly launched applications (http://www.linux-archive.org/debian-kde/690853-no-window-visible-newly-launched-applications.html)

"Andreas v. Heydwolff" 08-05-2012 04:06 PM

no window visible of newly launched applications
 
Hello,

my system: amd64, an up-to-date KDE 4.8 from Wheezy, some sid packages.

The quite annoying problem:

Since several months, usually after an uptime of often less than 12
hours, several KDE applications (okular, gwenview, dolphin, kwrite) that
have been launched a few times and closed again can only be launched and
seen as a process, but the do no longer appear as windows. They are not
visible in the task bar either.

When one of them degrades, none of the others can be newly launched and
be seen any more. Open instances continue to function but, e.g., opening
a pdf with okular from within a visible dolphin window also no longer works.

Launching the applications from konsole doesn't make a difference: The
process is being created, but the window cannot be seen, "Show
Application Window" in the System Activity plasmoid does not function.

The logout dialog is usually by then also unresponsive, and issuing
"reboot &" in konsole may no longer work as well, while "shutdown now
-h" usually still works.

Konqueror remains unaffected, the same is true for LibreOffice or other
non-KDE apps.

There are no defunct or zombie instances visible with ps and
.xsession-errors remains empty. After a reboot everything is fine again
for a while.

Any ideas how to debug this?

Greetings,
Andreas

--
Installed versions:

ii libqtgui4:amd64 4:4.8.2-2
ii libqtcore4:amd64 4:4.8.2-2
ii libkdeui5 4:4.8.4-3
ii libkdecore5 4:4.8.4-3
ii libkio5 4:4.8.4-3


ii dbus 1.6.2-2
ii dbus-x11 1.6.2-2
ii libdbus-1-3:amd64 1.6.2-2
ii libdbus-1-dev 1.6.2-2
ii libdbus-glib-1-2:amd64 0.100-1
ii libdbusmenu-glib4:amd64 0.6.2-1
ii libdbusmenu-qt-dev 0.9.0-1
ii libdbusmenu-qt2 0.9.0-1
ii libnet-dbus-perl 1.0.0-1+b1
ii libqt4-dbus:amd64 4:4.8.2-1
ii libsmokeqtdbus4-3 4:4.8.4-1
ii libstrigiqtdbusclient-dev 0.7.7-3
ii libstrigiqtdbusclient0 0.7.7-3
ii python-dbus 1.1.1-1
ii python-dbus-dev 1.1.1-1
ii python-qt4-dbus 4.9.3-3
ii qdbus 4:4.8.2-1


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 501E99EC.90008@sandpsych.at">http://lists.debian.org/501E99EC.90008@sandpsych.at

"Andreas v. Heydwolff" 08-07-2012 03:06 PM

no window visible of newly launched applications
 
On 2012-08-05 18:09, Waldo Cancino wrote:> Hello,
>
> Same symptoms here. Latest KDE from sid.

Waldo afterwards found the following:

---- quote ----
Some good news, aparently is a problem in gamin server,

take a look at bug
#542361
I update my gamin packages but u can start ur programs

killing the gaming server (gam_server)

-- end quote ---

I opened some 30 instances of okular and couldn't start dolphin
afterwards, killed the gamin server - and voila, a dolphin and another
okular window popped up on the screen. Now I've upgraded

gamin libgamin0

from Wheezy to the sid versions, hope that was it.

Cheers,
Andreas


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 50212EE3.8050003@sandpsych.at">http://lists.debian.org/50212EE3.8050003@sandpsych.at


All times are GMT. The time now is 07:12 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.