FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 07-07-2012, 12:22 PM
Sune Vuorela
 
Default kde daemon crashes

On 2012-07-07, Jacopo Nespolo <j.nespolo@gmail.com> wrote:
> Can anyone suggest against which packet i should file the bug?

So far, there is not enough information to make a bug report even close
to usable, so let's hold off for that for now.

> #13 0xabac8b18 in ?? () from /usr/lib/kde4/kded_kmixd.so
> #14 0xabac0904 in ?? () from /usr/lib/kde4/kded_kmixd.so
> #15 0xabac04e0 in ?? () from /usr/lib/kde4/kded_kmixd.so

So. what's going on with the kmix thingie in kded? try install
kdemultimedia-dbg

/Sune


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: slrnjvgagm.d1u.nospam@sshway.ssh.pusling.com">http ://lists.debian.org/slrnjvgagm.d1u.nospam@sshway.ssh.pusling.com
 
Old 07-07-2012, 12:23 PM
Sune Vuorela
 
Default kde daemon crashes

On 2012-07-07, john Culleton <John@wexfordpress.com> wrote:
Dear John Culleton

Please find another maillist to troll on. Thanks in advance.

/Sune


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: slrnjvgaiv.d1u.nospam@sshway.ssh.pusling.com">http ://lists.debian.org/slrnjvgaiv.d1u.nospam@sshway.ssh.pusling.com
 
Old 07-07-2012, 12:49 PM
"Andreas v. Heydwolff"
 
Default kde daemon crashes

Hello,
may I tune in? Since many weeks when I have kde 4.8.3/now .4 running for
half a day or day, okular, dolphin, and gwenview won't start any more.
konqueror seems to be unaffected.

Usually logging out, killing all the user's kde processes if any are
left over, and logging in again will not suffice but I will have to
restart my amd64 "mainly Wheezy/a little bit of sid" system.

Could this be a problem related to the one discussed here?

I had hoped to get away with updating the whole system on a daily basis
and the bug would "automagically" go away, but so far it didn't,
although the amount of times seems to have increased (from 4 or 5 to 8
or 10 times) how often I can start another instance of okular and
dolphin until "session rot" sets in.

If it's not related, would anyone have any clues how to debug this behavior?

Best,
Andreas


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4FF83066.6010007@sandpsych.at">http://lists.debian.org/4FF83066.6010007@sandpsych.at
 
Old 07-07-2012, 02:53 PM
Sune Vuorela
 
Default kde daemon crashes

On 2012-07-07, Andreas v. Heydwolff <listmail@sandpsych.at> wrote:
> Hello,
> may I tune in? Since many weeks when I have kde 4.8.3/now .4 running for
> half a day or day, okular, dolphin, and gwenview won't start any more.
> konqueror seems to be unaffected.

What do you mean with 'wont start'? do you get any feedback at all? what
if you try to launch the applicÄations from konsole?

anytihng interested printed to .xsession-errors while starting the apps?
in one konsole tab/window, do tail -f .xsession-errors and try launch
the application from another tab/vwindow

> Could this be a problem related to the one discussed here?

Most likely not.

> I had hoped to get away with updating the whole system on a daily basis
> and the bug would "automagically" go away, but so far it didn't,

I don't believe in magic

/Sune


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: slrnjvgjc1.d1u.nospam@sshway.ssh.pusling.com">http ://lists.debian.org/slrnjvgjc1.d1u.nospam@sshway.ssh.pusling.com
 
Old 07-07-2012, 03:04 PM
Reinhard Karcher
 
Default kde daemon crashes

Am 07.07.2012 16:53, schrieb Sune Vuorela:

On 2012-07-07, Andreas v. Heydwolff<listmail@sandpsych.at> wrote:

Hello,
may I tune in? Since many weeks when I have kde 4.8.3/now .4 running for
half a day or day, okular, dolphin, and gwenview won't start any more.
konqueror seems to be unaffected.




I run into such problems after an dbus update. After a reboot, all is well.

Reinhard


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4FF84FEB.70208@gmx.net">http://lists.debian.org/4FF84FEB.70208@gmx.net
 
Old 07-07-2012, 03:22 PM
"Andreas v. Heydwolff"
 
Default kde daemon crashes

Thanks, Sune ...

On 2012-07-07 16:53, Sune Vuorela wrote:
> On 2012-07-07, Andreas v. Heydwolff <listmail@sandpsych.at> wrote:
>> half a day or day, okular, dolphin, and gwenview won't start any more.
>> konqueror seems to be unaffected.
>
> What do you mean with 'wont start'? do you get any feedback at all? what
> if you try to launch the applicÄations from konsole?

no feedback at all, launching from konsole then doesn't work any more either

> anytihng interested printed to .xsession-errors while starting the apps?
> in one konsole tab/window, do tail -f .xsession-errors and try launch
> the application from another tab/vwindow

.xsession-errors remains empty.

~$ strace dolphin

generates these lines als the last bit of output; this is where it gets
stuck.

stat("/home/avh/.local/share/user-places.xbel", {st_mode=S_IFREG|0644,
st_size=14447, ...}) = 0
open("/home/avh/.local/share/user-places.xbel", O_RDONLY|O_CLOEXEC) = 9
fcntl(9, F_SETFD, FD_CLOEXEC) = 0
fstat(9, {st_mode=S_IFREG|0644, st_size=14447, ...}) = 0
fstat(9, {st_mode=S_IFREG|0644, st_size=14447, ...}) = 0
read(9, "<?xml version="1.0" encoding="UT"..., 16384) = 14447
read(9, "", 1937) = 0
brk(0x1f58000) = 0x1f58000
brk(0x1f79000) = 0x1f79000
read(9, "", 913) = 0
read(9, "", 16384) = 0
read(9, "", 1024) = 0
close(9) = 0
rt_sigaction(SIGUSR2, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGUSR2, {0x7f1d3f626d60, [USR2], SA_RESTORER|SA_RESTART,
0x7f1d470174f0}, {SIG_DFL, [], 0}, 8) = 0
getuid() = 1000
socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 9
connect(9, {sa_family=AF_FILE, path="/var/run/nscd/socket"}, 110) = 0
sendto(9, "2v7passwd", 19, MSG_NOSIGNAL, NULL, 0)
= 19
poll([{fd=9, events=POLLIN|POLLERR|POLLHUP}], 1, 5000) = 1 ([{fd=9,
revents=POLLIN|POLLHUP}])
recvmsg(9, {msg_name(0)=NULL, msg_iov(2)=[{"passwd", 7},
{"270O3", 8}], msg_controllen=24, {cmsg_len=20,
cmsg_level=SOL_SOCKET, cmsg_type=SCM_RIGHTS, {10}},
msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 15
mmap(NULL, 217016, PROT_READ, MAP_SHARED, 10, 0) = 0x7f1d47662000
close(10) = 0
close(9) = 0
socket(PF_FILE, SOCK_STREAM, 0) = 9
connect(9, {sa_family=AF_FILE, path=@"/tmp/fam-avh-"}, 110) = ?
ERESTARTSYS (To be restarted)
--- SIGWINCH (Window changed) @ 0 (0) ---


connect(9, {sa_family=AF_FILE, path=@"/tmp/fam-avh-"}, 110




>> Could this be a problem related to the one discussed here?
> Most likely not.
ok


What's my task now to debug this?
And I guess I should open a new thread?

Andreas


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4FF85446.1050002@sandpsych.at">http://lists.debian.org/4FF85446.1050002@sandpsych.at
 
Old 07-09-2012, 06:32 PM
Robert van den Berg
 
Default kde daemon crashes

On Friday 06 July 2012 09:57:49 Jacopo Nespolo wrote:
> Dear All,
> I'm running on Sid with all the latest upgrades. Kde Daemon often
> crashes on me, sometimes randomly, sometimes as I open Amarok or
> resume from screen lock or sleep. I wasn't really able to link the
> crash to a specific series of events.
>
> Any help is most welcome.
> Thanks all,
> Jacopo

I experienced KDE Daemon crashes as well, basically every time I logged on. I
finally arrived at the following bug report for KDE:
https://bugs.kde.org/show_bug.cgi?id=209975 and a related
bug report for alsa: https://bugtrack.alsa-project.org/alsa-
bug/view.php?id=5471 .

Maybe you suffer from the same bug. Workarounds can be found here:
https://bugs.kde.org/show_bug.cgi?id=209975#c99 ,
https://bugs.kde.org/show_bug.cgi?id=209975#c103 ,
https://bugs.kde.org/show_bug.cgi?id=209975#c117 . And it's either to run as
root alsactl init, or installing alsa-utils, or run as root alsaconf.

Installing alsa-utils solved the problem for me.

Cheers and good luck,

Robert


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201207092032.05765.vandenberg.ra78@gmail.com">http ://lists.debian.org/201207092032.05765.vandenberg.ra78@gmail.com
 
Old 07-09-2012, 07:26 PM
Jacopo Nespolo
 
Default kde daemon crashes

Hi

On 9 July 2012 20:32, Robert van den Berg <vandenberg.ra78@gmail.com> wrote:
> Maybe you suffer from the same bug. Workarounds can be found here:
> https://bugs.kde.org/show_bug.cgi?id=209975#c99 ,
> https://bugs.kde.org/show_bug.cgi?id=209975#c103 ,
> https://bugs.kde.org/show_bug.cgi?id=209975#c117 . And it's either to run as
> root alsactl init, or installing alsa-utils, or run as root alsaconf.

I arrived to the same bug, too. The problem is i don't have any trace
of ALSA, and i kind of like it that way cause i think phonon+pulse+vlc
is a far superior combination in many aspects (but this is mostly on
my personal experience rather than any technical knowledge of what
happens under the hood).

Anyway, if kmix needed alsa-utils to work properly, i think we should
eventually file a bug in debian and have dependencies fixed, shouldn't
we?

cheers,
j


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/CAPRP9-tDDcvz3PFziJqTo-xXTjQ=htrvRv0==f=gzS8ZYHMLyQ@mail.gmail.com
 
Old 07-09-2012, 07:48 PM
john Culleton
 
Default kde daemon crashes

On Mon, 9 Jul 2012 21:26:32 +0200
Jacopo Nespolo <j.nespolo@gmail.com> wrote:

> Hi
>
> On 9 July 2012 20:32, Robert van den Berg <vandenberg.ra78@gmail.com>
> wrote:
> > Maybe you suffer from the same bug. Workarounds can be found here:
> > https://bugs.kde.org/show_bug.cgi?id=209975#c99 ,
> > https://bugs.kde.org/show_bug.cgi?id=209975#c103 ,
> > https://bugs.kde.org/show_bug.cgi?id=209975#c117 . And it's either
> > to run as root alsactl init, or installing alsa-utils, or run as
> > root alsaconf.
>
> I arrived to the same bug, too. The problem is i don't have any trace
> of ALSA, and i kind of like it that way cause i think phonon+pulse+vlc
> is a far superior combination in many aspects (but this is mostly on
> my personal experience rather than any technical knowledge of what
> happens under the hood).
>
> Anyway, if kmix needed alsa-utils to work properly, i think we should
> eventually file a bug in debian and have dependencies fixed, shouldn't
> we?
>
> cheers,
> j
>
>

Debian doesn't create KDE. KDE is a separate software product
with its own bug roporting system. Note the bug reports listed
above.

BTW KDE has gone down hill of late. It gets as many complaints as
Vista it seems. My solution is simple. I use Trinity which is a
clone of KDE 3.5. Try it, you might like it (or not.)


--
John Culleton
Free list of books for self-publishers:
http://wexfordpress.net/shortlist.html
Police Procedural and Expose: "Death Wore Black"
"Create Book Covers with Scribus"
http://www.booklocker.com/books/4055.html


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120709154801.1f3c46b4@sda3.wexfordpress.net">htt p://lists.debian.org/20120709154801.1f3c46b4@sda3.wexfordpress.net
 
Old 07-09-2012, 07:54 PM
hrvojes
 
Default kde daemon crashes

On Monday 09 of July 2012 15:48:01 john Culleton wrote:
> On Mon, 9 Jul 2012 21:26:32 +0200
>
> Jacopo Nespolo <j.nespolo@gmail.com> wrote:
> > Hi
> >
> > On 9 July 2012 20:32, Robert van den Berg <vandenberg.ra78@gmail.com>
> >
> > wrote:
> > > Maybe you suffer from the same bug. Workarounds can be found here:
> > > https://bugs.kde.org/show_bug.cgi?id=209975#c99 ,
> > > https://bugs.kde.org/show_bug.cgi?id=209975#c103 ,
> > > https://bugs.kde.org/show_bug.cgi?id=209975#c117 . And it's either
> > > to run as root alsactl init, or installing alsa-utils, or run as
> > > root alsaconf.
> >
> > I arrived to the same bug, too. The problem is i don't have any trace
> >
> > of ALSA, and i kind of like it that way cause i think phonon+pulse+vlc
> > is a far superior combination in many aspects (but this is mostly on
> > my personal experience rather than any technical knowledge of what
> > happens under the hood).
> >
> > Anyway, if kmix needed alsa-utils to work properly, i think we should
> > eventually file a bug in debian and have dependencies fixed, shouldn't
> > we?
> >
> > cheers,
> > j
>
> Debian doesn't create KDE. KDE is a separate software product
> with its own bug roporting system. Note the bug reports listed
> above.
>
> BTW KDE has gone down hill of late. It gets as many complaints as
> Vista it seems. My solution is simple. I use Trinity which is a
> clone of KDE 3.5. Try it, you might like it (or not.)
Yes, the obvious solution is moving to obsoleted DE.

@Jacopo, i would indeed create a bugreport, with, what i have seen, patch that
solves the crashes.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/4651722.SrgseWvjSN@shumarija
 

Thread Tools




All times are GMT. The time now is 12:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org