FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 05-19-2012, 04:46 PM
Han Wen
 
Default amarok in kde 4.8.3

Hi all,

I just upgrade to kde 4.8.3 and like it a lot except I can't use amarok anymore. At startup it says

The amarok database reported the following errors:******************************************* **********************


GREPME MySQLe query failed! (2000)* on init********************************************** **************************
In most cases you will need to resolve these errors before Amarok will run properly.

Can anyone confirm this?


I am running on sid with only two 3th party repo: qt-kde and debian-multimedia. No pinning.

Thanks.
 
Old 05-19-2012, 04:56 PM
Diederik de Haas
 
Default amarok in kde 4.8.3

On Saturday 19 May 2012 18:46:00 Han Wen wrote:
> Hi all,
>
> I just upgrade to kde 4.8.3 and like it a lot except I can't use amarok
> anymore. At startup it says
>
> The amarok database reported the following
> errors:
> GREPME MySQLe query failed! (2000) on
> init
>
> In most cases you will need to resolve these errors before Amarok will run
> properly.
>
> Can anyone confirm this?

I can confirm this. The exact error msg I get is:
The amarok database reported the following errors:
GREPME MySQLe query failed! (2000) Fatal error: Can't open and lock privilege tables: Table
'mysql.host' doesn't exist on init
In most cases you will need to resolve these errors before Amarok will run properly.

After having clicked the error msg away, I can use amarok though.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201205191856.54970.didi.debian@cknow.org">http://lists.debian.org/201205191856.54970.didi.debian@cknow.org
 
Old 05-19-2012, 05:04 PM
Modestas Vainius
 
Default amarok in kde 4.8.3

Hello,

On šeštadienis 19 Gegužė 2012 19:46:00 Han Wen wrote:
> Hi all,
>
> I just upgrade to kde 4.8.3 and like it a lot except I can't use amarok
> anymore. At startup it says
>
> The amarok database reported the following
> errors:
> GREPME MySQLe query failed! (2000) on
> init
>

It's http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672207
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673403 and friends. It has
nothing to do with KDE 4.8.3 but rather with MySQL 5.5 having replaced MySQL
5.1 on your system.

--
Modestas Vainius <modax@debian.org>
 
Old 05-19-2012, 05:28 PM
Diederik de Haas
 
Default amarok in kde 4.8.3

On Saturday 19 May 2012 19:04:46 Modestas Vainius wrote:
> Hello,
>
> It's http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672207
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673403 and friends. It has
> nothing to do with KDE 4.8.3 but rather with MySQL 5.5 having replaced
> MySQL 5.1 on your system.

Yup. I did upgrade to 5.5 before the upgrade.
The 'fix' I found in bug 673403 (mkdir /etc/mysql/conf.d) solved the issue for me too.

Diederik


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201205191928.09890.didi.debian@cknow.org">http://lists.debian.org/201205191928.09890.didi.debian@cknow.org
 
Old 05-19-2012, 06:05 PM
Han Wen
 
Default amarok in kde 4.8.3

Thank you so much. "mkdir /etc/mysql/conf.d" fix the problem.

On Sat, May 19, 2012 at 1:04 PM, Modestas Vainius <modax@debian.org> wrote:

Hello,



On šeštadienis 19 Gegužė 2012 19:46:00 Han Wen wrote:

> Hi all,

>

> I just upgrade to kde 4.8.3 and like it a lot except I can't use amarok

> anymore. At startup it says

>

> The amarok database reported the following

> errors:

> GREPME MySQLe query failed! (2000) *on

> init

>



It's http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672207

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673403 and friends. It has

nothing to do with KDE 4.8.3 but rather with MySQL 5.5 having replaced MySQL

5.1 on your system.



--

Modestas Vainius <modax@debian.org>
 
Old 05-20-2012, 07:39 AM
Martin Steigerwald
 
Default amarok in kde 4.8.3

Am Samstag, 19. Mai 2012 schrieb Diederik de Haas:
> On Saturday 19 May 2012 19:04:46 Modestas Vainius wrote:
> > Hello,
> >
> > It's http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672207
> > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673403 and friends.
> > It has nothing to do with KDE 4.8.3 but rather with MySQL 5.5 having
> > replaced MySQL 5.1 on your system.
>
> Yup. I did upgrade to 5.5 before the upgrade.
> The 'fix' I found in bug 673403 (mkdir /etc/mysql/conf.d) solved the
> issue for me too.



I reported this on Amarok mailing list as well and asked whether there are
any upstream bugs involved that Amarok team wants me to report. And least
I think a better error message would be in order. And Amarok only being
SIGKILL-able isnt that nice either.

--
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA B82F 991B EAAC A599 84C7


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201205200939.17464.Martin@lichtvoll.de">http://lists.debian.org/201205200939.17464.Martin@lichtvoll.de
 

Thread Tools




All times are GMT. The time now is 10:02 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org