Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian KDE (http://www.linux-archive.org/debian-kde/)
-   -   libsolidcontrol4 vs libsolidcontrol4a (http://www.linux-archive.org/debian-kde/430070-libsolidcontrol4-vs-libsolidcontrol4a.html)

Diederik de Haas 09-21-2010 09:44 PM

libsolidcontrol4 vs libsolidcontrol4a
 
Hello all,

Since about a week ago I have 2 upgrades being held back since it breaks stuff and "aptitude -s full-
upgrade" suggests removing kde-plasma-desktop among other things. Of course that's not what I want.
I have libsolidcontrol4a installed and that conflicts with libsolidcontrol4, which wants to be
installed for an upgrade of plasma-widget-networkmanagement to which I recently switched on George's
recommendation/mail.
A similar conflict exists for libsolidcontrolifaces4 vs libsolidcontrolifaces4a (which is installed).

I have KDE 4.5.1 from http://qt-kde.debian.net/

What to do about it?

Regards,
Diederik


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009212344.09137.didi.debian@cknow.org">http://lists.debian.org/201009212344.09137.didi.debian@cknow.org

George Kiagiadakis 09-21-2010 09:57 PM

libsolidcontrol4 vs libsolidcontrol4a
 
On Wed, Sep 22, 2010 at 12:44 AM, Diederik de Haas
<didi.debian@cknow.org> wrote:
> Hello all,
>
> Since about a week ago I have 2 upgrades being held back since it breaks stuff and "aptitude -s full-
> upgrade" suggests removing kde-plasma-desktop among other things. Of course that's not what I want.
> I have libsolidcontrol4a installed and that conflicts with libsolidcontrol4, which wants to be
> installed for an upgrade of plasma-widget-networkmanagement to which I recently switched on George's
> recommendation/mail.
> A similar conflict exists for libsolidcontrolifaces4 vs libsolidcontrolifaces4a (which is installed).
>
> I have KDE 4.5.1 from http://qt-kde.debian.net/
>
> What to do about it?
>

I have an updated version of plasma-widget-networkmanagement in the
qt-kde.debian.net repository that uses the new version of
libsolidcontrol. Normally, aptitude should upgrade it without any
problem.

Btw, are you also getting trouble with libkwebkit1? We had another guy
in irc a few days ago having a similar problem and it seems that
libkwebkit1 was confusing aptitude (since this package is not
trivially upgradeable...)


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTinumbh4bh21cH8qTQNX8KxfGXdjjv+ExrSmr0CK@mail .gmail.com">http://lists.debian.org/AANLkTinumbh4bh21cH8qTQNX8KxfGXdjjv+ExrSmr0CK@mail .gmail.com

Diederik de Haas 09-21-2010 10:25 PM

libsolidcontrol4 vs libsolidcontrol4a
 
On Tuesday 21 September 2010 23:57:28 George Kiagiadakis wrote:
> I have an updated version of plasma-widget-networkmanagement in the
> qt-kde.debian.net repository that uses the new version of
> libsolidcontrol. Normally, aptitude should upgrade it without any
> problem.
And that version is what caused the issue with me.
But I've found the solution: "aptitude -s full-upgrade -t experimental-snapshots" does give a good
upgrade path :-)

> Btw, are you also getting trouble with libkwebkit1?
No.

Thanks for the help and sorry about the noise.

Diederik


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009220025.56291.didi.debian@cknow.org">http://lists.debian.org/201009220025.56291.didi.debian@cknow.org


All times are GMT. The time now is 09:44 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.