Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian KDE (http://www.linux-archive.org/debian-kde/)
-   -   Multiple monitors bug in KDE 4.5.1 (http://www.linux-archive.org/debian-kde/426714-multiple-monitors-bug-kde-4-5-1-a.html)

Lisandro Damián Nicanor Pérez Meyer 09-14-2010 03:08 AM

Multiple monitors bug in KDE 4.5.1
 
Hello! While I am sure this is an upstream "bug" (it may be a new kind of
feature...), I would like to know if I am not alone in this one :)

Since I upgraded to 4.5.1, every time I use my laptop with an external
monitor, defining it at the top, the panel and the plasmoids "move" to the
upper screen instead of staying in the bottom.

I just want to know if anyone else can reproduce this behaviour.

Regards, Lisandro.

--
UNIX is basically a simple operating system, but you have to be a
genius to understand the simplicity.
Dennis Ritchie

Lisandro Damián Nicanor Pérez Meyer
http://perezmeyer.com.ar/
http://perezmeyer.blogspot.com/

Kyle Kearney 09-14-2010 08:14 AM

Multiple monitors bug in KDE 4.5.1
 
I have the same problem (well, with left vs. right monitors, but a similar issue with the plasmoids moving to the external monitor). I did a bit of quick googling and from what I was able to gather it looks like it's an upstream bug. The workaround that I found was to configure the displays from the command line using xrandr (I've got an intel card - I'm not sure if this procedure holds for other vendors such as nVidia; IIRC they have their own configuration system for multiple displays) using the following (slightly modified to match your configuration)
xrandr --output VGA1 --mode 1440x900 --output LVDS1 --primary --below VGA1

You'll want to replace the mode value with the actual resolution of your external monitor (this may not be strictly necessary, but I found that if I didn't include it the external display would sometimes get initialized to the same resolution as the laptop display), and potentially replace VGA1 and LVDS1 with the actual names for your external and built-in display (respectively) if they differ.

Hope this helps...and I'd love it if someone knows of a way to automatically run this when I plug in my external monitor (bonus points if you can also tell me a way to automatically reduce the desktop back to one display when I unplug)

On Monday 13 September 2010 8:08:23 pm Lisandro Damián Nicanor Pérez Meyer wrote:
> Hello! While I am sure this is an upstream "bug" (it may be a new kind of
> feature...), I would like to know if I am not alone in this one :)
>
> Since I upgraded to 4.5.1, every time I use my laptop with an external
> monitor, defining it at the top, the panel and the plasmoids "move" to the
> upper screen instead of staying in the bottom.
>
> I just want to know if anyone else can reproduce this behaviour.
>
> Regards, Lisandro.
>
>


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009140114.30248.elyk53@gmail.com">http://lists.debian.org/201009140114.30248.elyk53@gmail.com

Lisandro Damián Nicanor Pérez Meyer 09-14-2010 12:50 PM

Multiple monitors bug in KDE 4.5.1
 
On Mar 14 Sep 2010 05:14:29 Kyle Kearney escribió:
> I have the same problem (well, with left vs. right monitors, but a similar
> issue with the plasmoids moving to the external monitor). I did a bit of
> quick googling and from what I was able to gather it looks like it's an
> upstream bug. The workaround that I found was to configure the displays
> from the command line using xrandr (I've got an intel card - I'm not sure
> if this procedure holds for other vendors such as nVidia; IIRC they have
> their own configuration system for multiple displays) using the following
> (slightly modified to match your configuration) xrandr --output VGA1
> --mode 1440x900 --output LVDS1 --primary --below VGA1

I did it by hand with the same results, but I was missing --primeary stuff.

Thanks :)

Do you know if the bug is already open upstream?

--
Super cow powers | bbq > /dev/stomach
Traveler1, seen on #debian-ar, irc.oftc.net

Lisandro Damián Nicanor Pérez Meyer
http://perezmeyer.com.ar/
http://perezmeyer.blogspot.com/

Facundo Aguilera 09-22-2010 05:51 PM

Multiple monitors bug in KDE 4.5.1
 
El Martes 14 Septiembre 2010 09:50:08 Lisandro Damián Nicanor Pérez Meyer
<perezmeyer@gmail.com> escribió:
> On Mar 14 Sep 2010 05:14:29 Kyle Kearney escribió:
> > I have the same problem (well, with left vs. right monitors, but a
> > similar issue with the plasmoids moving to the external monitor). I did
> > a bit of quick googling and from what I was able to gather it looks like
> > it's an upstream bug. The workaround that I found was to configure the
> > displays from the command line using xrandr (I've got an intel card -
> > I'm not sure if this procedure holds for other vendors such as nVidia;
> > IIRC they have their own configuration system for multiple displays)
> > using the following (slightly modified to match your configuration)
> > xrandr --output VGA1 --mode 1440x900 --output LVDS1 --primary --below
> > VGA1
>
> I did it by hand with the same results, but I was missing --primeary stuff.
>
> Thanks :)
>
> Do you know if the bug is already open upstream?

Same problem here.
Have you reported the bug?

fa


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009221451.37887.budinero@gmail.com">http://lists.debian.org/201009221451.37887.budinero@gmail.com


All times are GMT. The time now is 12:59 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.